B := $(BUILD_DIR)
D := $(CURDIR)/debian/mutt
-# Comment this line if you want the header cache with gdbm
-HCACHE_WITH_DB := --without-gdbm
+# Comment this line if you want the header cache with qdbm or gdbm
+HCACHE_WITH_DB := --without-qdbm --without-gdbm
clean:
$(MAKE) -f debian/sys-build.mk source.clean
$B/stamp-h.in $B/config.h.in
touch $@
+ # update config.guess and config.sub
+ -test -r /usr/share/misc/config.sub && \
+ cp -f /usr/share/misc/config.sub $B/config.sub
+ -test -r /usr/share/misc/config.guess && \
+ cp -f /usr/share/misc/config.guess $B/config.guess
+
configure: $(STAMP_DIR)/configure
$(STAMP_DIR)/configure: $(STAMP_DIR)/source.make
+ CPPFLAGS=-I/usr/include/qdbm \
CC=cc ac_cv_path_ISPELL=ispell \
SENDMAIL=/usr/sbin/sendmail PERL=/usr/bin/perl \
$(MAKE) -f debian/sys-build.mk source.command SOURCE_CMD=" \
--with-sharedir=/usr/share/mutt --with-docdir=/usr/share/doc \
--with-mailpath=/var/mail \
--enable-fcntl --enable-pop --enable-imap \
- --with-mixmaster --with-sasl2 --with-idn \
+ --with-mixmaster --with-sasl --with-idn \
--with-curses \
--with-gnutls \
--enable-debug \
$B/contrib/*rc $B/contrib/sample.muttrc-tlr \
extra/ray.muttrc extra/colors.angdraug
dh_installman \
- $B/doc/mutt.man $B/doc/dotlock.man \
+ $B/doc/mutt.1 $B/doc/dotlock.man \
$B/doc/muttrc.man $B/doc/mbox.man
install --mode=755 extra/debian-ldap-query extra/mailspell \