]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/trash-folder
upstream/544794-smtp-batch.patch: mutt won't ask for a password if smtp_user and...
[software/mutt-debian.git] / debian / patches / features / trash-folder
index a8c3722483d0f442f6a4740f8e467ec164a349f4..b8711756f008dab38c9119f249f863242b45ccc8 100644 (file)
@@ -46,11 +46,11 @@ To sum up, it's more integrated and transparent to the user.
   - Fixed indentation of "appended" in mutt.h.
 
 == END PATCH
   - Fixed indentation of "appended" in mutt.h.
 
 == END PATCH
-Index: trash/commands.c
+Index: mutt/commands.c
 ===================================================================
 ===================================================================
---- trash.orig/commands.c      2006-12-12 14:15:02.000000000 +0100
-+++ trash/commands.c   2007-02-15 19:34:10.324888040 +0100
-@@ -690,6 +690,7 @@ int _mutt_save_message (HEADER *h, CONTE
+--- mutt.orig/commands.c       2009-06-25 12:35:37.000000000 +0200
++++ mutt/commands.c    2009-06-25 12:35:48.000000000 +0200
+@@ -716,6 +716,7 @@
      if (option (OPTDELETEUNTAG))
        mutt_set_flag (Context, h, M_TAG, 0);
    }
      if (option (OPTDELETEUNTAG))
        mutt_set_flag (Context, h, M_TAG, 0);
    }
@@ -58,14 +58,14 @@ Index: trash/commands.c
    
    return 0;
  }
    
    return 0;
  }
-Index: trash/flags.c
+Index: mutt/flags.c
 ===================================================================
 ===================================================================
---- trash.orig/flags.c 2006-12-12 14:15:02.000000000 +0100
-+++ trash/flags.c      2007-02-15 19:34:10.325887888 +0100
-@@ -66,7 +66,13 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
-       else if (h->deleted)
+--- mutt.orig/flags.c  2009-06-25 12:35:37.000000000 +0200
++++ mutt/flags.c       2009-06-25 12:35:48.000000000 +0200
+@@ -65,7 +65,13 @@
        {
        h->deleted = 0;
        {
        h->deleted = 0;
+         update = 1;
 -      if (upd_ctx) ctx->deleted--;
 +      if (upd_ctx)
 +      {
 -      if (upd_ctx) ctx->deleted--;
 +      if (upd_ctx)
 +      {
@@ -77,7 +77,7 @@ Index: trash/flags.c
  #ifdef USE_IMAP
          /* see my comment above */
        if (ctx->magic == M_IMAP) 
  #ifdef USE_IMAP
          /* see my comment above */
        if (ctx->magic == M_IMAP) 
-@@ -88,6 +94,17 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+@@ -87,6 +93,17 @@
        }
        break;
  
        }
        break;
  
@@ -95,23 +95,23 @@ Index: trash/flags.c
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
-Index: trash/globals.h
+Index: mutt/globals.h
 ===================================================================
 ===================================================================
---- trash.orig/globals.h       2007-01-04 15:23:49.000000000 +0100
-+++ trash/globals.h    2007-02-15 19:34:10.325887888 +0100
-@@ -135,6 +135,7 @@ WHERE char *StChars;
+--- mutt.orig/globals.h        2009-06-25 12:35:44.000000000 +0200
++++ mutt/globals.h     2009-06-25 12:35:48.000000000 +0200
+@@ -139,6 +139,7 @@
  WHERE char *Status;
  WHERE char *Tempdir;
  WHERE char *Tochars;
 +WHERE char *TrashPath;
  WHERE char *Username;
  WHERE char *Visual;
  WHERE char *Status;
  WHERE char *Tempdir;
  WHERE char *Tochars;
 +WHERE char *TrashPath;
  WHERE char *Username;
  WHERE char *Visual;
-Index: trash/imap/message.c
+ WHERE char *XtermTitle;
+Index: mutt/imap/message.c
 ===================================================================
 ===================================================================
---- trash.orig/imap/message.c  2007-02-14 15:32:38.000000000 +0100
-+++ trash/imap/message.c       2007-02-15 19:34:10.325887888 +0100
-@@ -817,6 +817,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+--- mutt.orig/imap/message.c   2009-06-25 12:35:37.000000000 +0200
++++ mutt/imap/message.c        2009-06-25 12:35:48.000000000 +0200
+@@ -867,6 +867,7 @@
          if (ctx->hdrs[n]->tagged)
          {
            mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
          if (ctx->hdrs[n]->tagged)
          {
            mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
@@ -119,7 +119,7 @@ Index: trash/imap/message.c
            if (option (OPTDELETEUNTAG))
              mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
          }
            if (option (OPTDELETEUNTAG))
              mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
          }
-@@ -824,6 +825,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+@@ -874,6 +875,7 @@
      else
      {
        mutt_set_flag (ctx, h, M_DELETE, 1);
      else
      {
        mutt_set_flag (ctx, h, M_DELETE, 1);
@@ -127,13 +127,13 @@ Index: trash/imap/message.c
        if (option (OPTDELETEUNTAG))
          mutt_set_flag (ctx, h, M_TAG, 0);
      }
        if (option (OPTDELETEUNTAG))
          mutt_set_flag (ctx, h, M_TAG, 0);
      }
-Index: trash/init.h
+Index: mutt/init.h
 ===================================================================
 ===================================================================
---- trash.orig/init.h  2006-12-12 14:15:03.000000000 +0100
-+++ trash/init.h       2007-02-15 19:34:10.326887736 +0100
-@@ -2808,6 +2808,16 @@ struct option_t MuttVars[] = {
+--- mutt.orig/init.h   2009-06-25 12:35:44.000000000 +0200
++++ mutt/init.h        2009-06-25 12:35:48.000000000 +0200
+@@ -3180,6 +3180,16 @@
    ** by \fIyou\fP.  The sixth character is used to indicate when a mail
    ** by \fIyou\fP.  The sixth character is used to indicate when a mail
-   ** was sent to a mailing-list you subscribe to (default: L).
+   ** was sent to a mailing-list you subscribe to.
    */
 +  { "trash",          DT_PATH, R_NONE, UL &TrashPath, 0 },
 +  /*
    */
 +  { "trash",          DT_PATH, R_NONE, UL &TrashPath, 0 },
 +  /*
@@ -148,11 +148,11 @@ Index: trash/init.h
  #ifdef USE_SOCKET
    { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
    /*
  #ifdef USE_SOCKET
    { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
    /*
-Index: trash/mutt.h
+Index: mutt/mutt.h
 ===================================================================
 ===================================================================
---- trash.orig/mutt.h  2007-01-04 15:23:49.000000000 +0100
-+++ trash/mutt.h       2007-02-15 19:34:10.327887584 +0100
-@@ -200,6 +200,7 @@ enum
+--- mutt.orig/mutt.h   2009-06-25 12:35:44.000000000 +0200
++++ mutt/mutt.h        2009-06-25 12:35:48.000000000 +0200
+@@ -187,6 +187,7 @@
    M_DELETE,
    M_UNDELETE,
    M_DELETED,
    M_DELETE,
    M_UNDELETE,
    M_DELETED,
@@ -160,7 +160,7 @@ Index: trash/mutt.h
    M_FLAG,
    M_TAG,
    M_UNTAG,
    M_FLAG,
    M_TAG,
    M_UNTAG,
-@@ -703,6 +704,7 @@ typedef struct header
+@@ -702,6 +703,7 @@
    unsigned int mime : 1;              /* has a MIME-Version header? */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int mime : 1;              /* has a MIME-Version header? */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
@@ -168,19 +168,19 @@ Index: trash/mutt.h
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
-@@ -873,6 +875,7 @@ typedef struct
+@@ -874,6 +876,7 @@
    int new;                    /* how many new messages? */
    int unread;                 /* how many unread messages? */
    int deleted;                        /* how many deleted messages */
 +  int appended;                 /* how many saved messages? */
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
    int new;                    /* how many new messages? */
    int unread;                 /* how many unread messages? */
    int deleted;                        /* how many deleted messages */
 +  int appended;                 /* how many saved messages? */
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
- #if defined USE_POP || defined USE_IMAP
-Index: trash/muttlib.c
+Index: mutt/muttlib.c
 ===================================================================
 ===================================================================
---- trash.orig/muttlib.c       2007-01-04 15:23:50.000000000 +0100
-+++ trash/muttlib.c    2007-02-15 19:34:10.327887584 +0100
-@@ -1265,7 +1265,9 @@ int mutt_save_confirm (const char *s, st
+--- mutt.orig/muttlib.c        2009-06-25 12:35:37.000000000 +0200
++++ mutt/muttlib.c     2009-06-25 12:35:48.000000000 +0200
+@@ -1460,7 +1460,9 @@
  
    if (magic > 0 && !mx_access (s, W_OK))
    {
  
    if (magic > 0 && !mx_access (s, W_OK))
    {
@@ -191,11 +191,11 @@ Index: trash/muttlib.c
      {
        snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
        if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
      {
        snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
        if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
-Index: trash/mx.c
+Index: mutt/mx.c
 ===================================================================
 ===================================================================
---- trash.orig/mx.c    2006-12-12 14:15:03.000000000 +0100
-+++ trash/mx.c 2007-02-15 19:34:10.328887432 +0100
-@@ -822,6 +822,53 @@ static int sync_mailbox (CONTEXT *ctx, i
+--- mutt.orig/mx.c     2009-06-25 12:35:37.000000000 +0200
++++ mutt/mx.c  2009-06-25 12:35:48.000000000 +0200
+@@ -773,6 +773,53 @@
    return rc;
  }
  
    return rc;
  }
  
@@ -249,7 +249,7 @@ Index: trash/mx.c
  /* save changes and close mailbox */
  int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
  {
  /* save changes and close mailbox */
  int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
  {
-@@ -957,6 +1004,7 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -909,6 +956,7 @@
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
          {
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
          {
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
@@ -257,12 +257,12 @@ Index: trash/mx.c
          }
          else
          {
          }
          else
          {
-@@ -978,6 +1026,14 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -931,6 +979,14 @@
      return 0;
    }
    
 +  /* copy mails to the trash before expunging */
      return 0;
    }
    
 +  /* copy mails to the trash before expunging */
-+  if (purge && ctx->deleted)
++  if (purge && ctx->deleted && mutt_strcmp(ctx->path, TrashPath))
 +    if (trash_append (ctx) != 0)
 +    {
 +      ctx->closing = 0;
 +    if (trash_append (ctx) != 0)
 +    {
 +      ctx->closing = 0;
@@ -272,24 +272,24 @@ Index: trash/mx.c
  #ifdef USE_IMAP
    /* allow IMAP to preserve the deleted flag across sessions */
    if (ctx->magic == M_IMAP)
  #ifdef USE_IMAP
    /* allow IMAP to preserve the deleted flag across sessions */
    if (ctx->magic == M_IMAP)
-@@ -1173,6 +1229,12 @@ int mx_sync_mailbox (CONTEXT *ctx, int *
+@@ -1130,6 +1186,12 @@
    msgcount = ctx->msgcount;
    deleted = ctx->deleted;
  
    msgcount = ctx->msgcount;
    deleted = ctx->deleted;
  
-+  if (purge && ctx->deleted)
++  if (purge && ctx->deleted && mutt_strcmp(ctx->path, TrashPath))
 +  {
 +    if (trash_append (ctx) == -1)
 +      return -1;
 +  {
 +    if (trash_append (ctx) == -1)
 +      return -1;
-+  } 
++  }
 +
  #ifdef USE_IMAP
    if (ctx->magic == M_IMAP)
      rc = imap_sync_mailbox (ctx, purge, index_hint);
 +
  #ifdef USE_IMAP
    if (ctx->magic == M_IMAP)
      rc = imap_sync_mailbox (ctx, purge, index_hint);
-Index: trash/postpone.c
+Index: mutt/postpone.c
 ===================================================================
 ===================================================================
---- trash.orig/postpone.c      2006-12-12 14:15:03.000000000 +0100
-+++ trash/postpone.c   2007-02-15 19:34:10.328887432 +0100
-@@ -279,6 +279,9 @@ int mutt_get_postponed (CONTEXT *ctx, HE
+--- mutt.orig/postpone.c       2009-06-25 12:35:37.000000000 +0200
++++ mutt/postpone.c    2009-06-25 12:35:48.000000000 +0200
+@@ -276,6 +276,9 @@
    /* finished with this message, so delete it. */
    mutt_set_flag (PostContext, h, M_DELETE, 1);
  
    /* finished with this message, so delete it. */
    mutt_set_flag (PostContext, h, M_DELETE, 1);
  
@@ -299,9 +299,3 @@ Index: trash/postpone.c
    /* update the count for the status display */
    PostCount = PostContext->msgcount - PostContext->deleted;
  
    /* update the count for the status display */
    PostCount = PostContext->msgcount - PostContext->deleted;
  
-Index: trash/PATCHES
-===================================================================
---- trash/PATCHES.orig 2007-02-15 19:35:06.277381968 +0100
-+++ trash/PATCHES      2007-02-15 19:35:06.277381968 +0100
-@@ -0,0 +1 @@
-+patch-1.5.13.cd.trash_folder.3.4