]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/trash-folder
Refresh the remaining patches
[software/mutt-debian.git] / debian / patches / features / trash-folder
index a8c3722483d0f442f6a4740f8e467ec164a349f4..489672b17a363310ccf09c0634579bd1047e298e 100644 (file)
@@ -46,11 +46,9 @@ To sum up, it's more integrated and transparent to the user.
   - Fixed indentation of "appended" in mutt.h.
 
 == END PATCH
   - Fixed indentation of "appended" in mutt.h.
 
 == END PATCH
-Index: trash/commands.c
-===================================================================
---- trash.orig/commands.c      2006-12-12 14:15:02.000000000 +0100
-+++ trash/commands.c   2007-02-15 19:34:10.324888040 +0100
-@@ -690,6 +690,7 @@ int _mutt_save_message (HEADER *h, CONTE
+--- a/commands.c
++++ b/commands.c
+@@ -688,6 +688,7 @@ int _mutt_save_message (HEADER *h, CONTE
      if (option (OPTDELETEUNTAG))
        mutt_set_flag (Context, h, M_TAG, 0);
    }
      if (option (OPTDELETEUNTAG))
        mutt_set_flag (Context, h, M_TAG, 0);
    }
@@ -58,14 +56,12 @@ Index: trash/commands.c
    
    return 0;
  }
    
    return 0;
  }
-Index: trash/flags.c
-===================================================================
---- trash.orig/flags.c 2006-12-12 14:15:02.000000000 +0100
-+++ trash/flags.c      2007-02-15 19:34:10.325887888 +0100
-@@ -66,7 +66,13 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
-       else if (h->deleted)
+--- a/flags.c
++++ b/flags.c
+@@ -69,7 +69,13 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
        {
        h->deleted = 0;
        {
        h->deleted = 0;
+         update = 1;
 -      if (upd_ctx) ctx->deleted--;
 +      if (upd_ctx)
 +      {
 -      if (upd_ctx) ctx->deleted--;
 +      if (upd_ctx)
 +      {
@@ -77,7 +73,7 @@ Index: trash/flags.c
  #ifdef USE_IMAP
          /* see my comment above */
        if (ctx->magic == M_IMAP) 
  #ifdef USE_IMAP
          /* see my comment above */
        if (ctx->magic == M_IMAP) 
-@@ -88,6 +94,17 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+@@ -91,6 +97,17 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
        }
        break;
  
        }
        break;
  
@@ -95,23 +91,19 @@ Index: trash/flags.c
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
-Index: trash/globals.h
-===================================================================
---- trash.orig/globals.h       2007-01-04 15:23:49.000000000 +0100
-+++ trash/globals.h    2007-02-15 19:34:10.325887888 +0100
-@@ -135,6 +135,7 @@ WHERE char *StChars;
+--- a/globals.h
++++ b/globals.h
+@@ -142,6 +142,7 @@ WHERE char *StChars;
  WHERE char *Status;
  WHERE char *Tempdir;
  WHERE char *Tochars;
 +WHERE char *TrashPath;
  WHERE char *Username;
  WHERE char *Visual;
  WHERE char *Status;
  WHERE char *Tempdir;
  WHERE char *Tochars;
 +WHERE char *TrashPath;
  WHERE char *Username;
  WHERE char *Visual;
-Index: trash/imap/message.c
-===================================================================
---- trash.orig/imap/message.c  2007-02-14 15:32:38.000000000 +0100
-+++ trash/imap/message.c       2007-02-15 19:34:10.325887888 +0100
-@@ -817,6 +817,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+ WHERE char *XtermTitle;
+--- a/imap/message.c
++++ b/imap/message.c
+@@ -816,6 +816,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
          if (ctx->hdrs[n]->tagged)
          {
            mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
          if (ctx->hdrs[n]->tagged)
          {
            mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
@@ -119,7 +111,7 @@ Index: trash/imap/message.c
            if (option (OPTDELETEUNTAG))
              mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
          }
            if (option (OPTDELETEUNTAG))
              mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
          }
-@@ -824,6 +825,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+@@ -823,6 +824,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
      else
      {
        mutt_set_flag (ctx, h, M_DELETE, 1);
      else
      {
        mutt_set_flag (ctx, h, M_DELETE, 1);
@@ -127,11 +119,9 @@ Index: trash/imap/message.c
        if (option (OPTDELETEUNTAG))
          mutt_set_flag (ctx, h, M_TAG, 0);
      }
        if (option (OPTDELETEUNTAG))
          mutt_set_flag (ctx, h, M_TAG, 0);
      }
-Index: trash/init.h
-===================================================================
---- trash.orig/init.h  2006-12-12 14:15:03.000000000 +0100
-+++ trash/init.h       2007-02-15 19:34:10.326887736 +0100
-@@ -2808,6 +2808,16 @@ struct option_t MuttVars[] = {
+--- a/init.h
++++ b/init.h
+@@ -2881,6 +2881,16 @@ struct option_t MuttVars[] = {
    ** by \fIyou\fP.  The sixth character is used to indicate when a mail
    ** was sent to a mailing-list you subscribe to (default: L).
    */
    ** by \fIyou\fP.  The sixth character is used to indicate when a mail
    ** was sent to a mailing-list you subscribe to (default: L).
    */
@@ -148,11 +138,9 @@ Index: trash/init.h
  #ifdef USE_SOCKET
    { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
    /*
  #ifdef USE_SOCKET
    { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
    /*
-Index: trash/mutt.h
-===================================================================
---- trash.orig/mutt.h  2007-01-04 15:23:49.000000000 +0100
-+++ trash/mutt.h       2007-02-15 19:34:10.327887584 +0100
-@@ -200,6 +200,7 @@ enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -201,6 +201,7 @@ enum
    M_DELETE,
    M_UNDELETE,
    M_DELETED,
    M_DELETE,
    M_UNDELETE,
    M_DELETED,
@@ -160,7 +148,7 @@ Index: trash/mutt.h
    M_FLAG,
    M_TAG,
    M_UNTAG,
    M_FLAG,
    M_TAG,
    M_UNTAG,
-@@ -703,6 +704,7 @@ typedef struct header
+@@ -712,6 +713,7 @@ typedef struct header
    unsigned int mime : 1;              /* has a MIME-Version header? */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int mime : 1;              /* has a MIME-Version header? */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
@@ -168,19 +156,17 @@ Index: trash/mutt.h
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
-@@ -873,6 +875,7 @@ typedef struct
+@@ -883,6 +885,7 @@ typedef struct _context
    int new;                    /* how many new messages? */
    int unread;                 /* how many unread messages? */
    int deleted;                        /* how many deleted messages */
 +  int appended;                 /* how many saved messages? */
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
    int new;                    /* how many new messages? */
    int unread;                 /* how many unread messages? */
    int deleted;                        /* how many deleted messages */
 +  int appended;                 /* how many saved messages? */
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
- #if defined USE_POP || defined USE_IMAP
-Index: trash/muttlib.c
-===================================================================
---- trash.orig/muttlib.c       2007-01-04 15:23:50.000000000 +0100
-+++ trash/muttlib.c    2007-02-15 19:34:10.327887584 +0100
-@@ -1265,7 +1265,9 @@ int mutt_save_confirm (const char *s, st
+--- a/muttlib.c
++++ b/muttlib.c
+@@ -1430,7 +1430,9 @@ int mutt_save_confirm (const char *s, st
  
    if (magic > 0 && !mx_access (s, W_OK))
    {
  
    if (magic > 0 && !mx_access (s, W_OK))
    {
@@ -191,11 +177,9 @@ Index: trash/muttlib.c
      {
        snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
        if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
      {
        snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
        if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
-Index: trash/mx.c
-===================================================================
---- trash.orig/mx.c    2006-12-12 14:15:03.000000000 +0100
-+++ trash/mx.c 2007-02-15 19:34:10.328887432 +0100
-@@ -822,6 +822,53 @@ static int sync_mailbox (CONTEXT *ctx, i
+--- a/mx.c
++++ b/mx.c
+@@ -803,6 +803,53 @@ static int sync_mailbox (CONTEXT *ctx, i
    return rc;
  }
  
    return rc;
  }
  
@@ -249,7 +233,7 @@ Index: trash/mx.c
  /* save changes and close mailbox */
  int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
  {
  /* save changes and close mailbox */
  int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
  {
-@@ -957,6 +1004,7 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -938,6 +985,7 @@ int mx_close_mailbox (CONTEXT *ctx, int 
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
          {
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
          {
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
@@ -257,7 +241,7 @@ Index: trash/mx.c
          }
          else
          {
          }
          else
          {
-@@ -978,6 +1026,14 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -959,6 +1007,14 @@ int mx_close_mailbox (CONTEXT *ctx, int 
      return 0;
    }
    
      return 0;
    }
    
@@ -272,7 +256,7 @@ Index: trash/mx.c
  #ifdef USE_IMAP
    /* allow IMAP to preserve the deleted flag across sessions */
    if (ctx->magic == M_IMAP)
  #ifdef USE_IMAP
    /* allow IMAP to preserve the deleted flag across sessions */
    if (ctx->magic == M_IMAP)
-@@ -1173,6 +1229,12 @@ int mx_sync_mailbox (CONTEXT *ctx, int *
+@@ -1154,6 +1210,12 @@ int mx_sync_mailbox (CONTEXT *ctx, int *
    msgcount = ctx->msgcount;
    deleted = ctx->deleted;
  
    msgcount = ctx->msgcount;
    deleted = ctx->deleted;
  
@@ -285,10 +269,8 @@ Index: trash/mx.c
  #ifdef USE_IMAP
    if (ctx->magic == M_IMAP)
      rc = imap_sync_mailbox (ctx, purge, index_hint);
  #ifdef USE_IMAP
    if (ctx->magic == M_IMAP)
      rc = imap_sync_mailbox (ctx, purge, index_hint);
-Index: trash/postpone.c
-===================================================================
---- trash.orig/postpone.c      2006-12-12 14:15:03.000000000 +0100
-+++ trash/postpone.c   2007-02-15 19:34:10.328887432 +0100
+--- a/postpone.c
++++ b/postpone.c
 @@ -279,6 +279,9 @@ int mutt_get_postponed (CONTEXT *ctx, HE
    /* finished with this message, so delete it. */
    mutt_set_flag (PostContext, h, M_DELETE, 1);
 @@ -279,6 +279,9 @@ int mutt_get_postponed (CONTEXT *ctx, HE
    /* finished with this message, so delete it. */
    mutt_set_flag (PostContext, h, M_DELETE, 1);
@@ -299,9 +281,9 @@ Index: trash/postpone.c
    /* update the count for the status display */
    PostCount = PostContext->msgcount - PostContext->deleted;
  
    /* update the count for the status display */
    PostCount = PostContext->msgcount - PostContext->deleted;
  
-Index: trash/PATCHES
-===================================================================
---- trash/PATCHES.orig 2007-02-15 19:35:06.277381968 +0100
-+++ trash/PATCHES      2007-02-15 19:35:06.277381968 +0100
-@@ -0,0 +1 @@
+--- a/PATCHES
++++ b/PATCHES
+@@ -1,2 +1,3 @@
 +patch-1.5.13.cd.trash_folder.3.4
 +patch-1.5.13.cd.trash_folder.3.4
+ patch-1.5.13.nt+ab.xtitles.4
+ patch-1.5.13.cd.ifdef.2