]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
mutt (1.5.14+cvs20070315-1) experimental; urgency=low
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 600200adca3f62cc9d64847b83d2f2bcca9c6c7b..288ab6f830fd46017543071613fffdb42de79636 100644 (file)
@@ -7,23 +7,21 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2005-09-29
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.11.rr.compressed.1.gz
+  - Date: 2007-03-13
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.14.rr.compressed.1.gz
 
 * Changes made:
   - filterdiff -p1 \
     $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
 
 * Changes made:
   - filterdiff -p1 \
     $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - adjust the init.h hunk to the presence of group & ungroup
-  - 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
-  - 2006-08-16: adjust Makefile.am mutt-1.5.13
+  - 2007-03-13 myon: update for 1.5.14+tip (conflict in hook.c)
 
 == END PATCH
 
 == END PATCH
-Index: compress.c
+Index: mutt/compress.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ compress.c 2007-02-16 01:59:20.562597888 +0100
-@@ -0,0 +1,487 @@
++++ mutt/compress.c    2007-03-13 20:59:30.000000000 +0100
+@@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -130,7 +128,19 @@ Index: compress.c
 +  int magic;
 +
 +  if (is_new (path))
 +  int magic;
 +
 +  if (is_new (path))
-+    return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  {
++    char *dir_path = safe_strdup(path);
++    char *aux = strrchr(dir_path, '/');
++    int dir_valid = 1;
++    if (aux)
++    {
++      *aux='\0';
++      if (access(dir_path, W_OK|X_OK))
++        dir_valid = 0;
++    }
++    safe_free((void**)&dir_path);
++    return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  }
 +
 +  magic = mx_get_magic (path);
 +
 +
 +  magic = mx_get_magic (path);
 +
@@ -511,10 +521,10 @@ Index: compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
 +}
 +
 +#endif /* USE_COMPRESSED */
-Index: compress.h
+Index: mutt/compress.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ compress.h 2007-02-16 01:59:20.562597888 +0100
++++ mutt/compress.h    2007-03-13 20:59:30.000000000 +0100
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -543,11 +553,11 @@ Index: compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-Index: configure.in
+Index: mutt/configure.in
 ===================================================================
 ===================================================================
---- configure.in.orig  2007-02-16 01:59:04.810992496 +0100
-+++ configure.in       2007-02-16 01:59:20.563597736 +0100
-@@ -801,6 +801,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- mutt.orig/configure.in     2007-03-13 20:53:07.000000000 +0100
++++ mutt/configure.in  2007-03-13 20:59:30.000000000 +0100
+@@ -807,6 +807,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -559,10 +569,10 @@ Index: configure.in
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: curs_main.c
+Index: mutt/curs_main.c
 ===================================================================
 ===================================================================
---- curs_main.c.orig   2007-02-16 01:59:04.853985960 +0100
-+++ curs_main.c        2007-02-16 01:59:20.563597736 +0100
+--- mutt.orig/curs_main.c      2007-03-13 20:53:07.000000000 +0100
++++ mutt/curs_main.c   2007-03-13 20:59:30.000000000 +0100
 @@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
          {
          int check;
 @@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
          {
          int check;
@@ -575,13 +585,13 @@ Index: curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-Index: doc/manual.xml.head
+Index: mutt/doc/manual.xml.head
 ===================================================================
 ===================================================================
---- doc/manual.xml.head.orig   2007-02-16 01:59:04.898979120 +0100
-+++ doc/manual.xml.head        2007-02-16 01:59:20.566597280 +0100
-@@ -4749,6 +4749,205 @@ becomes an issue as mutt will silently f
+--- mutt.orig/doc/manual.xml.head      2007-03-13 20:53:07.000000000 +0100
++++ mutt/doc/manual.xml.head   2007-03-13 20:59:30.000000000 +0100
+@@ -4843,6 +4843,205 @@ becomes an issue as mutt will silently f
  
  
- </sect1>
+ </chapter>
  
 +<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
  
 +<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
@@ -782,13 +792,13 @@ Index: doc/manual.xml.head
 +</sect2>
 +</sect1>
 +
 +</sect2>
 +</sect1>
 +
- </chapter>
  <chapter id="mimesupport">
  <chapter id="mimesupport">
-Index: doc/muttrc.man.head
+ <title>Mutt's MIME Support</title>
+Index: mutt/doc/muttrc.man.head
 ===================================================================
 ===================================================================
---- doc/muttrc.man.head.orig   2007-02-16 01:59:04.942972432 +0100
-+++ doc/muttrc.man.head        2007-02-16 01:59:20.567597128 +0100
+--- mutt.orig/doc/muttrc.man.head      2007-03-13 20:53:07.000000000 +0100
++++ mutt/doc/muttrc.man.head   2007-03-13 20:59:30.000000000 +0100
 @@ -316,6 +316,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
 @@ -316,6 +316,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
@@ -814,10 +824,10 @@ Index: doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-Index: hook.c
+Index: mutt/hook.c
 ===================================================================
 ===================================================================
---- hook.c.orig        2007-02-16 01:59:04.986965744 +0100
-+++ hook.c     2007-02-16 01:59:20.567597128 +0100
+--- mutt.orig/hook.c   2007-03-13 20:53:07.000000000 +0100
++++ mutt/hook.c        2007-03-13 21:00:40.000000000 +0100
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -843,30 +853,30 @@ Index: hook.c
 +    }
 +  }
 +#endif
 +    }
 +  }
 +#endif
-   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
+   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-Index: init.h
+Index: mutt/init.h
 ===================================================================
 ===================================================================
---- init.h.orig        2007-02-16 01:59:05.029959208 +0100
-+++ init.h     2007-02-16 01:59:20.568596976 +0100
-@@ -3067,6 +3067,11 @@ struct command_t Commands[] = {
+--- mutt.orig/init.h   2007-03-13 20:53:07.000000000 +0100
++++ mutt/init.h        2007-03-13 20:59:30.000000000 +0100
+@@ -3167,6 +3167,11 @@ struct command_t Commands[] = {
+   { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
+   { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
+   { "group",          parse_group,            0 },
+   { "ungroup",                parse_ungroup,          0 },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
- #ifdef HAVE_ICONV
-   { "iconv-hook",     mutt_parse_hook,        M_ICONVHOOK }, 
-Index: main.c
+Index: mutt/main.c
 ===================================================================
 ===================================================================
---- main.c.orig        2007-02-16 01:59:05.073952520 +0100
-+++ main.c     2007-02-16 01:59:20.569596824 +0100
-@@ -398,6 +398,12 @@ static void show_version (void)
+--- mutt.orig/main.c   2007-03-13 20:53:07.000000000 +0100
++++ mutt/main.c        2007-03-13 20:59:30.000000000 +0100
+@@ -404,6 +404,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
  #endif
  #else
        "-LOCALES_HACK  "
  #endif
@@ -879,10 +889,10 @@ Index: main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-Index: Makefile.am
+Index: mutt/Makefile.am
 ===================================================================
 ===================================================================
---- Makefile.am.orig   2007-02-16 01:59:05.117945832 +0100
-+++ Makefile.am        2007-02-16 01:59:20.569596824 +0100
+--- mutt.orig/Makefile.am      2007-03-13 20:53:07.000000000 +0100
++++ mutt/Makefile.am   2007-03-13 20:59:30.000000000 +0100
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
@@ -892,7 +902,7 @@ Index: Makefile.am
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -67,7 +67,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
        utf8.c wcwidth.c 
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
        utf8.c wcwidth.c 
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
@@ -901,10 +911,10 @@ Index: Makefile.am
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: mbox.c
+Index: mutt/mbox.c
 ===================================================================
 ===================================================================
---- mbox.c.orig        2007-02-16 01:59:05.160939296 +0100
-+++ mbox.c     2007-02-16 01:59:20.569596824 +0100
+--- mutt.orig/mbox.c   2007-03-13 20:53:07.000000000 +0100
++++ mutt/mbox.c        2007-03-13 20:59:30.000000000 +0100
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -929,10 +939,10 @@ Index: mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-Index: mutt.h
+Index: mutt/mutt.h
 ===================================================================
 ===================================================================
---- mutt.h.orig        2007-02-16 01:59:05.203932760 +0100
-+++ mutt.h     2007-02-16 01:59:20.570596672 +0100
+--- mutt.orig/mutt.h   2007-03-13 20:53:07.000000000 +0100
++++ mutt/mutt.h        2007-03-13 20:59:30.000000000 +0100
 @@ -159,6 +159,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
 @@ -159,6 +159,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
@@ -945,7 +955,7 @@ Index: mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -879,6 +884,11 @@ typedef struct
+@@ -882,6 +887,11 @@ typedef struct
    void *data;                 /* driver specific data */
  #endif /* USE_IMAP */
  
    void *data;                 /* driver specific data */
  #endif /* USE_IMAP */
  
@@ -957,10 +967,10 @@ Index: mutt.h
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
-Index: mx.c
+Index: mutt/mx.c
 ===================================================================
 ===================================================================
---- mx.c.orig  2007-02-16 01:59:05.247926072 +0100
-+++ mx.c       2007-02-16 01:59:20.571596520 +0100
+--- mutt.orig/mx.c     2007-03-13 20:53:07.000000000 +0100
++++ mutt/mx.c  2007-03-13 20:59:30.000000000 +0100
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -983,9 +993,9 @@ Index: mx.c
    return (magic);
  }
  
    return (magic);
  }
  
-@@ -493,6 +501,13 @@ static int mx_open_mailbox_append (CONTE
- {
+@@ -494,6 +502,13 @@ static int mx_open_mailbox_append (CONTE
    struct stat sb;
    struct stat sb;
+   mode_t omask;
  
 +#ifdef USE_COMPRESSED
 +  /* special case for appending to compressed folders -
  
 +#ifdef USE_COMPRESSED
 +  /* special case for appending to compressed folders -
@@ -997,7 +1007,7 @@ Index: mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -656,7 +671,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -664,7 +679,12 @@ CONTEXT *mx_open_mailbox (const char *pa
    }
  
    ctx->magic = mx_get_magic (path);
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1011,7 +1021,7 @@ Index: mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -762,6 +782,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -770,6 +790,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1022,7 +1032,7 @@ Index: mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -819,6 +843,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -827,6 +851,12 @@ static int sync_mailbox (CONTEXT *ctx, i
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
  #endif
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
  #endif
@@ -1035,7 +1045,7 @@ Index: mx.c
    return rc;
  }
  
    return rc;
  }
  
-@@ -1020,6 +1050,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -1028,6 +1058,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1047,7 +1057,7 @@ Index: mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1329,6 +1364,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
+@@ -1342,6 +1377,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
  {
    int rc;
  
  {
    int rc;
  
@@ -1059,10 +1069,10 @@ Index: mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-Index: mx.h
+Index: mutt/mx.h
 ===================================================================
 ===================================================================
---- mx.h.orig  2007-02-16 01:59:05.289919688 +0100
-+++ mx.h       2007-02-16 01:59:20.571596520 +0100
+--- mutt.orig/mx.h     2007-03-13 20:53:07.000000000 +0100
++++ mutt/mx.h  2007-03-13 20:59:30.000000000 +0100
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
@@ -1073,16 +1083,16 @@ Index: mx.h
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: PATCHES
+Index: mutt/PATCHES
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ PATCHES    2007-02-16 01:59:50.727012200 +0100
++++ mutt/PATCHES       2007-03-13 20:59:30.000000000 +0100
 @@ -0,0 +1 @@
 @@ -0,0 +1 @@
-+patch-1.5.11.rr.compressed.1
-Index: po/de.po
++patch-1.5.14.rr.compressed.1
+Index: mutt/po/de.po
 ===================================================================
 ===================================================================
---- po/de.po.orig      2007-02-16 01:59:05.375906616 +0100
-+++ po/de.po   2007-02-16 01:59:20.572596368 +0100
+--- mutt.orig/po/de.po 2007-03-13 20:53:07.000000000 +0100
++++ mutt/po/de.po      2007-03-13 20:59:30.000000000 +0100
 @@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
 @@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
@@ -1132,7 +1142,7 @@ Index: po/de.po
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
-@@ -1892,6 +1934,10 @@ msgstr ""
+@@ -1926,6 +1968,10 @@ msgstr ""
  msgid "Help for %s"
  msgstr "Hilfe für %s"
  
  msgid "Help for %s"
  msgstr "Hilfe für %s"
  
@@ -1143,29 +1153,29 @@ Index: po/de.po
  #: hook.c:246
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
  #: hook.c:246
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
-@@ -3392,18 +3438,10 @@ msgstr "Lese %s... %d (%d%%)"
+@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
--#: mbox.c:662
+-#: mbox.c:670
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
- #: mbox.c:701 mbox.c:952
+ #: mbox.c:711 mbox.c:964
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
--#: mbox.c:710
+-#: mbox.c:720
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
-Index: po/POTFILES.in
+Index: mutt/po/POTFILES.in
 ===================================================================
 ===================================================================
---- po/POTFILES.in.orig        2007-02-16 01:59:05.419899928 +0100
-+++ po/POTFILES.in     2007-02-16 01:59:20.573596216 +0100
+--- mutt.orig/po/POTFILES.in   2007-03-13 20:53:07.000000000 +0100
++++ mutt/po/POTFILES.in        2007-03-13 20:59:30.000000000 +0100
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
@@ -1174,10 +1184,10 @@ Index: po/POTFILES.in
  crypt-gpgme.c
  crypt.c
  cryptglue.c
  crypt-gpgme.c
  crypt.c
  cryptglue.c
-Index: status.c
+Index: mutt/status.c
 ===================================================================
 ===================================================================
---- status.c.orig      2007-02-16 01:59:05.465892936 +0100
-+++ status.c   2007-02-16 01:59:20.573596216 +0100
+--- mutt.orig/status.c 2007-03-13 20:53:07.000000000 +0100
++++ mutt/status.c      2007-03-13 20:59:30.000000000 +0100
 @@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':
 @@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':