]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
new upstream release, patches refreshed
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 600200adca3f62cc9d64847b83d2f2bcca9c6c7b..dc2c38e0ad171a6000752ab56204561882e80ab8 100644 (file)
@@ -7,23 +7,19 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2005-09-29
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.11.rr.compressed.1.gz
+  - Date: 2008-05-20
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
 
 * Changes made:
-  - filterdiff -p1 \
-    $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
-      doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - adjust the init.h hunk to the presence of group & ungroup
-  - 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
-  - 2006-08-16: adjust Makefile.am mutt-1.5.13
+  - 2008-05-20 myon: refreshed to remove hunks in auto* files
+  - 2009-09-15 myon: refreshed for mutt-1.5.19
+                     status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
+  - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
 
 == END PATCH
-Index: compress.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ compress.c 2007-02-16 01:59:20.562597888 +0100
-@@ -0,0 +1,487 @@
+--- /dev/null
++++ b/compress.c
+@@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -130,7 +126,19 @@ Index: compress.c
 +  int magic;
 +
 +  if (is_new (path))
-+    return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  {
++    char *dir_path = safe_strdup(path);
++    char *aux = strrchr(dir_path, '/');
++    int dir_valid = 1;
++    if (aux)
++    {
++      *aux='\0';
++      if (access(dir_path, W_OK|X_OK))
++        dir_valid = 0;
++    }
++    safe_free((void**)&dir_path);
++    return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  }
 +
 +  magic = mx_get_magic (path);
 +
@@ -184,10 +192,10 @@ Index: compress.c
 +}
 +
 +static const char *
-+compresshook_format_str (char *dest, size_t destlen, char op, const char *src,
-+                       const char *fmt, const char *ifstring,
-+                       const char *elsestring, unsigned long data,
-+                       format_flag flags)
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
++                       const char *src, const char *fmt,
++                       const char *ifstring, const char *elsestring,
++                       unsigned long data, format_flag flags)
 +{
 +  char tmp[SHORT_STRING];
 +
@@ -218,8 +226,8 @@ Index: compress.c
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
-+  mutt_FormatString (expanded, sizeof (expanded), cmd, compresshook_format_str,
-+                   (unsigned long) ctx, 0);
++  mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
++                   compresshook_format_str, (unsigned long) ctx, 0);
 +  return safe_strdup (expanded);
 +}
 +
@@ -245,7 +253,7 @@ Index: compress.c
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
@@ -290,7 +298,7 @@ Index: compress.c
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
@@ -358,8 +366,8 @@ Index: compress.c
 +      fclose (ctx->fp);
 +    ctx->fp = NULL;
 +    /* if the folder was removed, remove the gzipped folder too */
-+    if ((ctx->magic > 0) 
-+      && (access (ctx->path, F_OK) != 0) 
++    if ((ctx->magic > 0)
++      && (access (ctx->path, F_OK) != 0)
 +      && ! option (OPTSAVEEMPTY))
 +      remove (ctx->realpath);
 +    else
@@ -438,7 +446,7 @@ Index: compress.c
 +  if (! (ctx->append
 +       && ((append = get_append_command (ctx->realpath, ctx))
 +           || (append = ci->close))))
-+  { 
++  {
 +    /* if we can not or should not append, we only have to remove the */
 +    /* compressed info, because sync was already called               */
 +    mutt_fast_close_compressed (ctx);
@@ -511,10 +519,8 @@ Index: compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
-Index: compress.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ compress.h 2007-02-16 01:59:20.562597888 +0100
+--- /dev/null
++++ b/compress.h
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -543,11 +549,9 @@ Index: compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-Index: configure.in
-===================================================================
---- configure.in.orig  2007-02-16 01:59:04.810992496 +0100
-+++ configure.in       2007-02-16 01:59:20.563597736 +0100
-@@ -801,6 +801,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- a/configure.ac
++++ b/configure.ac
+@@ -805,6 +805,11 @@
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -559,11 +563,9 @@ Index: configure.in
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: curs_main.c
-===================================================================
---- curs_main.c.orig   2007-02-16 01:59:04.853985960 +0100
-+++ curs_main.c        2007-02-16 01:59:20.563597736 +0100
-@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1135,6 +1135,11 @@
          {
          int check;
  
@@ -575,13 +577,11 @@ Index: curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-Index: doc/manual.xml.head
-===================================================================
---- doc/manual.xml.head.orig   2007-02-16 01:59:04.898979120 +0100
-+++ doc/manual.xml.head        2007-02-16 01:59:20.566597280 +0100
-@@ -4749,6 +4749,205 @@ becomes an issue as mutt will silently f
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -5678,6 +5678,205 @@
  
- </sect1>
+ </chapter>
  
 +<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
@@ -612,9 +612,9 @@ Index: doc/manual.xml.head
 +For example:
 +
 +<screen>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
++open-hook \\.gz$ "gzip -cd %f &gt; %t"
 +close-hook \\.gz$ "gzip -c %t &gt; %f"
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
++append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
 +</screen>
 +
 +You do not have to specify all of the commands. If you omit <link
@@ -662,7 +662,7 @@ Index: doc/manual.xml.head
 +Example:
 +
 +<screen>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
++open-hook \\.gz$ "gzip -cd %f &gt; %t"
 +</screen>
 +
 +If the <emphasis>command</emphasis> is empty, this operation is
@@ -728,7 +728,7 @@ Index: doc/manual.xml.head
 +Example:
 +
 +<screen>
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
++append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
 +</screen>
 +
 +When <link linkend="append-hook">append-hook</link> is used, the folder
@@ -782,14 +782,26 @@ Index: doc/manual.xml.head
 +</sect2>
 +</sect1>
 +
- </chapter>
  <chapter id="mimesupport">
-Index: doc/muttrc.man.head
-===================================================================
---- doc/muttrc.man.head.orig   2007-02-16 01:59:04.942972432 +0100
-+++ doc/muttrc.man.head        2007-02-16 01:59:20.567597128 +0100
-@@ -316,6 +316,24 @@ specify the ID of the public key to be u
+ <title>Mutt's MIME Support</title>
+--- a/doc/Muttrc.head
++++ b/doc/Muttrc.head
+@@ -29,6 +29,11 @@
+ macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
+ bind browser y exit
++# Use folders which match on \\.gz$ as gzipped folders:
++# open-hook \\.gz$ "gzip -cd %f > %t"
++# close-hook \\.gz$ "gzip -c %t > %f"
++# append-hook \\.gz$ "gzip -c %t >> %f"
++
+ # If Mutt is unable to determine your site's domain name correctly, you can
+ # set the default here.
+ #
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
+@@ -345,6 +345,24 @@
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -805,7 +817,7 @@ Index: doc/muttrc.man.head
 +"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
 +(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
 +compressed mail to a compressed folder (\fBappend-hook\fP). The
-+\fIcommand\fP string is the 
++\fIcommand\fP string is the
 +.BR printf (3)
 +like format string, and it should accept two parameters: \fB%f\fP,
 +which is replaced with the (compressed) folder name, and \fB%t\fP
@@ -814,10 +826,8 @@ Index: doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-Index: hook.c
-===================================================================
---- hook.c.orig        2007-02-16 01:59:04.986965744 +0100
-+++ hook.c     2007-02-16 01:59:20.567597128 +0100
+--- a/hook.c
++++ b/hook.c
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -829,7 +839,7 @@ Index: hook.c
  #include <limits.h>
  #include <string.h>
  #include <stdlib.h>
-@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
+@@ -92,6 +96,16 @@
      memset (&pattern, 0, sizeof (pattern));
      pattern.data = safe_strdup (path);
    }
@@ -838,35 +848,31 @@ Index: hook.c
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
-+      strfcpy (err->data, _("bad formatted command string"), err->dsize);
++      strfcpy (err->data, _("badly formatted command string"), err->dsize);
 +      return (-1);
 +    }
 +  }
 +#endif
-   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
+   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-Index: init.h
-===================================================================
---- init.h.orig        2007-02-16 01:59:05.029959208 +0100
-+++ init.h     2007-02-16 01:59:20.568596976 +0100
-@@ -3067,6 +3067,11 @@ struct command_t Commands[] = {
+--- a/init.h
++++ b/init.h
+@@ -3514,6 +3514,11 @@
+   { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
+   { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
+   { "group",          parse_group,            0 },
+   { "ungroup",                parse_ungroup,          0 },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
- #ifdef HAVE_ICONV
-   { "iconv-hook",     mutt_parse_hook,        M_ICONVHOOK }, 
-Index: main.c
-===================================================================
---- main.c.orig        2007-02-16 01:59:05.073952520 +0100
-+++ main.c     2007-02-16 01:59:20.569596824 +0100
-@@ -398,6 +398,12 @@ static void show_version (void)
+--- a/main.c
++++ b/main.c
+@@ -402,6 +402,12 @@
  #else
        "-LOCALES_HACK  "
  #endif
@@ -879,21 +885,19 @@ Index: main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-Index: Makefile.am
-===================================================================
---- Makefile.am.orig   2007-02-16 01:59:05.117945832 +0100
-+++ Makefile.am        2007-02-16 01:59:20.569596824 +0100
-@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,7 +18,7 @@
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
- mutt_SOURCES = $(BUILT_SOURCES) \
+ mutt_SOURCES = \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
 -      crypt.c cryptglue.c \
 +      crypt.c cryptglue.c compress.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -67,7 +67,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
-       utf8.c wcwidth.c 
+@@ -57,7 +57,7 @@
+       bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
 -      configure account.h \
@@ -901,10 +905,8 @@ Index: Makefile.am
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: mbox.c
-===================================================================
---- mbox.c.orig        2007-02-16 01:59:05.160939296 +0100
-+++ mbox.c     2007-02-16 01:59:20.569596824 +0100
+--- a/mbox.c
++++ b/mbox.c
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -916,7 +918,7 @@ Index: mbox.c
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1026,6 +1030,12 @@ bail:  /* Come here in case of disaster 
+@@ -1048,6 +1052,12 @@
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -929,11 +931,9 @@ Index: mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-Index: mutt.h
-===================================================================
---- mutt.h.orig        2007-02-16 01:59:05.203932760 +0100
-+++ mutt.h     2007-02-16 01:59:20.570596672 +0100
-@@ -159,6 +159,11 @@ typedef enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -146,6 +146,11 @@
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
@@ -945,9 +945,9 @@ Index: mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -879,6 +884,11 @@ typedef struct
-   void *data;                 /* driver specific data */
#endif /* USE_IMAP */
+@@ -883,6 +888,11 @@
+   int flagged;                        /* how many flagged messages */
  int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
 +#ifdef USE_COMPRESSED
 +  void *compressinfo;         /* compressed mbox module private data */
@@ -957,10 +957,8 @@ Index: mutt.h
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
-Index: mx.c
-===================================================================
---- mx.c.orig  2007-02-16 01:59:05.247926072 +0100
-+++ mx.c       2007-02-16 01:59:20.571596520 +0100
+--- a/mx.c
++++ b/mx.c
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -972,7 +970,7 @@ Index: mx.c
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -454,6 +458,10 @@ int mx_get_magic (const char *path)
+@@ -415,6 +419,10 @@
      return (-1);
    }
  
@@ -983,7 +981,7 @@ Index: mx.c
    return (magic);
  }
  
-@@ -493,6 +501,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -454,6 +462,13 @@
  {
    struct stat sb;
  
@@ -997,7 +995,7 @@ Index: mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -656,7 +671,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -617,7 +632,12 @@
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1011,7 +1009,7 @@ Index: mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -762,6 +782,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -718,6 +738,10 @@
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1022,10 +1020,10 @@ Index: mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -819,6 +843,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -770,6 +794,12 @@
+   
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
- #endif
 +
 +#ifdef USE_COMPRESSED
 +  if (rc == 0 && ctx->compressinfo)
@@ -1035,7 +1033,7 @@ Index: mx.c
    return rc;
  }
  
-@@ -1020,6 +1050,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -1033,6 +1063,11 @@
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1047,7 +1045,7 @@ Index: mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1329,6 +1364,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
+@@ -1355,6 +1390,11 @@
  {
    int rc;
  
@@ -1059,11 +1057,9 @@ Index: mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-Index: mx.h
-===================================================================
---- mx.h.orig  2007-02-16 01:59:05.289919688 +0100
-+++ mx.h       2007-02-16 01:59:20.571596520 +0100
-@@ -40,6 +40,9 @@ enum
+--- a/mx.h
++++ b/mx.h
+@@ -40,6 +40,9 @@
  #ifdef USE_POP
    , M_POP
  #endif
@@ -1073,20 +1069,24 @@ Index: mx.h
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: PATCHES
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ PATCHES    2007-02-16 01:59:50.727012200 +0100
-@@ -0,0 +1 @@
-+patch-1.5.11.rr.compressed.1
-Index: po/de.po
-===================================================================
---- po/de.po.orig      2007-02-16 01:59:05.375906616 +0100
-+++ po/de.po   2007-02-16 01:59:20.572596368 +0100
-@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
- msgid "Failed to figure out sender"
- msgstr "Kann Absender nicht ermitteln"
+--- a/po/de.po
++++ b/po/de.po
+@@ -2005,6 +2005,10 @@
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
  
++#: hook.c:96
++msgid "badly formatted command string"
++msgstr "Hook enthält nicht die Muster %f und %t"
++
+ #: hook.c:251
+ #, c-format
+ msgid "unhook: Can't do unhook * from within a hook."
+@@ -5378,3 +5382,45 @@
+ #~ msgid "Authentication method is unknown."
+ #~ msgstr "Authentifizierungsmethode unbekannt."
++
 +#: compress.c:203 mbox.c:661
 +msgid "Mailbox was corrupted!"
 +msgstr "Mailbox wurde zerstört!"
@@ -1128,45 +1128,9 @@ Index: po/de.po
 +#, c-format
 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
-+
- #: crypt.c:69
- #, c-format
- msgid " (current time: %c)"
-@@ -1892,6 +1934,10 @@ msgstr ""
- msgid "Help for %s"
- msgstr "Hilfe für %s"
-+#: hook.c:96
-+msgid "bad formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:246
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -3392,18 +3438,10 @@ msgstr "Lese %s... %d (%d%%)"
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
--#: mbox.c:662
--msgid "Mailbox was corrupted!"
--msgstr "Mailbox wurde zerstört!"
--
- #: mbox.c:701 mbox.c:952
- msgid "Fatal error!  Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:710
--msgid "Unable to lock mailbox!"
--msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
--
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted.  This should
- #. * never happen, is we presume it is a bug in mutt.
-Index: po/POTFILES.in
-===================================================================
---- po/POTFILES.in.orig        2007-02-16 01:59:05.419899928 +0100
-+++ po/POTFILES.in     2007-02-16 01:59:20.573596216 +0100
-@@ -8,6 +8,7 @@ charset.c
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -8,6 +8,7 @@
  color.c
  commands.c
  compose.c
@@ -1174,11 +1138,9 @@ Index: po/POTFILES.in
  crypt-gpgme.c
  crypt.c
  cryptglue.c
-Index: status.c
-===================================================================
---- status.c.orig      2007-02-16 01:59:05.465892936 +0100
-+++ status.c   2007-02-16 01:59:20.573596216 +0100
-@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
@@ -1186,10 +1148,15 @@ Index: status.c
 +      if (Context && Context->compressinfo && Context->realpath)
 +      {
 +       strfcpy (tmp, Context->realpath, sizeof (tmp));
-+       mutt_pretty_mailbox (tmp);
++       mutt_pretty_mailbox (tmp, sizeof (tmp));
 +      }
 +      else
 +#endif
        if (Context && Context->path)
        {
        strfcpy (tmp, Context->path, sizeof (tmp));
+--- a/PATCHES
++++ b/PATCHES
+@@ -1 +1,2 @@
++patch-1.5.18.rr.compressed.1
+ patch-1.5.13.cd.ifdef.2