]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
Note bugs fixed currently upstream.
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 600200adca3f62cc9d64847b83d2f2bcca9c6c7b..6dd7a6d22c926d48c2d9cdce939718941f96aff3 100644 (file)
@@ -7,23 +7,18 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2005-09-29
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.11.rr.compressed.1.gz
+  - Date: 2007-06-14
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
 
 * Changes made:
 
 * Changes made:
-  - filterdiff -p1 \
-    $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
-      doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - adjust the init.h hunk to the presence of group & ungroup
-  - 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
-  - 2006-08-16: adjust Makefile.am mutt-1.5.13
+  - 2007-06-14 myon: remove hunks for Muttrc*
 
 == END PATCH
 
 == END PATCH
-Index: compress.c
+Index: debian-mutt/compress.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ compress.c 2007-02-16 01:59:20.562597888 +0100
-@@ -0,0 +1,487 @@
++++ debian-mutt/compress.c     2007-06-14 10:57:02.000000000 +0200
+@@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -130,7 +125,19 @@ Index: compress.c
 +  int magic;
 +
 +  if (is_new (path))
 +  int magic;
 +
 +  if (is_new (path))
-+    return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  {
++    char *dir_path = safe_strdup(path);
++    char *aux = strrchr(dir_path, '/');
++    int dir_valid = 1;
++    if (aux)
++    {
++      *aux='\0';
++      if (access(dir_path, W_OK|X_OK))
++        dir_valid = 0;
++    }
++    safe_free((void**)&dir_path);
++    return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  }
 +
 +  magic = mx_get_magic (path);
 +
 +
 +  magic = mx_get_magic (path);
 +
@@ -184,10 +191,10 @@ Index: compress.c
 +}
 +
 +static const char *
 +}
 +
 +static const char *
-+compresshook_format_str (char *dest, size_t destlen, char op, const char *src,
-+                       const char *fmt, const char *ifstring,
-+                       const char *elsestring, unsigned long data,
-+                       format_flag flags)
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
++                       const char *src, const char *fmt,
++                       const char *ifstring, const char *elsestring,
++                       unsigned long data, format_flag flags)
 +{
 +  char tmp[SHORT_STRING];
 +
 +{
 +  char tmp[SHORT_STRING];
 +
@@ -218,8 +225,8 @@ Index: compress.c
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
-+  mutt_FormatString (expanded, sizeof (expanded), cmd, compresshook_format_str,
-+                   (unsigned long) ctx, 0);
++  mutt_FormatString (expanded, sizeof (expanded), 0, cmd, 
++                   compresshook_format_str, (unsigned long) ctx, 0);
 +  return safe_strdup (expanded);
 +}
 +
 +  return safe_strdup (expanded);
 +}
 +
@@ -245,7 +252,7 @@ Index: compress.c
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
@@ -290,7 +297,7 @@ Index: compress.c
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
@@ -511,10 +518,10 @@ Index: compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
 +}
 +
 +#endif /* USE_COMPRESSED */
-Index: compress.h
+Index: debian-mutt/compress.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ compress.h 2007-02-16 01:59:20.562597888 +0100
++++ debian-mutt/compress.h     2007-06-14 10:57:02.000000000 +0200
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -543,11 +550,55 @@ Index: compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-Index: configure.in
+Index: debian-mutt/config.h.in
+===================================================================
+--- debian-mutt.orig/config.h.in       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/config.h.in    2007-06-14 10:57:02.000000000 +0200
+@@ -513,6 +513,9 @@
+ /* Define to enable Sun mailtool attachments support. */
+ #undef SUN_ATTACHMENT
++/* Define to enable compressed mailboxes support */
++#undef USE_COMPRESSED
++
+ /* Define to use dotlocking for mailboxes. */
+ #undef USE_DOTLOCK
+Index: debian-mutt/configure
+===================================================================
+--- debian-mutt.orig/configure 2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/configure      2007-06-14 10:57:02.000000000 +0200
+@@ -1371,6 +1371,7 @@ Optional Features:
+   --enable-hcache         Enable header caching
+   --disable-iconv         Disable iconv support
+   --disable-nls           Do not use Native Language Support
++  --enable-compressed     Enable compressed folders support
+ Optional Packages:
+   --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
+@@ -15105,6 +15106,17 @@ _ACEOF
+ fi
++# Check whether --enable-compressed or --disable-compressed was given.
++if test "${enable_compressed+set}" = set; then
++  enableval="$enable_compressed"; if test x$enableval = xyes; then
++
++cat >>confdefs.h <<\_ACEOF
++#define USE_COMPRESSED 1
++_ACEOF
++
++        fi
++fi
++
+ # Check whether --with-exec-shell was given.
+ if test "${with_exec_shell+set}" = set; then
+Index: debian-mutt/configure.ac
 ===================================================================
 ===================================================================
---- configure.in.orig  2007-02-16 01:59:04.810992496 +0100
-+++ configure.in       2007-02-16 01:59:20.563597736 +0100
-@@ -801,6 +801,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- debian-mutt.orig/configure.ac      2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/configure.ac   2007-06-14 10:57:02.000000000 +0200
+@@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -559,11 +610,11 @@ Index: configure.in
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: curs_main.c
+Index: debian-mutt/curs_main.c
 ===================================================================
 ===================================================================
---- curs_main.c.orig   2007-02-16 01:59:04.853985960 +0100
-+++ curs_main.c        2007-02-16 01:59:20.563597736 +0100
-@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
+--- debian-mutt.orig/curs_main.c       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/curs_main.c    2007-06-14 10:57:02.000000000 +0200
+@@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
          {
          int check;
  
          {
          int check;
  
@@ -575,13 +626,13 @@ Index: curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-Index: doc/manual.xml.head
+Index: debian-mutt/doc/manual.xml.head
 ===================================================================
 ===================================================================
---- doc/manual.xml.head.orig   2007-02-16 01:59:04.898979120 +0100
-+++ doc/manual.xml.head        2007-02-16 01:59:20.566597280 +0100
-@@ -4749,6 +4749,205 @@ becomes an issue as mutt will silently f
+--- debian-mutt.orig/doc/manual.xml.head       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/doc/manual.xml.head    2007-06-14 10:57:02.000000000 +0200
+@@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
  
  
- </sect1>
+ </chapter>
  
 +<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
  
 +<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
@@ -782,14 +833,14 @@ Index: doc/manual.xml.head
 +</sect2>
 +</sect1>
 +
 +</sect2>
 +</sect1>
 +
- </chapter>
  <chapter id="mimesupport">
  <chapter id="mimesupport">
-Index: doc/muttrc.man.head
+ <title>Mutt's MIME Support</title>
+Index: debian-mutt/doc/muttrc.man.head
 ===================================================================
 ===================================================================
---- doc/muttrc.man.head.orig   2007-02-16 01:59:04.942972432 +0100
-+++ doc/muttrc.man.head        2007-02-16 01:59:20.567597128 +0100
-@@ -316,6 +316,24 @@ specify the ID of the public key to be u
+--- debian-mutt.orig/doc/muttrc.man.head       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/doc/muttrc.man.head    2007-06-14 10:57:02.000000000 +0200
+@@ -345,6 +345,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -814,10 +865,10 @@ Index: doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-Index: hook.c
+Index: debian-mutt/hook.c
 ===================================================================
 ===================================================================
---- hook.c.orig        2007-02-16 01:59:04.986965744 +0100
-+++ hook.c     2007-02-16 01:59:20.567597128 +0100
+--- debian-mutt.orig/hook.c    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/hook.c 2007-06-14 10:57:02.000000000 +0200
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -838,35 +889,35 @@ Index: hook.c
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
-+      strfcpy (err->data, _("bad formatted command string"), err->dsize);
++      strfcpy (err->data, _("badly formatted command string"), err->dsize);
 +      return (-1);
 +    }
 +  }
 +#endif
 +      return (-1);
 +    }
 +  }
 +#endif
-   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
+   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-Index: init.h
+Index: debian-mutt/init.h
 ===================================================================
 ===================================================================
---- init.h.orig        2007-02-16 01:59:05.029959208 +0100
-+++ init.h     2007-02-16 01:59:20.568596976 +0100
-@@ -3067,6 +3067,11 @@ struct command_t Commands[] = {
+--- debian-mutt.orig/init.h    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/init.h 2007-06-14 10:57:02.000000000 +0200
+@@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
+   { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
+   { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
+   { "group",          parse_group,            0 },
+   { "ungroup",                parse_ungroup,          0 },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
- #ifdef HAVE_ICONV
-   { "iconv-hook",     mutt_parse_hook,        M_ICONVHOOK }, 
-Index: main.c
+Index: debian-mutt/main.c
 ===================================================================
 ===================================================================
---- main.c.orig        2007-02-16 01:59:05.073952520 +0100
-+++ main.c     2007-02-16 01:59:20.569596824 +0100
-@@ -398,6 +398,12 @@ static void show_version (void)
+--- debian-mutt.orig/main.c    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/main.c 2007-06-14 10:57:02.000000000 +0200
+@@ -401,6 +401,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
  #endif
  #else
        "-LOCALES_HACK  "
  #endif
@@ -879,10 +930,10 @@ Index: main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-Index: Makefile.am
+Index: debian-mutt/Makefile.am
 ===================================================================
 ===================================================================
---- Makefile.am.orig   2007-02-16 01:59:05.117945832 +0100
-+++ Makefile.am        2007-02-16 01:59:20.569596824 +0100
+--- debian-mutt.orig/Makefile.am       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/Makefile.am    2007-06-14 10:57:02.000000000 +0200
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
@@ -892,7 +943,7 @@ Index: Makefile.am
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -67,7 +67,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
        utf8.c wcwidth.c 
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
        utf8.c wcwidth.c 
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
@@ -901,10 +952,49 @@ Index: Makefile.am
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: mbox.c
+Index: debian-mutt/Makefile.in
 ===================================================================
 ===================================================================
---- mbox.c.orig        2007-02-16 01:59:05.160939296 +0100
-+++ mbox.c     2007-02-16 01:59:20.569596824 +0100
+--- debian-mutt.orig/Makefile.in       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/Makefile.in    2007-06-14 10:57:02.000000000 +0200
+@@ -74,7 +74,7 @@ am_mutt_OBJECTS = $(am__objects_1) addrb
+       attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
+       buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
+       cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
+-      compose.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
++      compose.$(OBJEXT) compress.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
+       curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
+       enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
+       filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
+@@ -302,7 +302,7 @@ bin_SCRIPTS = muttbug flea @SMIMEAUX_TAR
+ BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h hcversion.h
+ mutt_SOURCES = $(BUILT_SOURCES) \
+       addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
+-      crypt.c cryptglue.c \
++      crypt.c cryptglue.c compress.c \
+       commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
+       edit.c enter.c flags.c init.c filter.c from.c \
+       getdomain.c group.c \
+@@ -335,7 +335,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+       utf8.c wcwidth.c 
+ EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
+-      configure account.h \
++      configure account.h compress.h \
+       attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
+       globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
+       mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
+@@ -507,6 +507,7 @@ distclean-compile:
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/commands.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/complete.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compose.Po@am__quote@
++@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/copy.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-gpgme.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-mod-pgp-classic.Po@am__quote@
+Index: debian-mutt/mbox.c
+===================================================================
+--- debian-mutt.orig/mbox.c    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mbox.c 2007-06-14 10:57:02.000000000 +0200
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -929,11 +1019,11 @@ Index: mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-Index: mutt.h
+Index: debian-mutt/mutt.h
 ===================================================================
 ===================================================================
---- mutt.h.orig        2007-02-16 01:59:05.203932760 +0100
-+++ mutt.h     2007-02-16 01:59:20.570596672 +0100
-@@ -159,6 +159,11 @@ typedef enum
+--- debian-mutt.orig/mutt.h    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mutt.h 2007-06-14 10:57:02.000000000 +0200
+@@ -160,6 +160,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
@@ -945,9 +1035,9 @@ Index: mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -879,6 +884,11 @@ typedef struct
-   void *data;                 /* driver specific data */
#endif /* USE_IMAP */
+@@ -885,6 +890,11 @@ typedef struct _context
+   int flagged;                        /* how many flagged messages */
  int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
 +#ifdef USE_COMPRESSED
 +  void *compressinfo;         /* compressed mbox module private data */
  
 +#ifdef USE_COMPRESSED
 +  void *compressinfo;         /* compressed mbox module private data */
@@ -957,10 +1047,10 @@ Index: mutt.h
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
-Index: mx.c
+Index: debian-mutt/mx.c
 ===================================================================
 ===================================================================
---- mx.c.orig  2007-02-16 01:59:05.247926072 +0100
-+++ mx.c       2007-02-16 01:59:20.571596520 +0100
+--- debian-mutt.orig/mx.c      2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mx.c   2007-06-14 10:57:02.000000000 +0200
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -972,7 +1062,7 @@ Index: mx.c
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -454,6 +458,10 @@ int mx_get_magic (const char *path)
+@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
      return (-1);
    }
  
      return (-1);
    }
  
@@ -983,7 +1073,7 @@ Index: mx.c
    return (magic);
  }
  
    return (magic);
  }
  
-@@ -493,6 +501,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
  {
    struct stat sb;
  
  {
    struct stat sb;
  
@@ -997,7 +1087,7 @@ Index: mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -656,7 +671,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
    }
  
    ctx->magic = mx_get_magic (path);
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1011,7 +1101,7 @@ Index: mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -762,6 +782,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -753,6 +773,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1022,10 +1112,10 @@ Index: mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -819,6 +843,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -805,6 +829,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+   
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
- #endif
 +
 +#ifdef USE_COMPRESSED
 +  if (rc == 0 && ctx->compressinfo)
 +
 +#ifdef USE_COMPRESSED
 +  if (rc == 0 && ctx->compressinfo)
@@ -1035,7 +1125,7 @@ Index: mx.c
    return rc;
  }
  
    return rc;
  }
  
-@@ -1020,6 +1050,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -1006,6 +1036,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1047,7 +1137,7 @@ Index: mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1329,6 +1364,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
+@@ -1315,6 +1350,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
  {
    int rc;
  
  {
    int rc;
  
@@ -1059,10 +1149,10 @@ Index: mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-Index: mx.h
+Index: debian-mutt/mx.h
 ===================================================================
 ===================================================================
---- mx.h.orig  2007-02-16 01:59:05.289919688 +0100
-+++ mx.h       2007-02-16 01:59:20.571596520 +0100
+--- debian-mutt.orig/mx.h      2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mx.h   2007-06-14 10:57:02.000000000 +0200
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
@@ -1073,17 +1163,17 @@ Index: mx.h
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: PATCHES
+Index: debian-mutt/PATCHES
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ PATCHES    2007-02-16 01:59:50.727012200 +0100
++++ debian-mutt/PATCHES        2007-06-14 10:57:02.000000000 +0200
 @@ -0,0 +1 @@
 @@ -0,0 +1 @@
-+patch-1.5.11.rr.compressed.1
-Index: po/de.po
++patch-1.5.16.rr.compressed.1
+Index: debian-mutt/po/de.po
 ===================================================================
 ===================================================================
---- po/de.po.orig      2007-02-16 01:59:05.375906616 +0100
-+++ po/de.po   2007-02-16 01:59:20.572596368 +0100
-@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
+--- debian-mutt.orig/po/de.po  2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/po/de.po       2007-06-14 10:57:02.000000000 +0200
+@@ -1279,6 +1279,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
@@ -1132,40 +1222,40 @@ Index: po/de.po
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
-@@ -1892,6 +1934,10 @@ msgstr ""
- msgid "Help for %s"
- msgstr "Hilfe für %s"
+@@ -1948,6 +1990,10 @@ msgstr "Hilfe für %s"
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
  
 +#: hook.c:96
  
 +#: hook.c:96
-+msgid "bad formatted command string"
++msgid "badly formatted command string"
 +msgstr "Hook enthält nicht die Muster %f und %t"
 +
 +msgstr "Hook enthält nicht die Muster %f und %t"
 +
- #: hook.c:246
+ #: hook.c:251
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
-@@ -3392,18 +3438,10 @@ msgstr "Lese %s... %d (%d%%)"
+@@ -3452,18 +3498,10 @@ msgstr "Lese %s..."
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
--#: mbox.c:662
+-#: mbox.c:670
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
- #: mbox.c:701 mbox.c:952
+ #: mbox.c:711 mbox.c:964
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
--#: mbox.c:710
+-#: mbox.c:720
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
-Index: po/POTFILES.in
+Index: debian-mutt/po/POTFILES.in
 ===================================================================
 ===================================================================
---- po/POTFILES.in.orig        2007-02-16 01:59:05.419899928 +0100
-+++ po/POTFILES.in     2007-02-16 01:59:20.573596216 +0100
+--- debian-mutt.orig/po/POTFILES.in    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/po/POTFILES.in 2007-06-14 10:57:02.000000000 +0200
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
@@ -1174,11 +1264,11 @@ Index: po/POTFILES.in
  crypt-gpgme.c
  crypt.c
  cryptglue.c
  crypt-gpgme.c
  crypt.c
  cryptglue.c
-Index: status.c
+Index: debian-mutt/status.c
 ===================================================================
 ===================================================================
---- status.c.orig      2007-02-16 01:59:05.465892936 +0100
-+++ status.c   2007-02-16 01:59:20.573596216 +0100
-@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
+--- debian-mutt.orig/status.c  2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/status.c       2007-06-14 10:57:02.000000000 +0200
+@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);