Index: compress.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ compress.c 2007-02-16 01:59:20.562597888 +0100
++++ compress.c 2007-03-01 22:30:00.101678680 +0100
@@ -0,0 +1,487 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
Index: compress.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ compress.h 2007-02-16 01:59:20.562597888 +0100
++++ compress.h 2007-03-01 22:30:00.101678680 +0100
@@ -0,0 +1,27 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+void mutt_fast_close_compressed (CONTEXT *);
Index: configure.in
===================================================================
---- configure.in.orig 2007-02-16 01:59:04.810992496 +0100
-+++ configure.in 2007-02-16 01:59:20.563597736 +0100
-@@ -801,6 +801,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- configure.in.orig 2007-03-01 22:20:42.248485256 +0100
++++ configure.in 2007-03-01 22:30:00.102678528 +0100
+@@ -808,6 +808,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
Index: curs_main.c
===================================================================
---- curs_main.c.orig 2007-02-16 01:59:04.853985960 +0100
-+++ curs_main.c 2007-02-16 01:59:20.563597736 +0100
+--- curs_main.c.orig 2007-03-01 22:08:47.806097008 +0100
++++ curs_main.c 2007-03-01 22:30:00.102678528 +0100
@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
{
int check;
Index: doc/manual.xml.head
===================================================================
---- doc/manual.xml.head.orig 2007-02-16 01:59:04.898979120 +0100
-+++ doc/manual.xml.head 2007-02-16 01:59:20.566597280 +0100
+--- doc/manual.xml.head.orig 2007-03-01 22:08:47.852090016 +0100
++++ doc/manual.xml.head 2007-03-01 22:30:00.106677920 +0100
@@ -4749,6 +4749,205 @@ becomes an issue as mutt will silently f
</sect1>
<chapter id="mimesupport">
Index: doc/muttrc.man.head
===================================================================
---- doc/muttrc.man.head.orig 2007-02-16 01:59:04.942972432 +0100
-+++ doc/muttrc.man.head 2007-02-16 01:59:20.567597128 +0100
+--- doc/muttrc.man.head.orig 2007-03-01 22:08:47.900082720 +0100
++++ doc/muttrc.man.head 2007-03-01 22:30:00.106677920 +0100
@@ -316,6 +316,24 @@ specify the ID of the public key to be u
to a certain recipient. The meaning of "key ID" is to be taken
broadly: This can be a different e-mail address, a numerical key ID,
This command adds the named \fIstring\fP to the keyboard buffer.
Index: hook.c
===================================================================
---- hook.c.orig 2007-02-16 01:59:04.986965744 +0100
-+++ hook.c 2007-02-16 01:59:20.567597128 +0100
+--- hook.c.orig 2007-03-01 22:08:47.947075576 +0100
++++ hook.c 2007-03-01 22:30:00.107677768 +0100
@@ -24,6 +24,10 @@
#include "mailbox.h"
#include "mutt_crypt.h"
)
Index: init.h
===================================================================
---- init.h.orig 2007-02-16 01:59:05.029959208 +0100
-+++ init.h 2007-02-16 01:59:20.568596976 +0100
-@@ -3067,6 +3067,11 @@ struct command_t Commands[] = {
+--- init.h.orig 2007-03-01 22:20:35.279544696 +0100
++++ init.h 2007-03-01 22:30:00.108677616 +0100
+@@ -3155,6 +3155,11 @@ struct command_t Commands[] = {
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
{ "group", parse_group, 0 },
{ "ungroup", parse_ungroup, 0 },
{ "iconv-hook", mutt_parse_hook, M_ICONVHOOK },
Index: main.c
===================================================================
---- main.c.orig 2007-02-16 01:59:05.073952520 +0100
-+++ main.c 2007-02-16 01:59:20.569596824 +0100
-@@ -398,6 +398,12 @@ static void show_version (void)
+--- main.c.orig 2007-03-01 22:20:46.386856128 +0100
++++ main.c 2007-03-01 22:30:00.108677616 +0100
+@@ -404,6 +404,12 @@ static void show_version (void)
#else
"-LOCALES_HACK "
#endif
"+HAVE_WC_FUNCS "
Index: Makefile.am
===================================================================
---- Makefile.am.orig 2007-02-16 01:59:05.117945832 +0100
-+++ Makefile.am 2007-02-16 01:59:20.569596824 +0100
+--- Makefile.am.orig 2007-03-01 22:20:46.454845792 +0100
++++ Makefile.am 2007-03-01 22:30:00.108677616 +0100
@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
mutt_SOURCES = $(BUILT_SOURCES) \
mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
Index: mbox.c
===================================================================
---- mbox.c.orig 2007-02-16 01:59:05.160939296 +0100
-+++ mbox.c 2007-02-16 01:59:20.569596824 +0100
+--- mbox.c.orig 2007-03-01 22:08:48.131047608 +0100
++++ mbox.c 2007-03-01 22:30:00.109677464 +0100
@@ -29,6 +29,10 @@
#include "copy.h"
#include "mutt_curses.h"
return 0;
Index: mutt.h
===================================================================
---- mutt.h.orig 2007-02-16 01:59:05.203932760 +0100
-+++ mutt.h 2007-02-16 01:59:20.570596672 +0100
+--- mutt.h.orig 2007-03-01 22:20:43.625275952 +0100
++++ mutt.h 2007-03-01 22:30:00.109677464 +0100
@@ -159,6 +159,11 @@ typedef enum
#define M_ACCOUNTHOOK (1<<9)
#define M_REPLYHOOK (1<<10)
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -879,6 +884,11 @@ typedef struct
+@@ -882,6 +887,11 @@ typedef struct
void *data; /* driver specific data */
#endif /* USE_IMAP */
unsigned char rights[(RIGHTSMAX + 7)/8]; /* ACL bits */
Index: mx.c
===================================================================
---- mx.c.orig 2007-02-16 01:59:05.247926072 +0100
-+++ mx.c 2007-02-16 01:59:20.571596520 +0100
+--- mx.c.orig 2007-03-01 22:08:48.223033624 +0100
++++ mx.c 2007-03-01 22:30:00.110677312 +0100
@@ -30,6 +30,10 @@
#include "keymap.h"
#include "url.h"
if (ctx->locked) lock = 0;
Index: mx.h
===================================================================
---- mx.h.orig 2007-02-16 01:59:05.289919688 +0100
-+++ mx.h 2007-02-16 01:59:20.571596520 +0100
+--- mx.h.orig 2007-03-01 22:08:48.272026176 +0100
++++ mx.h 2007-03-01 22:30:00.110677312 +0100
@@ -40,6 +40,9 @@ enum
#ifdef USE_POP
, M_POP
Index: PATCHES
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ PATCHES 2007-02-16 01:59:50.727012200 +0100
++++ PATCHES 2007-03-01 22:30:00.110677312 +0100
@@ -0,0 +1 @@
+patch-1.5.11.rr.compressed.1
Index: po/de.po
===================================================================
---- po/de.po.orig 2007-02-16 01:59:05.375906616 +0100
-+++ po/de.po 2007-02-16 01:59:20.572596368 +0100
+--- po/de.po.orig 2007-03-01 22:21:09.228383688 +0100
++++ po/de.po 2007-03-01 22:30:00.112677008 +0100
@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
msgid "Failed to figure out sender"
msgstr "Kann Absender nicht ermitteln"
#: crypt.c:69
#, c-format
msgid " (current time: %c)"
-@@ -1892,6 +1934,10 @@ msgstr ""
+@@ -1926,6 +1968,10 @@ msgstr ""
msgid "Help for %s"
msgstr "Hilfe für %s"
#: hook.c:246
#, c-format
msgid "unhook: Can't do unhook * from within a hook."
-@@ -3392,18 +3438,10 @@ msgstr "Lese %s... %d (%d%%)"
+@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
msgid "Mailbox is corrupt!"
msgstr "Mailbox fehlerhaft!"
--#: mbox.c:662
+-#: mbox.c:670
-msgid "Mailbox was corrupted!"
-msgstr "Mailbox wurde zerstört!"
-
- #: mbox.c:701 mbox.c:952
+ #: mbox.c:711 mbox.c:964
msgid "Fatal error! Could not reopen mailbox!"
msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:710
+-#: mbox.c:720
-msgid "Unable to lock mailbox!"
-msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-
#. * never happen, is we presume it is a bug in mutt.
Index: po/POTFILES.in
===================================================================
---- po/POTFILES.in.orig 2007-02-16 01:59:05.419899928 +0100
-+++ po/POTFILES.in 2007-02-16 01:59:20.573596216 +0100
+--- po/POTFILES.in.orig 2007-03-01 22:20:56.152371544 +0100
++++ po/POTFILES.in 2007-03-01 22:30:00.112677008 +0100
@@ -8,6 +8,7 @@ charset.c
color.c
commands.c
cryptglue.c
Index: status.c
===================================================================
---- status.c.orig 2007-02-16 01:59:05.465892936 +0100
-+++ status.c 2007-02-16 01:59:20.573596216 +0100
+--- status.c.orig 2007-03-01 22:08:48.458997752 +0100
++++ status.c 2007-03-01 22:30:00.113676856 +0100
@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
case 'f':