http://www.spinnaker.de/mutt/compressed/
* Patch last synced with upstream:
- - Date: 2005-09-29
- - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.11.rr.compressed.1.gz
+ - Date: 2007-06-14
+ - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
* Changes made:
- - filterdiff -p1 \
- $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
- doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
- - adjust the init.h hunk to the presence of group & ungroup
- - 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
- - 2006-08-16: adjust Makefile.am mutt-1.5.13
+ - 2007-06-14 myon: remove hunks for Muttrc*
== END PATCH
-Index: compress.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ compress.c 2007-02-16 01:59:20.562597888 +0100
-@@ -0,0 +1,487 @@
+--- /dev/null
++++ b/compress.c
+@@ -0,0 +1,499 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+ *
+ int magic;
+
+ if (is_new (path))
-+ return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++ {
++ char *dir_path = safe_strdup(path);
++ char *aux = strrchr(dir_path, '/');
++ int dir_valid = 1;
++ if (aux)
++ {
++ *aux='\0';
++ if (access(dir_path, W_OK|X_OK))
++ dir_valid = 0;
++ }
++ safe_free((void**)&dir_path);
++ return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++ }
+
+ magic = mx_get_magic (path);
+
+}
+
+static const char *
-+compresshook_format_str (char *dest, size_t destlen, char op, const char *src,
-+ const char *fmt, const char *ifstring,
-+ const char *elsestring, unsigned long data,
-+ format_flag flags)
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
++ const char *src, const char *fmt,
++ const char *ifstring, const char *elsestring,
++ unsigned long data, format_flag flags)
+{
+ char tmp[SHORT_STRING];
+
+static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
+{
+ char expanded[_POSIX_PATH_MAX];
-+ mutt_FormatString (expanded, sizeof (expanded), cmd, compresshook_format_str,
-+ (unsigned long) ctx, 0);
++ mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
++ compresshook_format_str, (unsigned long) ctx, 0);
+ return safe_strdup (expanded);
+}
+
+ COMPRESS_INFO *ci = set_compress_info (ctx);
+ if (!ci->open) {
+ ctx->magic = 0;
-+ FREE (ctx->compressinfo);
++ FREE (&ctx->compressinfo);
+ return (-1);
+ }
+ if (!ci->close || access (ctx->path, W_OK) != 0)
+ {
+ mutt_any_key_to_continue (NULL);
+ ctx->magic = 0;
-+ FREE (ctx->compressinfo);
++ FREE (&ctx->compressinfo);
+ mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
+ }
+ FREE (&cmd);
+}
+
+#endif /* USE_COMPRESSED */
-Index: compress.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ compress.h 2007-02-16 01:59:20.562597888 +0100
+--- /dev/null
++++ b/compress.h
@@ -0,0 +1,27 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+int mutt_test_compress_command (const char *);
+int mutt_check_mailbox_compressed (CONTEXT *);
+void mutt_fast_close_compressed (CONTEXT *);
-Index: configure.in
-===================================================================
---- configure.in.orig 2007-02-16 01:59:04.810992496 +0100
-+++ configure.in 2007-02-16 01:59:20.563597736 +0100
-@@ -801,6 +801,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- a/configure.ac
++++ b/configure.ac
+@@ -792,6 +792,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
[if test $withval != yes; then
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: curs_main.c
-===================================================================
---- curs_main.c.orig 2007-02-16 01:59:04.853985960 +0100
-+++ curs_main.c 2007-02-16 01:59:20.563597736 +0100
-@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1131,6 +1131,11 @@ int mutt_index_menu (void)
{
int check;
mutt_str_replace (&LastFolder, Context->path);
oldcount = Context ? Context->msgcount : 0;
-Index: doc/manual.xml.head
-===================================================================
---- doc/manual.xml.head.orig 2007-02-16 01:59:04.898979120 +0100
-+++ doc/manual.xml.head 2007-02-16 01:59:20.566597280 +0100
-@@ -4749,6 +4749,205 @@ becomes an issue as mutt will silently f
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -4676,6 +4676,205 @@ macro pager \cb |urlview\n
- </sect1>
+ </chapter>
+<sect1 id="compressedfolders">
+<title>Compressed folders Support (OPTIONAL)</title>
+</sect2>
+</sect1>
+
- </chapter>
-
<chapter id="mimesupport">
-Index: doc/muttrc.man.head
-===================================================================
---- doc/muttrc.man.head.orig 2007-02-16 01:59:04.942972432 +0100
-+++ doc/muttrc.man.head 2007-02-16 01:59:20.567597128 +0100
-@@ -316,6 +316,24 @@ specify the ID of the public key to be u
+ <title>Mutt's MIME Support</title>
+
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
+@@ -345,6 +345,24 @@ specify the ID of the public key to be u
to a certain recipient. The meaning of "key ID" is to be taken
broadly: This can be a different e-mail address, a numerical key ID,
or even just an arbitrary search string.
.TP
\fBpush\fP \fIstring\fP
This command adds the named \fIstring\fP to the keyboard buffer.
-Index: hook.c
-===================================================================
---- hook.c.orig 2007-02-16 01:59:04.986965744 +0100
-+++ hook.c 2007-02-16 01:59:20.567597128 +0100
+--- a/hook.c
++++ b/hook.c
@@ -24,6 +24,10 @@
#include "mailbox.h"
#include "mutt_crypt.h"
+ {
+ if (mutt_test_compress_command (command.data))
+ {
-+ strfcpy (err->data, _("bad formatted command string"), err->dsize);
++ strfcpy (err->data, _("badly formatted command string"), err->dsize);
+ return (-1);
+ }
+ }
+#endif
- else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
+ else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
&& (!WithCrypto || !(data & M_CRYPTHOOK))
)
-Index: init.h
-===================================================================
---- init.h.orig 2007-02-16 01:59:05.029959208 +0100
-+++ init.h 2007-02-16 01:59:20.568596976 +0100
-@@ -3067,6 +3067,11 @@ struct command_t Commands[] = {
+--- a/init.h
++++ b/init.h
+@@ -3210,6 +3210,11 @@ struct command_t Commands[] = {
+ { "fcc-hook", mutt_parse_hook, M_FCCHOOK },
+ { "fcc-save-hook", mutt_parse_hook, M_FCCHOOK | M_SAVEHOOK },
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
- { "group", parse_group, 0 },
- { "ungroup", parse_ungroup, 0 },
+#ifdef USE_COMPRESSED
+ { "open-hook", mutt_parse_hook, M_OPENHOOK },
+ { "close-hook", mutt_parse_hook, M_CLOSEHOOK },
+ { "append-hook", mutt_parse_hook, M_APPENDHOOK },
+#endif
+ { "group", parse_group, 0 },
+ { "ungroup", parse_ungroup, 0 },
{ "hdr_order", parse_list, UL &HeaderOrderList },
- #ifdef HAVE_ICONV
- { "iconv-hook", mutt_parse_hook, M_ICONVHOOK },
-Index: main.c
-===================================================================
---- main.c.orig 2007-02-16 01:59:05.073952520 +0100
-+++ main.c 2007-02-16 01:59:20.569596824 +0100
-@@ -398,6 +398,12 @@ static void show_version (void)
+--- a/main.c
++++ b/main.c
+@@ -409,6 +409,12 @@ static void show_version (void)
#else
"-LOCALES_HACK "
#endif
#ifdef HAVE_WC_FUNCS
"+HAVE_WC_FUNCS "
-Index: Makefile.am
-===================================================================
---- Makefile.am.orig 2007-02-16 01:59:05.117945832 +0100
-+++ Makefile.am 2007-02-16 01:59:20.569596824 +0100
+--- a/Makefile.am
++++ b/Makefile.am
@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
mutt_SOURCES = $(BUILT_SOURCES) \
commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
edit.c enter.c flags.c init.c filter.c from.c \
getdomain.c group.c \
-@@ -67,7 +67,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5.c mut
utf8.c wcwidth.c
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: mbox.c
-===================================================================
---- mbox.c.orig 2007-02-16 01:59:05.160939296 +0100
-+++ mbox.c 2007-02-16 01:59:20.569596824 +0100
+--- a/mbox.c
++++ b/mbox.c
@@ -29,6 +29,10 @@
#include "copy.h"
#include "mutt_curses.h"
mutt_unblock_signals ();
mx_fastclose_mailbox (ctx);
return 0;
-Index: mutt.h
-===================================================================
---- mutt.h.orig 2007-02-16 01:59:05.203932760 +0100
-+++ mutt.h 2007-02-16 01:59:20.570596672 +0100
-@@ -159,6 +159,11 @@ typedef enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -160,6 +160,11 @@ typedef enum
#define M_ACCOUNTHOOK (1<<9)
#define M_REPLYHOOK (1<<10)
#define M_SEND2HOOK (1<<11)
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -879,6 +884,11 @@ typedef struct
- void *data; /* driver specific data */
- #endif /* USE_IMAP */
+@@ -892,6 +897,11 @@ typedef struct _context
+ int flagged; /* how many flagged messages */
+ int msgnotreadyet; /* which msg "new" in pager, -1 if none */
+#ifdef USE_COMPRESSED
+ void *compressinfo; /* compressed mbox module private data */
short magic; /* mailbox type */
unsigned char rights[(RIGHTSMAX + 7)/8]; /* ACL bits */
-Index: mx.c
-===================================================================
---- mx.c.orig 2007-02-16 01:59:05.247926072 +0100
-+++ mx.c 2007-02-16 01:59:20.571596520 +0100
+--- a/mx.c
++++ b/mx.c
@@ -30,6 +30,10 @@
#include "keymap.h"
#include "url.h"
#ifdef USE_IMAP
#include "imap.h"
#endif
-@@ -454,6 +458,10 @@ int mx_get_magic (const char *path)
+@@ -445,6 +449,10 @@ int mx_get_magic (const char *path)
return (-1);
}
return (magic);
}
-@@ -493,6 +501,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -484,6 +492,13 @@ static int mx_open_mailbox_append (CONTE
{
struct stat sb;
ctx->append = 1;
#ifdef USE_IMAP
-@@ -656,7 +671,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -647,7 +662,12 @@ CONTEXT *mx_open_mailbox (const char *pa
}
ctx->magic = mx_get_magic (path);
if(ctx->magic == 0)
mutt_error (_("%s is not a mailbox."), path);
-@@ -762,6 +782,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -748,6 +768,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
mutt_free_header (&ctx->hdrs[i]);
FREE (&ctx->hdrs);
FREE (&ctx->v2r);
FREE (&ctx->path);
FREE (&ctx->pattern);
if (ctx->limit_pattern)
-@@ -819,6 +843,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -800,6 +824,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+
if (tmp && tmp->new == 0)
mutt_update_mailbox (tmp);
- #endif
+
+#ifdef USE_COMPRESSED
+ if (rc == 0 && ctx->compressinfo)
return rc;
}
-@@ -1020,6 +1050,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -1058,6 +1088,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
!mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
mx_unlink_empty (ctx->path);
mx_fastclose_mailbox (ctx);
return 0;
-@@ -1329,6 +1364,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
+@@ -1373,6 +1408,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
{
int rc;
if (ctx)
{
if (ctx->locked) lock = 0;
-Index: mx.h
-===================================================================
---- mx.h.orig 2007-02-16 01:59:05.289919688 +0100
-+++ mx.h 2007-02-16 01:59:20.571596520 +0100
+--- a/mx.h
++++ b/mx.h
@@ -40,6 +40,9 @@ enum
#ifdef USE_POP
, M_POP
};
WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: PATCHES
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ PATCHES 2007-02-16 01:59:50.727012200 +0100
-@@ -0,0 +1 @@
-+patch-1.5.11.rr.compressed.1
-Index: po/de.po
-===================================================================
---- po/de.po.orig 2007-02-16 01:59:05.375906616 +0100
-+++ po/de.po 2007-02-16 01:59:20.572596368 +0100
-@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
+--- a/po/de.po
++++ b/po/de.po
+@@ -1279,6 +1279,48 @@ msgstr "Prüfung des Absenders fehlgeschl
msgid "Failed to figure out sender"
msgstr "Kann Absender nicht ermitteln"
#: crypt.c:69
#, c-format
msgid " (current time: %c)"
-@@ -1892,6 +1934,10 @@ msgstr ""
- msgid "Help for %s"
- msgstr "Hilfe für %s"
+@@ -1948,6 +1990,10 @@ msgstr "Hilfe für %s"
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
+#: hook.c:96
-+msgid "bad formatted command string"
++msgid "badly formatted command string"
+msgstr "Hook enthält nicht die Muster %f und %t"
+
- #: hook.c:246
+ #: hook.c:251
#, c-format
msgid "unhook: Can't do unhook * from within a hook."
-@@ -3392,18 +3438,10 @@ msgstr "Lese %s... %d (%d%%)"
+@@ -3463,18 +3509,10 @@ msgstr "Lese %s..."
msgid "Mailbox is corrupt!"
msgstr "Mailbox fehlerhaft!"
--#: mbox.c:662
+-#: mbox.c:670
-msgid "Mailbox was corrupted!"
-msgstr "Mailbox wurde zerstört!"
-
- #: mbox.c:701 mbox.c:952
+ #: mbox.c:711 mbox.c:964
msgid "Fatal error! Could not reopen mailbox!"
msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:710
+-#: mbox.c:720
-msgid "Unable to lock mailbox!"
-msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-
#. this means ctx->changed or ctx->deleted was set, but no
#. * messages were found to be changed or deleted. This should
#. * never happen, is we presume it is a bug in mutt.
-Index: po/POTFILES.in
-===================================================================
---- po/POTFILES.in.orig 2007-02-16 01:59:05.419899928 +0100
-+++ po/POTFILES.in 2007-02-16 01:59:20.573596216 +0100
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
@@ -8,6 +8,7 @@ charset.c
color.c
commands.c
crypt-gpgme.c
crypt.c
cryptglue.c
-Index: status.c
-===================================================================
---- status.c.orig 2007-02-16 01:59:05.465892936 +0100
-+++ status.c 2007-02-16 01:59:20.573596216 +0100
-@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
+--- a/status.c
++++ b/status.c
+@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
case 'f':
snprintf (fmt, sizeof(fmt), "%%%ss", prefix);