]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features-old/patch-1.5.4.vk.pgp_verbose_mime
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / features-old / patch-1.5.4.vk.pgp_verbose_mime
index a953b6028a8962c068bf252efd018d3ee47cdd03..4179485098fc712cb5a89101aea909f849bb31c4 100644 (file)
@@ -1,6 +1,8 @@
+Enable pgp_mime_signature_filename and pgp_mime_signature_description
+
 --- a/globals.h
 +++ b/globals.h
-@@ -241,6 +241,8 @@
+@@ -243,6 +243,8 @@
  WHERE char *PgpListSecringCommand;
  WHERE char *PgpListPubringCommand;
  WHERE char *PgpGetkeysCommand;
@@ -11,9 +13,9 @@
  WHERE char *SmimeDefaultKey;
 --- a/init.h
 +++ b/init.h
-@@ -1790,6 +1790,18 @@
-   ** checked with the \fC$<check-traditional-pgp>\fP function, mutt will automatically
-   ** check the message for traditional pgp.
+@@ -2556,6 +2556,18 @@
+   ** a line quoted text if it also matches $$smileys. This mostly
+   ** happens at the beginning of a line.
    */
 +  { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
 +  /*
 +  ** PGP/MIME signed messages.
 +  */
  
-   /* XXX Default values! */
  
 --- a/pgp.c
 +++ b/pgp.c
-@@ -1113,6 +1113,8 @@
-   t->disposition = DISPINLINE;
+@@ -1129,6 +1129,8 @@
+   t->disposition = DISPNONE;
    t->encoding = ENC7BIT;
    t->unlink = 1; /* ok to remove this file after sending. */
 +  mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);