== END PATCH
--- a/OPS
+++ b/OPS
-@@ -141,6 +141,7 @@
+@@ -142,6 +142,7 @@
OP_PREV_LINE "scroll up one line"
OP_PREV_PAGE "move to the previous page"
OP_PRINT "print the current entry"
OP_QUIT "save changes to mailbox and quit"
--- a/curs_main.c
+++ b/curs_main.c
-@@ -1816,6 +1816,7 @@
+@@ -1843,6 +1843,7 @@
MAYBE_REDRAW (menu->redraw);
break;
case OP_DELETE:
CHECK_MSGCOUNT;
-@@ -1826,6 +1827,7 @@
+@@ -1853,6 +1854,7 @@
if (tag)
{
mutt_tag_set_flag (M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_tag_set_flag (M_TAG, 0);
menu->redraw = REDRAW_INDEX;
-@@ -1833,6 +1835,8 @@
+@@ -1860,6 +1862,8 @@
else
{
mutt_set_flag (Context, CURHDR, M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, CURHDR, M_TAG, 0);
if (option (OPTRESOLVE))
-@@ -2129,11 +2133,13 @@
+@@ -2161,11 +2165,13 @@
if (tag)
{
mutt_tag_set_flag (M_DELETE, 0);
if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
{
menu->current++;
-@@ -2154,9 +2160,11 @@
+@@ -2186,9 +2192,11 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
--- a/functions.h
+++ b/functions.h
-@@ -120,6 +120,7 @@
+@@ -121,6 +121,7 @@
{ "toggle-write", OP_TOGGLE_WRITE, "%" },
{ "next-thread", OP_MAIN_NEXT_THREAD, "\016" },
{ "next-subthread", OP_MAIN_NEXT_SUBTHREAD, "\033n" },
{ "query", OP_QUERY, "Q" },
{ "quit", OP_QUIT, "q" },
{ "reply", OP_REPLY, "r" },
-@@ -207,6 +208,7 @@
+@@ -213,6 +214,7 @@
{ "print-message", OP_PRINT, "p" },
{ "previous-thread", OP_MAIN_PREV_THREAD, "\020" },
{ "previous-subthread",OP_MAIN_PREV_SUBTHREAD, "\033p" },
{ "reply", OP_REPLY, "r" },
--- a/mutt.h
+++ b/mutt.h
-@@ -182,6 +182,7 @@
+@@ -188,6 +188,7 @@
M_UNDELETE,
M_DELETED,
M_APPENDED,
M_FLAG,
M_TAG,
M_UNTAG,
-@@ -695,6 +696,7 @@
+@@ -709,6 +710,7 @@
unsigned int flagged : 1; /* marked important? */
unsigned int tagged : 1;
unsigned int appended : 1; /* has been saved */
unsigned int attach_del : 1; /* has an attachment marked for deletion */
--- a/mx.c
+++ b/mx.c
-@@ -833,6 +833,7 @@
+@@ -806,6 +806,7 @@
{
for (i = 0 ; i < ctx->msgcount ; i++)
if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
mx_close_mailbox (ctx_trash, NULL);
--- a/pager.c
+++ b/pager.c
-@@ -2272,12 +2272,15 @@
+@@ -2343,12 +2343,15 @@
MAYBE_REDRAW (redraw);
break;
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, extra->hdr, M_TAG, 0);
redraw = REDRAW_STATUS | REDRAW_INDEX;
-@@ -2590,6 +2593,7 @@
+@@ -2675,6 +2678,7 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message"));
mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
redraw = REDRAW_STATUS | REDRAW_INDEX;
if (option (OPTRESOLVE))
{
-@@ -2605,9 +2609,11 @@
+@@ -2690,9 +2694,11 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
{
--- a/pattern.c
+++ b/pattern.c
-@@ -1344,8 +1344,10 @@
+@@ -1357,8 +1357,10 @@
{
switch (op)
{