]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
incorporating fixes of http://bugs.mutt.org/3308 into the existing patch
[software/mutt-debian.git] / debian / rules
index 9edd5c8521b9ed9f7a7cc4afd66060a28b99d2da..1b5641f63e6aa76d5f3214ace21c16a0fe81def6 100755 (executable)
@@ -6,7 +6,7 @@ include /usr/share/quilt/quilt.make
 
 ###
 # build a separate mutt-patched package?
-#BUILD_PATCHED := yes -- disabled until there is a sidebar patch for 1.5.19
+BUILD_PATCHED := yes
 ###
 # header cache backend
 # HCACHE_DB := bdb
@@ -14,7 +14,7 @@ HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
 ###
 # GPGME backend
-GPGME := --enable-gpgme
+GPGME := --enable-gpgme
 ###
 
 ###################### variables ######################
@@ -26,13 +26,13 @@ endif
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
-    hcache_db := --without-gdbm --without-qdbm
+    hcache_db := --without-gdbm --without-qdbm --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),gdbm)
-    hcache_db := --without-qdbm --without-bdb
+    hcache_db := --without-qdbm --without-bdb --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),qdbm)
-    hcache_db := --without-gdbm --without-bdb
+    hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
 endif
 
 confflags =    --prefix=/usr                   \
@@ -126,7 +126,7 @@ install: build
        ###################### install ######################
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \