]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/xtitles
Instead of trying to maintain the PATCHES file, put "quilt applied" output there.
[software/mutt-debian.git] / debian / patches / features / xtitles
index 6419282fa94d7f0e4dc37d210be890ef207d428a..b42acc15a708c00814c6d358b4d72cee371870e1 100644 (file)
@@ -10,9 +10,11 @@ This is the xterm title patch as found on the mutt mailing lists.
     (cleaner code, no functional change, evades conflict with sidebar patch)
 
 == END PATCH
     (cleaner code, no functional change, evades conflict with sidebar patch)
 
 == END PATCH
---- a/curs_main.c
-+++ b/curs_main.c
-@@ -112,6 +112,19 @@ static const char *No_visible = N_("No v
+Index: mutt/curs_main.c
+===================================================================
+--- mutt.orig/curs_main.c      2009-06-25 12:35:37.000000000 +0200
++++ mutt/curs_main.c   2009-06-25 12:35:44.000000000 +0200
+@@ -110,6 +110,19 @@
  
  extern size_t UngetCount;
  
  
  extern size_t UngetCount;
  
@@ -32,7 +34,7 @@ This is the xterm title patch as found on the mutt mailing lists.
  void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
  {
    format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
  void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
  {
    format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
-@@ -574,6 +587,13 @@ int mutt_index_menu (void)
+@@ -566,6 +579,13 @@
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
        menu->redraw &= ~REDRAW_STATUS;
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
        menu->redraw &= ~REDRAW_STATUS;
@@ -46,9 +48,11 @@ This is the xterm title patch as found on the mutt mailing lists.
        }
  
        menu->redraw = 0;
        }
  
        menu->redraw = 0;
---- a/globals.h
-+++ b/globals.h
-@@ -145,6 +145,8 @@ WHERE char *Tempdir;
+Index: mutt/globals.h
+===================================================================
+--- mutt.orig/globals.h        2009-06-25 12:35:37.000000000 +0200
++++ mutt/globals.h     2009-06-25 12:35:44.000000000 +0200
+@@ -141,6 +141,8 @@
  WHERE char *Tochars;
  WHERE char *Username;
  WHERE char *Visual;
  WHERE char *Tochars;
  WHERE char *Username;
  WHERE char *Visual;
@@ -57,9 +61,11 @@ This is the xterm title patch as found on the mutt mailing lists.
  
  WHERE char *CurrentFolder;
  WHERE char *LastFolder;
  
  WHERE char *CurrentFolder;
  WHERE char *LastFolder;
---- a/init.c
-+++ b/init.c
-@@ -1870,6 +1870,26 @@ static int parse_set (BUFFER *tmp, BUFFE
+Index: mutt/init.c
+===================================================================
+--- mutt.orig/init.c   2009-06-25 12:35:42.000000000 +0200
++++ mutt/init.c        2009-06-25 12:35:44.000000000 +0200
+@@ -1892,6 +1892,26 @@
        toggle_option (MuttVars[idx].data);
        else
        set_option (MuttVars[idx].data);
        toggle_option (MuttVars[idx].data);
        else
        set_option (MuttVars[idx].data);
@@ -86,11 +92,13 @@ This is the xterm title patch as found on the mutt mailing lists.
      }
      else if (myvar || DTYPE (MuttVars[idx].type) == DT_STR ||
             DTYPE (MuttVars[idx].type) == DT_PATH ||
      }
      else if (myvar || DTYPE (MuttVars[idx].type) == DT_STR ||
             DTYPE (MuttVars[idx].type) == DT_PATH ||
---- a/init.h
-+++ b/init.h
-@@ -3104,6 +3104,27 @@ struct option_t MuttVars[] = {
-   ** option does nothing: mutt will never write out the BCC header
-   ** in this case.
+Index: mutt/init.h
+===================================================================
+--- mutt.orig/init.h   2009-06-25 12:35:42.000000000 +0200
++++ mutt/init.h        2009-06-25 12:35:44.000000000 +0200
+@@ -3337,6 +3337,27 @@
+   ** Also see the $$read_inc, $$net_inc and $$time_inc variables and the
+   ** ``$tuning'' section of the manual for performance considerations.
    */
 +  {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
 +  /*
    */
 +  {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
 +  /*
@@ -114,11 +122,13 @@ This is the xterm title patch as found on the mutt mailing lists.
 +  ** to the one used by ``$$status_format''.
 +  */
    /*--*/
 +  ** to the one used by ``$$status_format''.
 +  */
    /*--*/
-   { NULL }
+   { NULL, 0, 0, 0, 0 }
  };
  };
---- a/mutt.h
-+++ b/mutt.h
-@@ -458,6 +458,7 @@ enum
+Index: mutt/mutt.h
+===================================================================
+--- mutt.orig/mutt.h   2009-06-25 12:35:37.000000000 +0200
++++ mutt/mutt.h        2009-06-25 12:35:44.000000000 +0200
+@@ -446,6 +446,7 @@
    OPTWRAPSEARCH,
    OPTWRITEBCC,                /* write out a bcc header? */
    OPTXMAILER,
    OPTWRAPSEARCH,
    OPTWRITEBCC,                /* write out a bcc header? */
    OPTXMAILER,
@@ -126,10 +136,12 @@ This is the xterm title patch as found on the mutt mailing lists.
  
    OPTCRYPTUSEGPGME,
    OPTCRYPTUSEPKA,
  
    OPTCRYPTUSEGPGME,
    OPTCRYPTUSEPKA,
---- a/pager.c
-+++ b/pager.c
-@@ -1767,6 +1767,13 @@ mutt_pager (const char *banner, const ch
-       mutt_paddstr (COLS, IsHeader (extra) || IsMsgAttach (extra) ?  buffer : banner);
+Index: mutt/pager.c
+===================================================================
+--- mutt.orig/pager.c  2009-06-25 12:35:37.000000000 +0200
++++ mutt/pager.c       2009-06-25 12:35:44.000000000 +0200
+@@ -1784,6 +1784,13 @@
+       }
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
 +      if (option(OPTXTERMSETTITLES))
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
 +      if (option(OPTXTERMSETTITLES))
@@ -142,9 +154,11 @@ This is the xterm title patch as found on the mutt mailing lists.
      }
  
      if ((redraw & REDRAW_INDEX) && index)
      }
  
      if ((redraw & REDRAW_INDEX) && index)
---- a/status.c
-+++ b/status.c
-@@ -195,6 +195,8 @@ status_format_str (char *buf, size_t buf
+Index: mutt/status.c
+===================================================================
+--- mutt.orig/status.c 2009-06-25 12:35:37.000000000 +0200
++++ mutt/status.c      2009-06-25 12:35:44.000000000 +0200
+@@ -195,6 +195,8 @@
        break;
  
      case 'P':
        break;
  
      case 'P':
@@ -153,18 +167,16 @@ This is the xterm title patch as found on the mutt mailing lists.
        if (menu->top + menu->pagelen >= menu->max)
        cp = menu->top ? "end" : "all";
        else
        if (menu->top + menu->pagelen >= menu->max)
        cp = menu->top ? "end" : "all";
        else
---- a/mutt_menu.h
-+++ b/mutt_menu.h
-@@ -103,6 +103,8 @@ void menu_current_middle (MUTTMENU *);
+Index: mutt/mutt_menu.h
+===================================================================
+--- mutt.orig/mutt_menu.h      2009-06-25 12:35:37.000000000 +0200
++++ mutt/mutt_menu.h   2009-06-25 12:35:44.000000000 +0200
+@@ -103,6 +103,8 @@
  void menu_current_bottom (MUTTMENU *);
  void menu_check_recenter (MUTTMENU *);
  void menu_status_line (char *, size_t, MUTTMENU *, const char *);
 +void set_xterm_title_bar (char *title);
 +void set_xterm_icon_name (char *name);
  
  void menu_current_bottom (MUTTMENU *);
  void menu_check_recenter (MUTTMENU *);
  void menu_status_line (char *, size_t, MUTTMENU *, const char *);
 +void set_xterm_title_bar (char *title);
 +void set_xterm_icon_name (char *name);
  
- MUTTMENU *mutt_new_menu (void);
+ MUTTMENU *mutt_new_menu (int);
  void mutt_menuDestroy (MUTTMENU **);
  void mutt_menuDestroy (MUTTMENU **);
---- a/PATCHES
-+++ b/PATCHES
-@@ -0,0 +1 @@
-+patch-1.5.13.nt+ab.xtitles.4