]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/Md.etc_mailname_gethostbyname.diff
* debian/patches/series:
[software/mutt-debian.git] / debian / patches / debian-specific / Md.etc_mailname_gethostbyname.diff
index f7a94b0104c437ae4d134f51850447e0d322ec89..61d04ce4f872e5be1e7436d33d65722eb8b5fa26 100644 (file)
@@ -1,6 +1,9 @@
+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
 --- a/init.c
 +++ b/init.c
-@@ -46,6 +46,7 @@
+@@ -47,6 +47,7 @@
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
@@ -8,7 +11,7 @@
  #include <errno.h>
  #include <sys/wait.h>
  
-@@ -2911,6 +2912,31 @@ static int mutt_execute_commands (LIST *
+@@ -2953,6 +2954,31 @@
    return 0;
  }
  
@@ -40,7 +43,7 @@
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
-@@ -2982,10 +3008,25 @@ void mutt_init (int skip_sys_rc, LIST *c
+@@ -3027,10 +3053,25 @@
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */