]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/use_usr_bin_editor.diff
Merge commit 'upstream/1.5.21'
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
index 13baea5395c9596fdc07131d79416ea9fa2b5152..5c51a580cb6d349b3d687dd97430383081c37b28 100644 (file)
@@ -1,6 +1,9 @@
+Even if EDITOR is not set, mutt will always use /usr/bin/editor (which 
+is set by update-alternatives), rather than falling back to vi
+
 --- a/init.c
 +++ b/init.c
-@@ -3114,7 +3114,7 @@ void mutt_init (int skip_sys_rc, LIST *c
+@@ -3115,7 +3115,7 @@
    {
      p = getenv ("EDITOR");
      if (!p)
@@ -11,7 +14,7 @@
    Visual = safe_strdup (p);
 --- a/init.h
 +++ b/init.h
-@@ -589,7 +589,7 @@ struct option_t MuttVars[] = {
+@@ -686,7 +686,7 @@
    ** .pp
    ** This variable specifies which editor is used by mutt.
    ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment