]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/Md.etc_mailname_gethostbyname.diff
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / debian-specific / Md.etc_mailname_gethostbyname.diff
index f7a94b0104c437ae4d134f51850447e0d322ec89..13a96b65cb85b213b94a6900c2515956546b88ac 100644 (file)
@@ -1,15 +1,18 @@
+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
 --- a/init.c
 +++ b/init.c
 --- a/init.c
 +++ b/init.c
-@@ -46,6 +46,7 @@
+@@ -48,6 +48,7 @@
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
 +#include <netdb.h>
  #include <errno.h>
  #include <sys/wait.h>
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
 +#include <netdb.h>
  #include <errno.h>
  #include <sys/wait.h>
-@@ -2911,6 +2912,31 @@ static int mutt_execute_commands (LIST *
-   return 0;
+ #include <sys/time.h>
+@@ -2952,6 +2953,31 @@
+   srandom(seed);
  }
  
 +int getmailname(char *s, size_t l)
  }
  
 +int getmailname(char *s, size_t l)
@@ -40,7 +43,7 @@
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
-@@ -2982,10 +3008,25 @@ void mutt_init (int skip_sys_rc, LIST *c
+@@ -3027,10 +3053,25 @@
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */