]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/xtitles
removing patches that were applied usptream into 1.5.21
[software/mutt-debian.git] / debian / patches / features / xtitles
index 6419282fa94d7f0e4dc37d210be890ef207d428a..dc9951ba5a8b486441d8192ff13a9fa061b24db9 100644 (file)
@@ -12,7 +12,7 @@ This is the xterm title patch as found on the mutt mailing lists.
 == END PATCH
 --- a/curs_main.c
 +++ b/curs_main.c
-@@ -112,6 +112,19 @@ static const char *No_visible = N_("No v
+@@ -110,6 +110,19 @@
  
  extern size_t UngetCount;
  
@@ -32,7 +32,7 @@ This is the xterm title patch as found on the mutt mailing lists.
  void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
  {
    format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
-@@ -574,6 +587,13 @@ int mutt_index_menu (void)
+@@ -562,6 +575,13 @@
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
        menu->redraw &= ~REDRAW_STATUS;
@@ -48,7 +48,7 @@ This is the xterm title patch as found on the mutt mailing lists.
        menu->redraw = 0;
 --- a/globals.h
 +++ b/globals.h
-@@ -145,6 +145,8 @@ WHERE char *Tempdir;
+@@ -141,6 +141,8 @@
  WHERE char *Tochars;
  WHERE char *Username;
  WHERE char *Visual;
@@ -59,7 +59,7 @@ This is the xterm title patch as found on the mutt mailing lists.
  WHERE char *LastFolder;
 --- a/init.c
 +++ b/init.c
-@@ -1870,6 +1870,26 @@ static int parse_set (BUFFER *tmp, BUFFE
+@@ -1873,6 +1873,26 @@
        toggle_option (MuttVars[idx].data);
        else
        set_option (MuttVars[idx].data);
@@ -88,9 +88,9 @@ This is the xterm title patch as found on the mutt mailing lists.
             DTYPE (MuttVars[idx].type) == DT_PATH ||
 --- a/init.h
 +++ b/init.h
-@@ -3104,6 +3104,27 @@ struct option_t MuttVars[] = {
-   ** option does nothing: mutt will never write out the BCC header
-   ** in this case.
+@@ -3364,6 +3364,27 @@
+   ** Also see the $$read_inc, $$net_inc and $$time_inc variables and the
+   ** ``$tuning'' section of the manual for performance considerations.
    */
 +  {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
 +  /*
@@ -114,11 +114,11 @@ This is the xterm title patch as found on the mutt mailing lists.
 +  ** to the one used by ``$$status_format''.
 +  */
    /*--*/
-   { NULL }
+   { NULL, 0, 0, 0, 0 }
  };
 --- a/mutt.h
 +++ b/mutt.h
-@@ -458,6 +458,7 @@ enum
+@@ -447,6 +447,7 @@
    OPTWRAPSEARCH,
    OPTWRITEBCC,                /* write out a bcc header? */
    OPTXMAILER,
@@ -128,8 +128,8 @@ This is the xterm title patch as found on the mutt mailing lists.
    OPTCRYPTUSEPKA,
 --- a/pager.c
 +++ b/pager.c
-@@ -1767,6 +1767,13 @@ mutt_pager (const char *banner, const ch
-       mutt_paddstr (COLS, IsHeader (extra) || IsMsgAttach (extra) ?  buffer : banner);
+@@ -1812,6 +1812,13 @@
+       }
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
 +      if (option(OPTXTERMSETTITLES))
@@ -144,7 +144,7 @@ This is the xterm title patch as found on the mutt mailing lists.
      if ((redraw & REDRAW_INDEX) && index)
 --- a/status.c
 +++ b/status.c
-@@ -195,6 +195,8 @@ status_format_str (char *buf, size_t buf
+@@ -195,6 +195,8 @@
        break;
  
      case 'P':
@@ -155,16 +155,12 @@ This is the xterm title patch as found on the mutt mailing lists.
        else
 --- a/mutt_menu.h
 +++ b/mutt_menu.h
-@@ -103,6 +103,8 @@ void menu_current_middle (MUTTMENU *);
+@@ -103,6 +103,8 @@
  void menu_current_bottom (MUTTMENU *);
  void menu_check_recenter (MUTTMENU *);
  void menu_status_line (char *, size_t, MUTTMENU *, const char *);
 +void set_xterm_title_bar (char *title);
 +void set_xterm_icon_name (char *name);
  
- MUTTMENU *mutt_new_menu (void);
+ MUTTMENU *mutt_new_menu (int);
  void mutt_menuDestroy (MUTTMENU **);
---- a/PATCHES
-+++ b/PATCHES
-@@ -0,0 +1 @@
-+patch-1.5.13.nt+ab.xtitles.4