counting messages; the if..break part has been dropped.
--- a/buffy.c
+++ b/buffy.c
-@@ -409,6 +409,11 @@ int mutt_buffy_check (int force)
+@@ -409,6 +409,11 @@
tmp->has_new = tmp->new = 1;
tmp->msgcount++;
tmp->msg_unread++;
if(tmp->msg_unread)
--- a/buffy.h
+++ b/buffy.h
-@@ -26,6 +26,7 @@ typedef struct buffy_t
- long size;
+@@ -26,6 +26,7 @@
+ off_t size;
struct buffy_t *next;
struct buffy_t *prev;
+ time_t mtime; /* for maildirs...time of newest entry */