]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
mutt (1.5.14+cvs20070315-1) experimental; urgency=low
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 027bbec8231aca4e397af28d47fc91688148def4..288ab6f830fd46017543071613fffdb42de79636 100644 (file)
@@ -7,21 +7,21 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2005-09-29
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.11.rr.compressed.1.gz
+  - Date: 2007-03-13
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.14.rr.compressed.1.gz
 
 * Changes made:
   - filterdiff -p1 \
     $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
 
 * Changes made:
   - filterdiff -p1 \
     $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - adjust the init.h hunk to the presence of group & ungroup
-  - 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
-  - 2006-08-16: adjust Makefile.am mutt-1.5.13
+  - 2007-03-13 myon: update for 1.5.14+tip (conflict in hook.c)
 
 == END PATCH
 
 == END PATCH
---- /dev/null
-+++ compress.c
-@@ -0,0 +1,487 @@
+Index: mutt/compress.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ mutt/compress.c    2007-03-13 20:59:30.000000000 +0100
+@@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -128,7 +128,19 @@ The home page for this patch is:
 +  int magic;
 +
 +  if (is_new (path))
 +  int magic;
 +
 +  if (is_new (path))
-+    return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  {
++    char *dir_path = safe_strdup(path);
++    char *aux = strrchr(dir_path, '/');
++    int dir_valid = 1;
++    if (aux)
++    {
++      *aux='\0';
++      if (access(dir_path, W_OK|X_OK))
++        dir_valid = 0;
++    }
++    safe_free((void**)&dir_path);
++    return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  }
 +
 +  magic = mx_get_magic (path);
 +
 +
 +  magic = mx_get_magic (path);
 +
@@ -509,8 +521,10 @@ The home page for this patch is:
 +}
 +
 +#endif /* USE_COMPRESSED */
 +}
 +
 +#endif /* USE_COMPRESSED */
---- /dev/null
-+++ compress.h
+Index: mutt/compress.h
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ mutt/compress.h    2007-03-13 20:59:30.000000000 +0100
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -539,9 +553,11 @@ The home page for this patch is:
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
---- configure.in.orig
-+++ configure.in
-@@ -798,6 +798,11 @@
+Index: mutt/configure.in
+===================================================================
+--- mutt.orig/configure.in     2007-03-13 20:53:07.000000000 +0100
++++ mutt/configure.in  2007-03-13 20:59:30.000000000 +0100
+@@ -807,6 +807,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -553,9 +569,11 @@ The home page for this patch is:
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
---- curs_main.c.orig
-+++ curs_main.c
-@@ -1096,6 +1096,11 @@
+Index: mutt/curs_main.c
+===================================================================
+--- mutt.orig/curs_main.c      2007-03-13 20:53:07.000000000 +0100
++++ mutt/curs_main.c   2007-03-13 20:59:30.000000000 +0100
+@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
          {
          int check;
  
          {
          int check;
  
@@ -567,11 +585,13 @@ The home page for this patch is:
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
---- doc/manual.xml.head.orig
-+++ doc/manual.xml.head
-@@ -4749,6 +4749,205 @@
+Index: mutt/doc/manual.xml.head
+===================================================================
+--- mutt.orig/doc/manual.xml.head      2007-03-13 20:53:07.000000000 +0100
++++ mutt/doc/manual.xml.head   2007-03-13 20:59:30.000000000 +0100
+@@ -4843,6 +4843,205 @@ becomes an issue as mutt will silently f
  
  
- </sect1>
+ </chapter>
  
 +<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
  
 +<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
@@ -772,12 +792,14 @@ The home page for this patch is:
 +</sect2>
 +</sect1>
 +
 +</sect2>
 +</sect1>
 +
- </chapter>
  <chapter id="mimesupport">
  <chapter id="mimesupport">
---- doc/muttrc.man.head.orig
-+++ doc/muttrc.man.head
-@@ -316,6 +316,24 @@
+ <title>Mutt's MIME Support</title>
+Index: mutt/doc/muttrc.man.head
+===================================================================
+--- mutt.orig/doc/muttrc.man.head      2007-03-13 20:53:07.000000000 +0100
++++ mutt/doc/muttrc.man.head   2007-03-13 20:59:30.000000000 +0100
+@@ -316,6 +316,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -802,8 +824,10 @@ The home page for this patch is:
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
---- hook.c.orig
-+++ hook.c
+Index: mutt/hook.c
+===================================================================
+--- mutt.orig/hook.c   2007-03-13 20:53:07.000000000 +0100
++++ mutt/hook.c        2007-03-13 21:00:40.000000000 +0100
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -815,7 +839,7 @@ The home page for this patch is:
  #include <limits.h>
  #include <string.h>
  #include <stdlib.h>
  #include <limits.h>
  #include <string.h>
  #include <stdlib.h>
-@@ -92,6 +96,16 @@
+@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
      memset (&pattern, 0, sizeof (pattern));
      pattern.data = safe_strdup (path);
    }
      memset (&pattern, 0, sizeof (pattern));
      pattern.data = safe_strdup (path);
    }
@@ -829,26 +853,30 @@ The home page for this patch is:
 +    }
 +  }
 +#endif
 +    }
 +  }
 +#endif
-   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
+   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
---- init.h.orig
-+++ init.h
-@@ -3119,6 +3119,11 @@
+Index: mutt/init.h
+===================================================================
+--- mutt.orig/init.h   2007-03-13 20:53:07.000000000 +0100
++++ mutt/init.h        2007-03-13 20:59:30.000000000 +0100
+@@ -3167,6 +3167,11 @@ struct command_t Commands[] = {
+   { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
+   { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
+   { "group",          parse_group,            0 },
+   { "ungroup",                parse_ungroup,          0 },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
- #ifdef HAVE_ICONV
-   { "iconv-hook",     mutt_parse_hook,        M_ICONVHOOK }, 
---- main.c.orig
-+++ main.c
-@@ -398,6 +398,12 @@
+Index: mutt/main.c
+===================================================================
+--- mutt.orig/main.c   2007-03-13 20:53:07.000000000 +0100
++++ mutt/main.c        2007-03-13 20:59:30.000000000 +0100
+@@ -404,6 +404,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
  #endif
  #else
        "-LOCALES_HACK  "
  #endif
@@ -861,9 +889,11 @@ The home page for this patch is:
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
---- Makefile.am.orig
-+++ Makefile.am
-@@ -18,7 +18,7 @@
+Index: mutt/Makefile.am
+===================================================================
+--- mutt.orig/Makefile.am      2007-03-13 20:53:07.000000000 +0100
++++ mutt/Makefile.am   2007-03-13 20:59:30.000000000 +0100
+@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
@@ -872,8 +902,8 @@ The home page for this patch is:
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -66,7 +66,7 @@
-       crypt-gpgme.c crypt-mod-pgp-gpgme.c crypt-mod-smime-gpgme.c
+@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+       utf8.c wcwidth.c 
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
 -      configure account.h \
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
 -      configure account.h \
@@ -881,11 +911,13 @@ The home page for this patch is:
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
---- mbox.c.orig
-+++ mbox.c
-@@ -28,6 +28,10 @@
- #include "sort.h"
+Index: mutt/mbox.c
+===================================================================
+--- mutt.orig/mbox.c   2007-03-13 20:53:07.000000000 +0100
++++ mutt/mbox.c        2007-03-13 20:59:30.000000000 +0100
+@@ -29,6 +29,10 @@
  #include "copy.h"
  #include "copy.h"
+ #include "mutt_curses.h"
  
 +#ifdef USE_COMPRESSED
 +#include "compress.h"
  
 +#ifdef USE_COMPRESSED
 +#include "compress.h"
@@ -894,7 +926,7 @@ The home page for this patch is:
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1014,6 +1018,12 @@
+@@ -1026,6 +1030,12 @@ bail:  /* Come here in case of disaster 
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -907,9 +939,11 @@ The home page for this patch is:
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
---- mutt.h.orig
-+++ mutt.h
-@@ -157,6 +157,11 @@
+Index: mutt/mutt.h
+===================================================================
+--- mutt.orig/mutt.h   2007-03-13 20:53:07.000000000 +0100
++++ mutt/mutt.h        2007-03-13 20:59:30.000000000 +0100
+@@ -159,6 +159,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
@@ -921,7 +955,7 @@ The home page for this patch is:
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -864,6 +869,11 @@
+@@ -882,6 +887,11 @@ typedef struct
    void *data;                 /* driver specific data */
  #endif /* USE_IMAP */
  
    void *data;                 /* driver specific data */
  #endif /* USE_IMAP */
  
@@ -932,9 +966,11 @@ The home page for this patch is:
 +
    short magic;                        /* mailbox type */
  
 +
    short magic;                        /* mailbox type */
  
-   unsigned int locked : 1;    /* is the mailbox locked? */
---- mx.c.orig
-+++ mx.c
+   unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
+Index: mutt/mx.c
+===================================================================
+--- mutt.orig/mx.c     2007-03-13 20:53:07.000000000 +0100
++++ mutt/mx.c  2007-03-13 20:59:30.000000000 +0100
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -946,7 +982,7 @@ The home page for this patch is:
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -454,6 +458,10 @@
+@@ -454,6 +458,10 @@ int mx_get_magic (const char *path)
      return (-1);
    }
  
      return (-1);
    }
  
@@ -957,9 +993,9 @@ The home page for this patch is:
    return (magic);
  }
  
    return (magic);
  }
  
-@@ -493,6 +501,13 @@
- {
+@@ -494,6 +502,13 @@ static int mx_open_mailbox_append (CONTE
    struct stat sb;
    struct stat sb;
+   mode_t omask;
  
 +#ifdef USE_COMPRESSED
 +  /* special case for appending to compressed folders -
  
 +#ifdef USE_COMPRESSED
 +  /* special case for appending to compressed folders -
@@ -971,7 +1007,7 @@ The home page for this patch is:
    ctx->append = 1;
  
  #ifdef USE_IMAP
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -653,7 +668,12 @@
+@@ -664,7 +679,12 @@ CONTEXT *mx_open_mailbox (const char *pa
    }
  
    ctx->magic = mx_get_magic (path);
    }
  
    ctx->magic = mx_get_magic (path);
@@ -985,7 +1021,7 @@ The home page for this patch is:
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -759,6 +779,10 @@
+@@ -770,6 +790,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -996,7 +1032,7 @@ The home page for this patch is:
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -816,6 +840,12 @@
+@@ -827,6 +851,12 @@ static int sync_mailbox (CONTEXT *ctx, i
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
  #endif
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
  #endif
@@ -1009,7 +1045,7 @@ The home page for this patch is:
    return rc;
  }
  
    return rc;
  }
  
-@@ -1017,6 +1047,11 @@
+@@ -1028,6 +1058,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1021,7 +1057,7 @@ The home page for this patch is:
    mx_fastclose_mailbox (ctx);
  
    return 0;
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1326,6 +1361,11 @@
+@@ -1342,6 +1377,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
  {
    int rc;
  
  {
    int rc;
  
@@ -1033,9 +1069,11 @@ The home page for this patch is:
    if (ctx)
    {
      if (ctx->locked) lock = 0;
    if (ctx)
    {
      if (ctx->locked) lock = 0;
---- mx.h.orig
-+++ mx.h
-@@ -40,6 +40,9 @@
+Index: mutt/mx.h
+===================================================================
+--- mutt.orig/mx.h     2007-03-13 20:53:07.000000000 +0100
++++ mutt/mx.h  2007-03-13 20:59:30.000000000 +0100
+@@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
  #endif
  #ifdef USE_POP
    , M_POP
  #endif
@@ -1045,15 +1083,17 @@ The home page for this patch is:
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
---- PATCHES.orig
-+++ PATCHES
-@@ -1,2 +1,3 @@
-+patch-1.5.11.rr.compressed.1
- patch-1.5.6.tt.assumed_charset.1
- patch-1.5.6.dw.maildir-mtime.1
---- po/de.po.orig
-+++ po/de.po
-@@ -1267,6 +1267,48 @@
+Index: mutt/PATCHES
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ mutt/PATCHES       2007-03-13 20:59:30.000000000 +0100
+@@ -0,0 +1 @@
++patch-1.5.14.rr.compressed.1
+Index: mutt/po/de.po
+===================================================================
+--- mutt.orig/po/de.po 2007-03-13 20:53:07.000000000 +0100
++++ mutt/po/de.po      2007-03-13 20:59:30.000000000 +0100
+@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
@@ -1102,7 +1142,7 @@ The home page for this patch is:
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
-@@ -1915,6 +1957,10 @@
+@@ -1926,6 +1968,10 @@ msgstr ""
  msgid "Help for %s"
  msgstr "Hilfe für %s"
  
  msgid "Help for %s"
  msgstr "Hilfe für %s"
  
@@ -1113,28 +1153,30 @@ The home page for this patch is:
  #: hook.c:246
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
  #: hook.c:246
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
-@@ -3422,18 +3468,10 @@
+@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
--#: mbox.c:662
+-#: mbox.c:670
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
- #: mbox.c:701 mbox.c:952
+ #: mbox.c:711 mbox.c:964
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
--#: mbox.c:710
+-#: mbox.c:720
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
---- po/POTFILES.in.orig
-+++ po/POTFILES.in
-@@ -8,6 +8,7 @@
+Index: mutt/po/POTFILES.in
+===================================================================
+--- mutt.orig/po/POTFILES.in   2007-03-13 20:53:07.000000000 +0100
++++ mutt/po/POTFILES.in        2007-03-13 20:59:30.000000000 +0100
+@@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
  compose.c
  color.c
  commands.c
  compose.c
@@ -1142,9 +1184,11 @@ The home page for this patch is:
  crypt-gpgme.c
  crypt.c
  cryptglue.c
  crypt-gpgme.c
  crypt.c
  cryptglue.c
---- status.c.orig
-+++ status.c
-@@ -97,6 +97,14 @@
+Index: mutt/status.c
+===================================================================
+--- mutt.orig/status.c 2007-03-13 20:53:07.000000000 +0100
++++ mutt/status.c      2007-03-13 20:59:30.000000000 +0100
+@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);