]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
Merge from etch branch.
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 186428dc7b9bf862f79e3019e5123e5ae39bd227..6dd7a6d22c926d48c2d9cdce939718941f96aff3 100644 (file)
@@ -7,23 +7,17 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2007-03-13
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.14.rr.compressed.1.gz
+  - Date: 2007-06-14
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
 
 * Changes made:
 
 * Changes made:
-  - filterdiff -p1 \
-    $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
-      doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - 2007-03-13 myon: update for 1.5.14+tip (conflict in hook.c)
-  - 2007-03-20 myon: conflict in mx.c resolved (BUFFY_SIZE is gone)
-  - 2007-05-16 myon: conflict in flags.c resolved, adjusted mutt_FormatString
-    call and compresshook_format_str in compress.c
+  - 2007-06-14 myon: remove hunks for Muttrc*
 
 == END PATCH
 Index: debian-mutt/compress.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 
 == END PATCH
 Index: debian-mutt/compress.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.c     2007-05-17 00:11:39.000000000 +0200
++++ debian-mutt/compress.c     2007-06-14 10:57:02.000000000 +0200
 @@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 @@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -197,10 +191,10 @@ Index: debian-mutt/compress.c
 +}
 +
 +static const char *
 +}
 +
 +static const char *
-+compresshook_format_str (char *dest, size_t destlen, size_t col, char op, const char *src,
-+                       const char *fmt, const char *ifstring,
-+                       const char *elsestring, unsigned long data,
-+                       format_flag flags)
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
++                       const char *src, const char *fmt,
++                       const char *ifstring, const char *elsestring,
++                       unsigned long data, format_flag flags)
 +{
 +  char tmp[SHORT_STRING];
 +
 +{
 +  char tmp[SHORT_STRING];
 +
@@ -231,8 +225,8 @@ Index: debian-mutt/compress.c
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
-+  mutt_FormatString (expanded, sizeof (expanded), 0, cmd, compresshook_format_str,
-+                   (unsigned long) ctx, 0);
++  mutt_FormatString (expanded, sizeof (expanded), 0, cmd, 
++                   compresshook_format_str, (unsigned long) ctx, 0);
 +  return safe_strdup (expanded);
 +}
 +
 +  return safe_strdup (expanded);
 +}
 +
@@ -258,7 +252,7 @@ Index: debian-mutt/compress.c
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
@@ -303,7 +297,7 @@ Index: debian-mutt/compress.c
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
@@ -527,7 +521,7 @@ Index: debian-mutt/compress.c
 Index: debian-mutt/compress.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 Index: debian-mutt/compress.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.h     2007-05-16 23:54:01.000000000 +0200
++++ debian-mutt/compress.h     2007-06-14 10:57:02.000000000 +0200
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -556,10 +550,54 @@ Index: debian-mutt/compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
+Index: debian-mutt/config.h.in
+===================================================================
+--- debian-mutt.orig/config.h.in       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/config.h.in    2007-06-14 10:57:02.000000000 +0200
+@@ -513,6 +513,9 @@
+ /* Define to enable Sun mailtool attachments support. */
+ #undef SUN_ATTACHMENT
++/* Define to enable compressed mailboxes support */
++#undef USE_COMPRESSED
++
+ /* Define to use dotlocking for mailboxes. */
+ #undef USE_DOTLOCK
+Index: debian-mutt/configure
+===================================================================
+--- debian-mutt.orig/configure 2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/configure      2007-06-14 10:57:02.000000000 +0200
+@@ -1371,6 +1371,7 @@ Optional Features:
+   --enable-hcache         Enable header caching
+   --disable-iconv         Disable iconv support
+   --disable-nls           Do not use Native Language Support
++  --enable-compressed     Enable compressed folders support
+ Optional Packages:
+   --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
+@@ -15105,6 +15106,17 @@ _ACEOF
+ fi
++# Check whether --enable-compressed or --disable-compressed was given.
++if test "${enable_compressed+set}" = set; then
++  enableval="$enable_compressed"; if test x$enableval = xyes; then
++
++cat >>confdefs.h <<\_ACEOF
++#define USE_COMPRESSED 1
++_ACEOF
++
++        fi
++fi
++
+ # Check whether --with-exec-shell was given.
+ if test "${with_exec_shell+set}" = set; then
 Index: debian-mutt/configure.ac
 ===================================================================
 Index: debian-mutt/configure.ac
 ===================================================================
---- debian-mutt.orig/configure.ac      2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/configure.ac   2007-05-16 23:54:02.000000000 +0200
+--- debian-mutt.orig/configure.ac      2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/configure.ac   2007-06-14 10:57:02.000000000 +0200
 @@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
 @@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
@@ -574,8 +612,8 @@ Index: debian-mutt/configure.ac
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
 Index: debian-mutt/curs_main.c
 ===================================================================
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
 Index: debian-mutt/curs_main.c
 ===================================================================
---- debian-mutt.orig/curs_main.c       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/curs_main.c    2007-05-17 00:13:50.000000000 +0200
+--- debian-mutt.orig/curs_main.c       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/curs_main.c    2007-06-14 10:57:02.000000000 +0200
 @@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
          {
          int check;
 @@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
          {
          int check;
@@ -590,8 +628,8 @@ Index: debian-mutt/curs_main.c
  
 Index: debian-mutt/doc/manual.xml.head
 ===================================================================
  
 Index: debian-mutt/doc/manual.xml.head
 ===================================================================
---- debian-mutt.orig/doc/manual.xml.head       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/doc/manual.xml.head    2007-05-17 00:13:50.000000000 +0200
+--- debian-mutt.orig/doc/manual.xml.head       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/doc/manual.xml.head    2007-06-14 10:57:02.000000000 +0200
 @@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
  
  </chapter>
 @@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
  
  </chapter>
@@ -800,8 +838,8 @@ Index: debian-mutt/doc/manual.xml.head
  
 Index: debian-mutt/doc/muttrc.man.head
 ===================================================================
  
 Index: debian-mutt/doc/muttrc.man.head
 ===================================================================
---- debian-mutt.orig/doc/muttrc.man.head       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/doc/muttrc.man.head    2007-05-16 23:54:01.000000000 +0200
+--- debian-mutt.orig/doc/muttrc.man.head       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/doc/muttrc.man.head    2007-06-14 10:57:02.000000000 +0200
 @@ -345,6 +345,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
 @@ -345,6 +345,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
@@ -829,8 +867,8 @@ Index: debian-mutt/doc/muttrc.man.head
  This command adds the named \fIstring\fP to the keyboard buffer.
 Index: debian-mutt/hook.c
 ===================================================================
  This command adds the named \fIstring\fP to the keyboard buffer.
 Index: debian-mutt/hook.c
 ===================================================================
---- debian-mutt.orig/hook.c    2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/hook.c 2007-05-16 23:54:01.000000000 +0200
+--- debian-mutt.orig/hook.c    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/hook.c 2007-06-14 10:57:02.000000000 +0200
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -851,7 +889,7 @@ Index: debian-mutt/hook.c
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
-+      strfcpy (err->data, _("bad formatted command string"), err->dsize);
++      strfcpy (err->data, _("badly formatted command string"), err->dsize);
 +      return (-1);
 +    }
 +  }
 +      return (-1);
 +    }
 +  }
@@ -861,8 +899,8 @@ Index: debian-mutt/hook.c
        )
 Index: debian-mutt/init.h
 ===================================================================
        )
 Index: debian-mutt/init.h
 ===================================================================
---- debian-mutt.orig/init.h    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/init.h 2007-05-17 00:13:50.000000000 +0200
+--- debian-mutt.orig/init.h    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/init.h 2007-06-14 10:57:02.000000000 +0200
 @@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
 @@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
@@ -877,8 +915,8 @@ Index: debian-mutt/init.h
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
 Index: debian-mutt/main.c
 ===================================================================
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
 Index: debian-mutt/main.c
 ===================================================================
---- debian-mutt.orig/main.c    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/main.c 2007-05-16 23:54:01.000000000 +0200
+--- debian-mutt.orig/main.c    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/main.c 2007-06-14 10:57:02.000000000 +0200
 @@ -401,6 +401,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
 @@ -401,6 +401,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
@@ -894,8 +932,8 @@ Index: debian-mutt/main.c
        "+HAVE_WC_FUNCS  "
 Index: debian-mutt/Makefile.am
 ===================================================================
        "+HAVE_WC_FUNCS  "
 Index: debian-mutt/Makefile.am
 ===================================================================
---- debian-mutt.orig/Makefile.am       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/Makefile.am    2007-05-16 23:54:01.000000000 +0200
+--- debian-mutt.orig/Makefile.am       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/Makefile.am    2007-06-14 10:57:02.000000000 +0200
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
@@ -914,10 +952,49 @@ Index: debian-mutt/Makefile.am
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
+Index: debian-mutt/Makefile.in
+===================================================================
+--- debian-mutt.orig/Makefile.in       2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/Makefile.in    2007-06-14 10:57:02.000000000 +0200
+@@ -74,7 +74,7 @@ am_mutt_OBJECTS = $(am__objects_1) addrb
+       attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
+       buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
+       cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
+-      compose.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
++      compose.$(OBJEXT) compress.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
+       curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
+       enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
+       filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
+@@ -302,7 +302,7 @@ bin_SCRIPTS = muttbug flea @SMIMEAUX_TAR
+ BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h hcversion.h
+ mutt_SOURCES = $(BUILT_SOURCES) \
+       addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
+-      crypt.c cryptglue.c \
++      crypt.c cryptglue.c compress.c \
+       commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
+       edit.c enter.c flags.c init.c filter.c from.c \
+       getdomain.c group.c \
+@@ -335,7 +335,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+       utf8.c wcwidth.c 
+ EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
+-      configure account.h \
++      configure account.h compress.h \
+       attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
+       globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
+       mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
+@@ -507,6 +507,7 @@ distclean-compile:
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/commands.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/complete.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compose.Po@am__quote@
++@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/copy.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-gpgme.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-mod-pgp-classic.Po@am__quote@
 Index: debian-mutt/mbox.c
 ===================================================================
 Index: debian-mutt/mbox.c
 ===================================================================
---- debian-mutt.orig/mbox.c    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/mbox.c 2007-05-16 23:54:01.000000000 +0200
+--- debian-mutt.orig/mbox.c    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mbox.c 2007-06-14 10:57:02.000000000 +0200
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -944,8 +1021,8 @@ Index: debian-mutt/mbox.c
    return 0;
 Index: debian-mutt/mutt.h
 ===================================================================
    return 0;
 Index: debian-mutt/mutt.h
 ===================================================================
---- debian-mutt.orig/mutt.h    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/mutt.h 2007-05-17 00:13:50.000000000 +0200
+--- debian-mutt.orig/mutt.h    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mutt.h 2007-06-14 10:57:02.000000000 +0200
 @@ -160,6 +160,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
 @@ -160,6 +160,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
@@ -972,8 +1049,8 @@ Index: debian-mutt/mutt.h
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
 Index: debian-mutt/mx.c
 ===================================================================
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
 Index: debian-mutt/mx.c
 ===================================================================
---- debian-mutt.orig/mx.c      2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/mx.c   2007-05-17 00:13:49.000000000 +0200
+--- debian-mutt.orig/mx.c      2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mx.c   2007-06-14 10:57:02.000000000 +0200
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -1074,8 +1151,8 @@ Index: debian-mutt/mx.c
      if (ctx->locked) lock = 0;
 Index: debian-mutt/mx.h
 ===================================================================
      if (ctx->locked) lock = 0;
 Index: debian-mutt/mx.h
 ===================================================================
---- debian-mutt.orig/mx.h      2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/mx.h   2007-05-16 23:54:01.000000000 +0200
+--- debian-mutt.orig/mx.h      2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/mx.h   2007-06-14 10:57:02.000000000 +0200
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
@@ -1089,14 +1166,14 @@ Index: debian-mutt/mx.h
 Index: debian-mutt/PATCHES
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 Index: debian-mutt/PATCHES
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/PATCHES        2007-05-17 00:13:50.000000000 +0200
++++ debian-mutt/PATCHES        2007-06-14 10:57:02.000000000 +0200
 @@ -0,0 +1 @@
 @@ -0,0 +1 @@
-+patch-1.5.14.rr.compressed.1
++patch-1.5.16.rr.compressed.1
 Index: debian-mutt/po/de.po
 ===================================================================
 Index: debian-mutt/po/de.po
 ===================================================================
---- debian-mutt.orig/po/de.po  2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/po/de.po       2007-05-16 23:54:01.000000000 +0200
-@@ -1280,6 +1280,48 @@ msgstr "Prüfung des Absenders fehlgeschl
+--- debian-mutt.orig/po/de.po  2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/po/de.po       2007-06-14 10:57:02.000000000 +0200
+@@ -1279,6 +1279,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
@@ -1145,7 +1222,18 @@ Index: debian-mutt/po/de.po
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
-@@ -3437,18 +3479,10 @@ msgstr "Lese %s..."
+@@ -1948,6 +1990,10 @@ msgstr "Hilfe für %s"
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
++#: hook.c:96
++msgid "badly formatted command string"
++msgstr "Hook enthält nicht die Muster %f und %t"
++
+ #: hook.c:251
+ #, c-format
+ msgid "unhook: Can't do unhook * from within a hook."
+@@ -3452,18 +3498,10 @@ msgstr "Lese %s..."
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
@@ -1166,8 +1254,8 @@ Index: debian-mutt/po/de.po
  #. * never happen, is we presume it is a bug in mutt.
 Index: debian-mutt/po/POTFILES.in
 ===================================================================
  #. * never happen, is we presume it is a bug in mutt.
 Index: debian-mutt/po/POTFILES.in
 ===================================================================
---- debian-mutt.orig/po/POTFILES.in    2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/po/POTFILES.in 2007-05-16 23:54:01.000000000 +0200
+--- debian-mutt.orig/po/POTFILES.in    2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/po/POTFILES.in 2007-06-14 10:57:02.000000000 +0200
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
@@ -1178,8 +1266,8 @@ Index: debian-mutt/po/POTFILES.in
  cryptglue.c
 Index: debian-mutt/status.c
 ===================================================================
  cryptglue.c
 Index: debian-mutt/status.c
 ===================================================================
---- debian-mutt.orig/status.c  2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/status.c       2007-05-17 00:13:49.000000000 +0200
+--- debian-mutt.orig/status.c  2007-06-14 10:54:19.000000000 +0200
++++ debian-mutt/status.c       2007-06-14 10:57:02.000000000 +0200
 @@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':
 @@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':