]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
features/compressed-folders: removed any reference to DefaultMagic (Closes: 541360)
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 186428dc7b9bf862f79e3019e5123e5ae39bd227..16baf3cfd2356084dc08ff9e7ae5d14aca72066b 100644 (file)
@@ -7,24 +7,20 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2007-03-13
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.14.rr.compressed.1.gz
+  - Date: 2008-05-20
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
 
 * Changes made:
-  - filterdiff -p1 \
-    $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
-      doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - 2007-03-13 myon: update for 1.5.14+tip (conflict in hook.c)
-  - 2007-03-20 myon: conflict in mx.c resolved (BUFFY_SIZE is gone)
-  - 2007-05-16 myon: conflict in flags.c resolved, adjusted mutt_FormatString
-    call and compresshook_format_str in compress.c
+  - 2008-05-20 myon: refreshed to remove hunks in auto* files
+  - 2009-09-15 myon: refreshed for mutt-1.5.19
+                     status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
+  - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+  - 2009-09-11 antonio: removed DefaultMagic, see 541360
 
 == END PATCH
-Index: debian-mutt/compress.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.c     2007-05-17 00:11:39.000000000 +0200
-@@ -0,0 +1,499 @@
+--- /dev/null
++++ b/compress.c
+@@ -0,0 +1,496 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -197,10 +193,10 @@ Index: debian-mutt/compress.c
 +}
 +
 +static const char *
-+compresshook_format_str (char *dest, size_t destlen, size_t col, char op, const char *src,
-+                       const char *fmt, const char *ifstring,
-+                       const char *elsestring, unsigned long data,
-+                       format_flag flags)
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
++                       const char *src, const char *fmt,
++                       const char *ifstring, const char *elsestring,
++                       unsigned long data, format_flag flags)
 +{
 +  char tmp[SHORT_STRING];
 +
@@ -231,8 +227,8 @@ Index: debian-mutt/compress.c
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
-+  mutt_FormatString (expanded, sizeof (expanded), 0, cmd, compresshook_format_str,
-+                   (unsigned long) ctx, 0);
++  mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
++                   compresshook_format_str, (unsigned long) ctx, 0);
 +  return safe_strdup (expanded);
 +}
 +
@@ -258,7 +254,7 @@ Index: debian-mutt/compress.c
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
@@ -303,7 +299,7 @@ Index: debian-mutt/compress.c
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
@@ -348,10 +344,7 @@ Index: debian-mutt/compress.c
 +
 +  set_path (ctx);
 +
-+  ctx->magic = DefaultMagic;
-+
 +  if (!is_new (ctx->realpath))
-+    if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
@@ -371,8 +364,8 @@ Index: debian-mutt/compress.c
 +      fclose (ctx->fp);
 +    ctx->fp = NULL;
 +    /* if the folder was removed, remove the gzipped folder too */
-+    if ((ctx->magic > 0) 
-+      && (access (ctx->path, F_OK) != 0) 
++    if ((ctx->magic > 0)
++      && (access (ctx->path, F_OK) != 0)
 +      && ! option (OPTSAVEEMPTY))
 +      remove (ctx->realpath);
 +    else
@@ -451,7 +444,7 @@ Index: debian-mutt/compress.c
 +  if (! (ctx->append
 +       && ((append = get_append_command (ctx->realpath, ctx))
 +           || (append = ci->close))))
-+  { 
++  {
 +    /* if we can not or should not append, we only have to remove the */
 +    /* compressed info, because sync was already called               */
 +    mutt_fast_close_compressed (ctx);
@@ -524,10 +517,8 @@ Index: debian-mutt/compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
-Index: debian-mutt/compress.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.h     2007-05-16 23:54:01.000000000 +0200
+--- /dev/null
++++ b/compress.h
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -556,11 +547,9 @@ Index: debian-mutt/compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-Index: debian-mutt/configure.ac
-===================================================================
---- debian-mutt.orig/configure.ac      2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/configure.ac   2007-05-16 23:54:02.000000000 +0200
-@@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- a/configure.ac
++++ b/configure.ac
+@@ -805,6 +805,11 @@
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -572,11 +561,9 @@ Index: debian-mutt/configure.ac
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: debian-mutt/curs_main.c
-===================================================================
---- debian-mutt.orig/curs_main.c       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/curs_main.c    2007-05-17 00:13:50.000000000 +0200
-@@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1135,6 +1135,11 @@
          {
          int check;
  
@@ -588,11 +575,9 @@ Index: debian-mutt/curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-Index: debian-mutt/doc/manual.xml.head
-===================================================================
---- debian-mutt.orig/doc/manual.xml.head       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/doc/manual.xml.head    2007-05-17 00:13:50.000000000 +0200
-@@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -5678,6 +5678,205 @@
  
  </chapter>
  
@@ -625,9 +610,9 @@ Index: debian-mutt/doc/manual.xml.head
 +For example:
 +
 +<screen>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
++open-hook \\.gz$ "gzip -cd %f &gt; %t"
 +close-hook \\.gz$ "gzip -c %t &gt; %f"
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
++append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
 +</screen>
 +
 +You do not have to specify all of the commands. If you omit <link
@@ -675,7 +660,7 @@ Index: debian-mutt/doc/manual.xml.head
 +Example:
 +
 +<screen>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
++open-hook \\.gz$ "gzip -cd %f &gt; %t"
 +</screen>
 +
 +If the <emphasis>command</emphasis> is empty, this operation is
@@ -741,7 +726,7 @@ Index: debian-mutt/doc/manual.xml.head
 +Example:
 +
 +<screen>
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
++append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
 +</screen>
 +
 +When <link linkend="append-hook">append-hook</link> is used, the folder
@@ -798,11 +783,23 @@ Index: debian-mutt/doc/manual.xml.head
  <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
-Index: debian-mutt/doc/muttrc.man.head
-===================================================================
---- debian-mutt.orig/doc/muttrc.man.head       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/doc/muttrc.man.head    2007-05-16 23:54:01.000000000 +0200
-@@ -345,6 +345,24 @@ specify the ID of the public key to be u
+--- a/doc/Muttrc.head
++++ b/doc/Muttrc.head
+@@ -29,6 +29,11 @@
+ macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
+ bind browser y exit
++# Use folders which match on \\.gz$ as gzipped folders:
++# open-hook \\.gz$ "gzip -cd %f > %t"
++# close-hook \\.gz$ "gzip -c %t > %f"
++# append-hook \\.gz$ "gzip -c %t >> %f"
++
+ # If Mutt is unable to determine your site's domain name correctly, you can
+ # set the default here.
+ #
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
+@@ -345,6 +345,24 @@
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -818,7 +815,7 @@ Index: debian-mutt/doc/muttrc.man.head
 +"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
 +(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
 +compressed mail to a compressed folder (\fBappend-hook\fP). The
-+\fIcommand\fP string is the 
++\fIcommand\fP string is the
 +.BR printf (3)
 +like format string, and it should accept two parameters: \fB%f\fP,
 +which is replaced with the (compressed) folder name, and \fB%t\fP
@@ -827,10 +824,8 @@ Index: debian-mutt/doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-Index: debian-mutt/hook.c
-===================================================================
---- debian-mutt.orig/hook.c    2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/hook.c 2007-05-16 23:54:01.000000000 +0200
+--- a/hook.c
++++ b/hook.c
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -842,7 +837,7 @@ Index: debian-mutt/hook.c
  #include <limits.h>
  #include <string.h>
  #include <stdlib.h>
-@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
+@@ -92,6 +96,16 @@
      memset (&pattern, 0, sizeof (pattern));
      pattern.data = safe_strdup (path);
    }
@@ -851,7 +846,7 @@ Index: debian-mutt/hook.c
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
-+      strfcpy (err->data, _("bad formatted command string"), err->dsize);
++      strfcpy (err->data, _("badly formatted command string"), err->dsize);
 +      return (-1);
 +    }
 +  }
@@ -859,11 +854,9 @@ Index: debian-mutt/hook.c
    else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-Index: debian-mutt/init.h
-===================================================================
---- debian-mutt.orig/init.h    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/init.h 2007-05-17 00:13:50.000000000 +0200
-@@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
+--- a/init.h
++++ b/init.h
+@@ -3504,6 +3504,11 @@
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -875,11 +868,9 @@ Index: debian-mutt/init.h
    { "group",          parse_group,            0 },
    { "ungroup",                parse_ungroup,          0 },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
-Index: debian-mutt/main.c
-===================================================================
---- debian-mutt.orig/main.c    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/main.c 2007-05-16 23:54:01.000000000 +0200
-@@ -401,6 +401,12 @@ static void show_version (void)
+--- a/main.c
++++ b/main.c
+@@ -402,6 +402,12 @@
  #else
        "-LOCALES_HACK  "
  #endif
@@ -892,21 +883,19 @@ Index: debian-mutt/main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-Index: debian-mutt/Makefile.am
-===================================================================
---- debian-mutt.orig/Makefile.am       2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/Makefile.am    2007-05-16 23:54:01.000000000 +0200
-@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,7 +18,7 @@
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
- mutt_SOURCES = $(BUILT_SOURCES) \
+ mutt_SOURCES = \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
 -      crypt.c cryptglue.c \
 +      crypt.c cryptglue.c compress.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
-       utf8.c wcwidth.c 
+@@ -57,7 +57,7 @@
+       bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
 -      configure account.h \
@@ -914,10 +903,8 @@ Index: debian-mutt/Makefile.am
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: debian-mutt/mbox.c
-===================================================================
---- debian-mutt.orig/mbox.c    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/mbox.c 2007-05-16 23:54:01.000000000 +0200
+--- a/mbox.c
++++ b/mbox.c
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -929,7 +916,7 @@ Index: debian-mutt/mbox.c
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1026,6 +1030,12 @@ bail:  /* Come here in case of disaster 
+@@ -1048,6 +1052,12 @@
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -942,11 +929,9 @@ Index: debian-mutt/mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-Index: debian-mutt/mutt.h
-===================================================================
---- debian-mutt.orig/mutt.h    2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/mutt.h 2007-05-17 00:13:50.000000000 +0200
-@@ -160,6 +160,11 @@ typedef enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -146,6 +146,11 @@
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
@@ -958,7 +943,7 @@ Index: debian-mutt/mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -885,6 +890,11 @@ typedef struct _context
+@@ -882,6 +887,11 @@
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
@@ -970,10 +955,8 @@ Index: debian-mutt/mutt.h
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
-Index: debian-mutt/mx.c
-===================================================================
---- debian-mutt.orig/mx.c      2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/mx.c   2007-05-17 00:13:49.000000000 +0200
+--- a/mx.c
++++ b/mx.c
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -985,7 +968,7 @@ Index: debian-mutt/mx.c
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
+@@ -415,6 +419,10 @@
      return (-1);
    }
  
@@ -996,7 +979,7 @@ Index: debian-mutt/mx.c
    return (magic);
  }
  
-@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -454,6 +462,13 @@
  {
    struct stat sb;
  
@@ -1010,7 +993,7 @@ Index: debian-mutt/mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -617,7 +632,12 @@
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1024,7 +1007,7 @@ Index: debian-mutt/mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -753,6 +773,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -718,6 +738,10 @@
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1035,7 +1018,7 @@ Index: debian-mutt/mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -805,6 +829,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -770,6 +794,12 @@
    
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
@@ -1048,7 +1031,7 @@ Index: debian-mutt/mx.c
    return rc;
  }
  
-@@ -1006,6 +1036,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -1033,6 +1063,11 @@
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1060,7 +1043,7 @@ Index: debian-mutt/mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1315,6 +1350,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
+@@ -1355,6 +1390,11 @@
  {
    int rc;
  
@@ -1072,11 +1055,9 @@ Index: debian-mutt/mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-Index: debian-mutt/mx.h
-===================================================================
---- debian-mutt.orig/mx.h      2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/mx.h   2007-05-16 23:54:01.000000000 +0200
-@@ -40,6 +40,9 @@ enum
+--- a/mx.h
++++ b/mx.h
+@@ -40,6 +40,9 @@
  #ifdef USE_POP
    , M_POP
  #endif
@@ -1086,38 +1067,51 @@ Index: debian-mutt/mx.h
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: debian-mutt/PATCHES
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/PATCHES        2007-05-17 00:13:50.000000000 +0200
-@@ -0,0 +1 @@
-+patch-1.5.14.rr.compressed.1
-Index: debian-mutt/po/de.po
-===================================================================
---- debian-mutt.orig/po/de.po  2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/po/de.po       2007-05-16 23:54:01.000000000 +0200
-@@ -1280,6 +1280,48 @@ msgstr "Prüfung des Absenders fehlgeschl
- msgid "Failed to figure out sender"
- msgstr "Kann Absender nicht ermitteln"
+--- a/po/de.po
++++ b/po/de.po
+@@ -2005,6 +2005,10 @@
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
++#: hook.c:96
++msgid "badly formatted command string"
++msgstr "Hook enthält nicht die Muster %f und %t"
++
+ #: hook.c:251
+ #, c-format
+ msgid "unhook: Can't do unhook * from within a hook."
+@@ -2766,7 +2770,7 @@
+ msgid "Mailbox is corrupt!"
+ msgstr "Mailbox fehlerhaft!"
+-#: mbox.c:678
++#: mbox.c:678 compress.c:203 mbox.c:661
+ msgid "Mailbox was corrupted!"
+ msgstr "Mailbox wurde zerstört!"
+@@ -2774,10 +2778,11 @@
+ msgid "Fatal error!  Could not reopen mailbox!"
+ msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
+-#: mbox.c:746
++#: mbox.c:746 compress.c:264 compress.c:246 compress.c:367 compress.c:443 mbox.c:706
+ msgid "Unable to lock mailbox!"
+ msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
++
+ #. this means ctx->changed or ctx->deleted was set, but no
+ #. * messages were found to be changed or deleted.  This should
+ #. * never happen, is we presume it is a bug in mutt.
+@@ -5378,3 +5383,32 @@
  
-+#: compress.c:203 mbox.c:661
-+msgid "Mailbox was corrupted!"
-+msgstr "Mailbox wurde zerstört!"
+ #~ msgid "Authentication method is unknown."
+ #~ msgstr "Authentifizierungsmethode unbekannt."
 +
 +#: compress.c:228 compress.c:253
 +#, c-format
 +msgid "Decompressing %s...\n"
 +msgstr "Entpacke %s...\n"
 +
-+#: compress.c:246 compress.c:367 compress.c:443 mbox.c:706
-+msgid "Unable to lock mailbox!"
-+msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-+
-+#: compress.c:264
-+#, c-format
-+msgid "Error executing: %s : unable to open the mailbox!\n"
-+msgstr "Fehler beim Ausführen von %s : Kann die Mailbox nicht öffnen!\n"
-+
 +#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
 +#, c-format
 +msgid "Compressing %s...\n"
@@ -1141,34 +1135,9 @@ Index: debian-mutt/po/de.po
 +#, c-format
 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
-+
- #: crypt.c:69
- #, c-format
- msgid " (current time: %c)"
-@@ -3437,18 +3479,10 @@ msgstr "Lese %s..."
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
--#: mbox.c:670
--msgid "Mailbox was corrupted!"
--msgstr "Mailbox wurde zerstört!"
--
- #: mbox.c:711 mbox.c:964
- msgid "Fatal error!  Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:720
--msgid "Unable to lock mailbox!"
--msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
--
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted.  This should
- #. * never happen, is we presume it is a bug in mutt.
-Index: debian-mutt/po/POTFILES.in
-===================================================================
---- debian-mutt.orig/po/POTFILES.in    2007-05-16 23:53:59.000000000 +0200
-+++ debian-mutt/po/POTFILES.in 2007-05-16 23:54:01.000000000 +0200
-@@ -8,6 +8,7 @@ charset.c
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -8,6 +8,7 @@
  color.c
  commands.c
  compose.c
@@ -1176,11 +1145,9 @@ Index: debian-mutt/po/POTFILES.in
  crypt-gpgme.c
  crypt.c
  cryptglue.c
-Index: debian-mutt/status.c
-===================================================================
---- debian-mutt.orig/status.c  2007-05-16 23:53:58.000000000 +0200
-+++ debian-mutt/status.c       2007-05-17 00:13:49.000000000 +0200
-@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
@@ -1188,7 +1155,7 @@ Index: debian-mutt/status.c
 +      if (Context && Context->compressinfo && Context->realpath)
 +      {
 +       strfcpy (tmp, Context->realpath, sizeof (tmp));
-+       mutt_pretty_mailbox (tmp);
++       mutt_pretty_mailbox (tmp, sizeof (tmp));
 +      }
 +      else
 +#endif