== END PATCH
--- /dev/null
+++ b/compress.c
-@@ -0,0 +1,496 @@
+@@ -0,0 +1,499 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+ *
+ ctx->realpath = ctx->path;
+
+ /* Uncompress to /tmp */
-+ mutt_mktemp (tmppath);
++ mutt_mktemp (tmppath, sizeof(tmppath));
+ ctx->path = safe_malloc (strlen (tmppath) + 1);
+ strcpy (ctx->path, tmppath);
+}
+ ctx->magic = 0;
+ FREE (&ctx->compressinfo);
+ mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
++ // remove the partial uncompressed file
++ remove_file (ctx);
++ restore_path (ctx);
+ }
+ FREE (&cmd);
+ if (rc)