]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index a9de103ed633274ebebf49e8b229d0f3e1fdc37d..5a16ce84c1768e1aab9812d3b06da457405a94ba 100644 (file)
@@ -22,7 +22,7 @@ The home page for this patch is:
 == END PATCH
 --- /dev/null
 +++ b/compress.c
 == END PATCH
 --- /dev/null
 +++ b/compress.c
-@@ -0,0 +1,496 @@
+@@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -175,7 +175,7 @@ The home page for this patch is:
 +  ctx->realpath = ctx->path;
 +
 +  /* Uncompress to /tmp */
 +  ctx->realpath = ctx->path;
 +
 +  /* Uncompress to /tmp */
-+  mutt_mktemp (tmppath);
++  mutt_mktemp (tmppath, sizeof(tmppath));
 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
 +  strcpy (ctx->path, tmppath);
 +}
 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
 +  strcpy (ctx->path, tmppath);
 +}
@@ -303,6 +303,9 @@ The home page for this patch is:
 +    ctx->magic = 0;
 +    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +    ctx->magic = 0;
 +    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
++    // remove the partial uncompressed file
++    remove_file (ctx);
++    restore_path (ctx);
 +  }
 +  FREE (&cmd);
 +  if (rc)
 +  }
 +  FREE (&cmd);
 +  if (rc)