]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar-sorted
multiple-fccs: added a patch that allows multiple FCC separated by commas, written...
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-sorted
index 5467465134485fbf4959528745d498c1e32c4b39..6e5aa4eea1bd0f5c044bb7bdfa50ff094c30d7a9 100644 (file)
@@ -11,10 +11,8 @@ I hope, it's usefull for someone ;)
 PS: This has to be applied ontop of my sidebar-dotted patch, but it
 should be easy to adopt it to a vanilla mutt.
 
-Index: mutt/sidebar.c
-===================================================================
---- mutt.orig/sidebar.c        2009-06-25 12:36:59.000000000 +0200
-+++ mutt/sidebar.c     2009-06-25 12:37:03.000000000 +0200
+--- a/sidebar.c
++++ b/sidebar.c
 @@ -54,6 +54,35 @@
        for ( ; tmp->next != 0; tmp = tmp->next )
                tmp->next->prev = tmp;
@@ -51,11 +49,9 @@ Index: mutt/sidebar.c
        if ( TopBuffy == 0 && BottomBuffy == 0 )
                TopBuffy = Incoming;
        if ( BottomBuffy == 0 ) {
-Index: mutt/init.h
-===================================================================
---- mutt.orig/init.h   2009-06-25 12:36:59.000000000 +0200
-+++ mutt/init.h        2009-06-25 12:37:03.000000000 +0200
-@@ -1974,6 +1974,11 @@
+--- a/init.h
++++ b/init.h
+@@ -1986,6 +1986,11 @@
    ** .pp
    ** Should the sidebar shorten the path showed.
    */
@@ -67,11 +63,9 @@ Index: mutt/init.h
    { "pgp_use_gpg_agent", DT_BOOL, R_NONE, OPTUSEGPGAGENT, 0},
    /*
    ** .pp
-Index: mutt/mutt.h
-===================================================================
---- mutt.orig/mutt.h   2009-06-25 12:36:59.000000000 +0200
-+++ mutt/mutt.h        2009-06-25 12:37:03.000000000 +0200
-@@ -427,6 +427,7 @@
+--- a/mutt.h
++++ b/mutt.h
+@@ -433,6 +433,7 @@
    OPTSCORE,
    OPTSIDEBAR,
    OPTSIDEBARSHORTPATH,
@@ -79,3 +73,15 @@ Index: mutt/mutt.h
    OPTSIGDASHES,
    OPTSIGONTOP,
    OPTSORTRE,
+--- a/debian/extra/samples/sidebar.muttrc
++++ b/debian/extra/samples/sidebar.muttrc
+@@ -55,6 +55,9 @@
+ # When using IMAP, a '.' is often used as a separator. This option
+ # allows to shorten the folder name to the part after the last dot.
+ #
++# sidebar_sort (boolean)
++# Sorts the folders in the sidebar alphabetically.
++#
+ # color sidebar_new [fg] [bg]
+ # The foreground (fg) and background (bg) color of folders that contain new
+ # mail.