]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/Md.etc_mailname_gethostbyname.diff
624085-gnutls-deprecated-verify-peers.patch: deprecate gnutls_certificate_verify_peer...
[software/mutt-debian.git] / debian / patches / debian-specific / Md.etc_mailname_gethostbyname.diff
index 61d04ce4f872e5be1e7436d33d65722eb8b5fa26..13a96b65cb85b213b94a6900c2515956546b88ac 100644 (file)
@@ -3,16 +3,16 @@ used, rather than calling gethostbyname() on the actual hostname
 
 --- a/init.c
 +++ b/init.c
 
 --- a/init.c
 +++ b/init.c
-@@ -47,6 +47,7 @@
+@@ -48,6 +48,7 @@
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
 +#include <netdb.h>
  #include <errno.h>
  #include <sys/wait.h>
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
 +#include <netdb.h>
  #include <errno.h>
  #include <sys/wait.h>
-@@ -2953,6 +2954,31 @@
-   return 0;
+ #include <sys/time.h>
+@@ -2952,6 +2953,31 @@
+   srandom(seed);
  }
  
 +int getmailname(char *s, size_t l)
  }
  
 +int getmailname(char *s, size_t l)