]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
removing patches that were applied usptream into 1.5.21
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 40460162bbd4b24797fa5af3d49b6674d2a030f7..7f6e233373adbb5fb9840b528e43a12e0b97f65f 100644 (file)
@@ -15,13 +15,14 @@ The home page for this patch is:
   - 2009-09-15 myon: refreshed for mutt-1.5.19
                      status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
   - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+  - 2009-09-11 antonio: removed DefaultMagic, see 541360
+  - 2010-05-31 myon: remove commented paragraph "Use folders..." in
+                     doc/Muttrc.head, see #578096
 
 == END PATCH
-Index: mutt/compress.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ mutt/compress.c    2009-06-25 12:36:25.000000000 +0200
-@@ -0,0 +1,499 @@
+--- /dev/null
++++ b/compress.c
+@@ -0,0 +1,496 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -174,7 +175,7 @@ Index: mutt/compress.c
 +  ctx->realpath = ctx->path;
 +
 +  /* Uncompress to /tmp */
-+  mutt_mktemp (tmppath);
++  mutt_mktemp (tmppath, sizeof(tmppath));
 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
 +  strcpy (ctx->path, tmppath);
 +}
@@ -345,10 +346,7 @@ Index: mutt/compress.c
 +
 +  set_path (ctx);
 +
-+  ctx->magic = DefaultMagic;
-+
 +  if (!is_new (ctx->realpath))
-+    if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
@@ -521,10 +519,8 @@ Index: mutt/compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
-Index: mutt/compress.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ mutt/compress.h    2009-06-25 12:36:26.000000000 +0200
+--- /dev/null
++++ b/compress.h
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -553,11 +549,9 @@ Index: mutt/compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-Index: mutt/configure.ac
-===================================================================
---- mutt.orig/configure.ac     2009-06-25 12:35:38.000000000 +0200
-+++ mutt/configure.ac  2009-06-25 12:36:26.000000000 +0200
-@@ -805,6 +805,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -812,6 +812,11 @@
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -569,11 +563,9 @@ Index: mutt/configure.ac
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: mutt/curs_main.c
-===================================================================
---- mutt.orig/curs_main.c      2009-06-25 12:36:14.000000000 +0200
-+++ mutt/curs_main.c   2009-06-25 12:36:26.000000000 +0200
-@@ -1135,6 +1135,11 @@
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1153,6 +1153,11 @@
          {
          int check;
  
@@ -585,11 +577,9 @@ Index: mutt/curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-Index: mutt/doc/manual.xml.head
-===================================================================
---- mutt.orig/doc/manual.xml.head      2009-06-25 12:35:42.000000000 +0200
-+++ mutt/doc/manual.xml.head   2009-06-25 12:36:26.000000000 +0200
-@@ -5678,6 +5678,205 @@
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -6116,6 +6116,205 @@
  
  </chapter>
  
@@ -795,27 +785,9 @@ Index: mutt/doc/manual.xml.head
  <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
-Index: mutt/doc/Muttrc.head
-===================================================================
---- mutt.orig/doc/Muttrc.head  2009-06-25 12:35:36.000000000 +0200
-+++ mutt/doc/Muttrc.head       2009-06-25 12:36:26.000000000 +0200
-@@ -29,6 +29,11 @@
- macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
- bind browser y exit
-+# Use folders which match on \\.gz$ as gzipped folders:
-+# open-hook \\.gz$ "gzip -cd %f > %t"
-+# close-hook \\.gz$ "gzip -c %t > %f"
-+# append-hook \\.gz$ "gzip -c %t >> %f"
-+
- # If Mutt is unable to determine your site's domain name correctly, you can
- # set the default here.
- #
-Index: mutt/doc/muttrc.man.head
-===================================================================
---- mutt.orig/doc/muttrc.man.head      2009-06-25 12:35:36.000000000 +0200
-+++ mutt/doc/muttrc.man.head   2009-06-25 12:36:26.000000000 +0200
-@@ -345,6 +345,24 @@
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
+@@ -346,6 +346,24 @@
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -840,10 +812,8 @@ Index: mutt/doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-Index: mutt/hook.c
-===================================================================
---- mutt.orig/hook.c   2009-06-25 12:35:36.000000000 +0200
-+++ mutt/hook.c        2009-06-25 12:36:26.000000000 +0200
+--- a/hook.c
++++ b/hook.c
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -872,11 +842,9 @@ Index: mutt/hook.c
    else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-Index: mutt/init.h
-===================================================================
---- mutt.orig/init.h   2009-06-25 12:36:22.000000000 +0200
-+++ mutt/init.h        2009-06-25 12:36:26.000000000 +0200
-@@ -3504,6 +3504,11 @@
+--- a/init.h
++++ b/init.h
+@@ -3530,6 +3530,11 @@
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -885,14 +853,12 @@ Index: mutt/init.h
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
+   { "group",          parse_group,            M_GROUP },
+   { "ungroup",                parse_group,            M_UNGROUP },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
-Index: mutt/main.c
-===================================================================
---- mutt.orig/main.c   2009-06-25 12:35:36.000000000 +0200
-+++ mutt/main.c        2009-06-25 12:36:26.000000000 +0200
-@@ -402,6 +402,12 @@
+--- a/main.c
++++ b/main.c
+@@ -401,6 +401,12 @@
  #else
        "-LOCALES_HACK  "
  #endif
@@ -905,11 +871,9 @@ Index: mutt/main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-Index: mutt/Makefile.am
-===================================================================
---- mutt.orig/Makefile.am      2009-06-25 12:35:36.000000000 +0200
-+++ mutt/Makefile.am   2009-06-25 12:36:26.000000000 +0200
-@@ -18,7 +18,7 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,7 +22,7 @@
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
@@ -918,7 +882,7 @@ Index: mutt/Makefile.am
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -57,7 +57,7 @@
+@@ -61,7 +61,7 @@
        bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
@@ -927,10 +891,8 @@ Index: mutt/Makefile.am
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: mutt/mbox.c
-===================================================================
---- mutt.orig/mbox.c   2009-06-25 12:35:36.000000000 +0200
-+++ mutt/mbox.c        2009-06-25 12:36:26.000000000 +0200
+--- a/mbox.c
++++ b/mbox.c
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -942,7 +904,7 @@ Index: mutt/mbox.c
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1048,6 +1052,12 @@
+@@ -1070,6 +1074,12 @@
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -955,10 +917,8 @@ Index: mutt/mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-Index: mutt/mutt.h
-===================================================================
---- mutt.orig/mutt.h   2009-06-25 12:36:14.000000000 +0200
-+++ mutt/mutt.h        2009-06-25 12:36:26.000000000 +0200
+--- a/mutt.h
++++ b/mutt.h
 @@ -146,6 +146,11 @@
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
@@ -971,7 +931,7 @@ Index: mutt/mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -882,6 +887,11 @@
+@@ -887,6 +892,11 @@
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
@@ -983,10 +943,8 @@ Index: mutt/mutt.h
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
-Index: mutt/mx.c
-===================================================================
---- mutt.orig/mx.c     2009-06-25 12:36:14.000000000 +0200
-+++ mutt/mx.c  2009-06-25 12:36:26.000000000 +0200
+--- a/mx.c
++++ b/mx.c
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -998,7 +956,7 @@ Index: mutt/mx.c
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -415,6 +419,10 @@
+@@ -414,6 +418,10 @@
      return (-1);
    }
  
@@ -1009,7 +967,7 @@ Index: mutt/mx.c
    return (magic);
  }
  
-@@ -454,6 +462,13 @@
+@@ -453,6 +461,13 @@
  {
    struct stat sb;
  
@@ -1023,7 +981,7 @@ Index: mutt/mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -617,7 +632,12 @@
+@@ -616,7 +631,12 @@
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1037,7 +995,7 @@ Index: mutt/mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -718,6 +738,10 @@
+@@ -721,6 +741,10 @@
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1048,7 +1006,7 @@ Index: mutt/mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -770,6 +794,12 @@
+@@ -773,6 +797,12 @@
    
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
@@ -1061,7 +1019,7 @@ Index: mutt/mx.c
    return rc;
  }
  
-@@ -1033,6 +1063,11 @@
+@@ -1043,6 +1073,11 @@
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1073,7 +1031,7 @@ Index: mutt/mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1355,6 +1390,11 @@
+@@ -1361,6 +1396,11 @@
  {
    int rc;
  
@@ -1085,61 +1043,51 @@ Index: mutt/mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-Index: mutt/mx.h
-===================================================================
---- mutt.orig/mx.h     2009-06-25 12:35:36.000000000 +0200
-+++ mutt/mx.h  2009-06-25 12:36:26.000000000 +0200
-@@ -40,6 +40,9 @@
- #ifdef USE_POP
-   , M_POP
- #endif
+--- a/mx.h
++++ b/mx.h
+@@ -36,6 +36,9 @@
+   M_MAILDIR,
+   M_IMAP,
+   M_POP
 +#ifdef USE_COMPRESSED
 +  , M_COMPRESSED
 +#endif
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: mutt/po/de.po
-===================================================================
---- mutt.orig/po/de.po 2009-06-25 12:35:36.000000000 +0200
-+++ mutt/po/de.po      2009-06-25 12:36:26.000000000 +0200
-@@ -2005,6 +2005,10 @@
- msgid "Bad history file format (line %d)"
- msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
-+#: hook.c:96
-+msgid "badly formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:251
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -2766,7 +2770,7 @@
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
--#: mbox.c:678
-+#: mbox.c:678 compress.c:203 mbox.c:661
- msgid "Mailbox was corrupted!"
- msgstr "Mailbox wurde zerstört!"
-@@ -2774,10 +2778,11 @@
- msgid "Fatal error!  Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:746
-+#: mbox.c:746 compress.c:264 compress.c:246 compress.c:367 compress.c:443 mbox.c:706
- msgid "Unable to lock mailbox!"
- msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -8,6 +8,7 @@
+ color.c
+ commands.c
+ compose.c
++compress.c
+ crypt-gpgme.c
+ crypt.c
+ cryptglue.c
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
  
-+
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted.  This should
- #. * never happen, is we presume it is a bug in mutt.
-@@ -5378,3 +5383,32 @@
+     case 'f':
+       snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
++#ifdef USE_COMPRESSED
++      if (Context && Context->compressinfo && Context->realpath)
++      {
++       strfcpy (tmp, Context->realpath, sizeof (tmp));
++       mutt_pretty_mailbox (tmp, sizeof (tmp));
++      }
++      else
++#endif
+       if (Context && Context->path)
+       {
+       strfcpy (tmp, Context->path, sizeof (tmp));
+--- a/po/de.po
++++ b/po/de.po
+@@ -5159,6 +5159,36 @@
+ msgid "show S/MIME options"
+ msgstr "Zeige S/MIME Optionen"
  
- #~ msgid "Authentication method is unknown."
- #~ msgstr "Authentifizierungsmethode unbekannt."
 +
 +#: compress.c:228 compress.c:253
 +#, c-format
@@ -1169,34 +1117,7 @@ Index: mutt/po/de.po
 +#, c-format
 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
-Index: mutt/po/POTFILES.in
-===================================================================
---- mutt.orig/po/POTFILES.in   2009-06-25 12:35:36.000000000 +0200
-+++ mutt/po/POTFILES.in        2009-06-25 12:36:26.000000000 +0200
-@@ -8,6 +8,7 @@
- color.c
- commands.c
- compose.c
-+compress.c
- crypt-gpgme.c
- crypt.c
- cryptglue.c
-Index: mutt/status.c
-===================================================================
---- mutt.orig/status.c 2009-06-25 12:35:44.000000000 +0200
-+++ mutt/status.c      2009-06-25 12:36:26.000000000 +0200
-@@ -96,6 +96,14 @@
++
+ #~ msgid "Clear"
+ #~ msgstr "Klartext"
  
-     case 'f':
-       snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
-+#ifdef USE_COMPRESSED
-+      if (Context && Context->compressinfo && Context->realpath)
-+      {
-+       strfcpy (tmp, Context->realpath, sizeof (tmp));
-+       mutt_pretty_mailbox (tmp, sizeof (tmp));
-+      }
-+      else
-+#endif
-       if (Context && Context->path)
-       {
-       strfcpy (tmp, Context->path, sizeof (tmp));