]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/maildir-mtime
Refresh the remaining patches
[software/mutt-debian.git] / debian / patches / features / maildir-mtime
index e104baec9588f88dfd2adf03a2bc5f7d5221a6bc..ca4b41569fb3dff13248f3dbbd43e774eb670c95 100644 (file)
@@ -143,10 +143,10 @@ The home page for this patch is:
    closedir (dp);  
    browser_sort (state);
 @@ -438,14 +444,15 @@ static int examine_mailboxes (MUTTMENU *
    closedir (dp);  
    browser_sort (state);
 @@ -438,14 +444,15 @@ static int examine_mailboxes (MUTTMENU *
- #ifdef USE_IMAP
      if (mx_is_imap (tmp->path))
      {
      if (mx_is_imap (tmp->path))
      {
--      add_folder (menu, state, tmp->path, NULL, tmp->new);
+       imap_mailbox_state (tmp->path, &mbox);
+-      add_folder (menu, state, tmp->path, NULL, mbox.new);
 +      tmp->new = mbox.new;
 +      add_folder (menu, state, tmp->path, NULL, tmp);
        continue;
 +      tmp->new = mbox.new;
 +      add_folder (menu, state, tmp->path, NULL, tmp);
        continue;