}
--- a/flags.c
+++ b/flags.c
-@@ -66,7 +66,13 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
- else if (h->deleted)
+@@ -69,7 +69,13 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
{
h->deleted = 0;
+ update = 1;
- if (upd_ctx) ctx->deleted--;
+ if (upd_ctx)
+ {
#ifdef USE_IMAP
/* see my comment above */
if (ctx->magic == M_IMAP)
-@@ -88,6 +94,17 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+@@ -91,6 +97,17 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
}
break;
WHERE char *XtermTitle;
--- a/imap/message.c
+++ b/imap/message.c
-@@ -820,6 +820,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+@@ -816,6 +816,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
if (ctx->hdrs[n]->tagged)
{
mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
}
-@@ -827,6 +828,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+@@ -823,6 +824,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
else
{
mutt_set_flag (ctx, h, M_DELETE, 1);
}
--- a/init.h
+++ b/init.h
-@@ -2862,6 +2862,16 @@ struct option_t MuttVars[] = {
+@@ -2881,6 +2881,16 @@ struct option_t MuttVars[] = {
** by \fIyou\fP. The sixth character is used to indicate when a mail
** was sent to a mailing-list you subscribe to (default: L).
*/
M_FLAG,
M_TAG,
M_UNTAG,
-@@ -710,6 +711,7 @@ typedef struct header
+@@ -712,6 +713,7 @@ typedef struct header
unsigned int mime : 1; /* has a MIME-Version header? */
unsigned int flagged : 1; /* marked important? */
unsigned int tagged : 1;
unsigned int deleted : 1;
unsigned int changed : 1;
unsigned int attach_del : 1; /* has an attachment marked for deletion */
-@@ -881,6 +883,7 @@ typedef struct _context
+@@ -883,6 +885,7 @@ typedef struct _context
int new; /* how many new messages? */
int unread; /* how many unread messages? */
int deleted; /* how many deleted messages */
--- a/muttlib.c
+++ b/muttlib.c
-@@ -1380,7 +1380,9 @@ int mutt_save_confirm (const char *s, st
+@@ -1430,7 +1430,9 @@ int mutt_save_confirm (const char *s, st
if (magic > 0 && !mx_access (s, W_OK))
{
if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
--- a/mx.c
+++ b/mx.c
-@@ -808,6 +808,53 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -803,6 +803,53 @@ static int sync_mailbox (CONTEXT *ctx, i
return rc;
}
/* save changes and close mailbox */
int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
{
-@@ -943,6 +990,7 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -938,6 +985,7 @@ int mx_close_mailbox (CONTEXT *ctx, int
if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
{
mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
}
else
{
-@@ -964,6 +1012,14 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -959,6 +1007,14 @@ int mx_close_mailbox (CONTEXT *ctx, int
return 0;
}
#ifdef USE_IMAP
/* allow IMAP to preserve the deleted flag across sessions */
if (ctx->magic == M_IMAP)
-@@ -1159,6 +1215,12 @@ int mx_sync_mailbox (CONTEXT *ctx, int *
+@@ -1154,6 +1210,12 @@ int mx_sync_mailbox (CONTEXT *ctx, int *
msgcount = ctx->msgcount;
deleted = ctx->deleted;
/* update the count for the status display */
PostCount = PostContext->msgcount - PostContext->deleted;
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,3 +1,4 @@
-+patch-1.5.13.cd.trash_folder.3.4
- patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2