http://www.spinnaker.de/mutt/compressed/
* Patch last synced with upstream:
- - Date: 2007-06-14
- - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
+ - Date: 2008-05-20
+ - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
* Changes made:
- - 2007-06-14 myon: remove hunks for Muttrc*
+ - 2008-05-20 myon: refreshed to remove hunks in auto* files
== END PATCH
--- /dev/null
+void mutt_fast_close_compressed (CONTEXT *);
--- a/configure.ac
+++ b/configure.ac
-@@ -804,6 +804,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+@@ -787,6 +787,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
--- a/curs_main.c
+++ b/curs_main.c
-@@ -1116,6 +1116,11 @@ int mutt_index_menu (void)
+@@ -1132,6 +1132,11 @@ int mutt_index_menu (void)
{
int check;
--- a/doc/manual.xml.head
+++ b/doc/manual.xml.head
-@@ -4932,6 +4932,205 @@ becomes an issue as mutt will silently f
+@@ -4799,6 +4799,205 @@ macro pager \cb |urlview\n
</chapter>
<chapter id="mimesupport">
<title>Mutt's MIME Support</title>
+--- a/doc/Muttrc
++++ b/doc/Muttrc
+@@ -24,6 +24,11 @@ macro generic,pager <F1> "<shell-escape>
+ macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
+ bind browser y exit
+
++# Use folders which match on \\.gz$ as gzipped folders:
++# open-hook \\.gz$ "gzip -cd %f > %t"
++# close-hook \\.gz$ "gzip -c %t > %f"
++# append-hook \\.gz$ "gzip -c %t >> %f"
++
+ # If Mutt is unable to determine your site's domain name correctly, you can
+ # set the default here.
+ #
+--- a/doc/Muttrc.head
++++ b/doc/Muttrc.head
+@@ -24,6 +24,11 @@ macro generic,pager <F1> "<shell-escape>
+ macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
+ bind browser y exit
+
++# Use folders which match on \\.gz$ as gzipped folders:
++# open-hook \\.gz$ "gzip -cd %f > %t"
++# close-hook \\.gz$ "gzip -c %t > %f"
++# append-hook \\.gz$ "gzip -c %t >> %f"
++
+ # If Mutt is unable to determine your site's domain name correctly, you can
+ # set the default here.
+ #
--- a/doc/muttrc.man.head
+++ b/doc/muttrc.man.head
@@ -345,6 +345,24 @@ specify the ID of the public key to be u
)
--- a/init.h
+++ b/init.h
-@@ -3172,6 +3172,11 @@ struct command_t Commands[] = {
+@@ -3272,6 +3272,11 @@ struct command_t Commands[] = {
{ "fcc-hook", mutt_parse_hook, M_FCCHOOK },
{ "fcc-save-hook", mutt_parse_hook, M_FCCHOOK | M_SAVEHOOK },
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
{ "hdr_order", parse_list, UL &HeaderOrderList },
--- a/main.c
+++ b/main.c
-@@ -400,6 +400,12 @@ static void show_version (void)
+@@ -403,6 +403,12 @@ static void show_version (void)
#else
"-LOCALES_HACK "
#endif
+++ b/Makefile.am
@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
- mutt_SOURCES = $(BUILT_SOURCES) \
+ mutt_SOURCES = \
addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
- crypt.c cryptglue.c \
+ crypt.c cryptglue.c compress.c \
commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
edit.c enter.c flags.c init.c filter.c from.c \
getdomain.c group.c \
-@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+@@ -57,7 +57,7 @@ EXTRA_mutt_SOURCES = account.c md5.c mut
utf8.c wcwidth.c
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
#include <sys/stat.h>
#include <dirent.h>
#include <string.h>
-@@ -1026,6 +1030,12 @@ bail: /* Come here in case of disaster
+@@ -1037,6 +1041,12 @@ bail: /* Come here in case of disaster
int mbox_close_mailbox (CONTEXT *ctx)
{
mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -889,6 +894,11 @@ typedef struct _context
+@@ -892,6 +897,11 @@ typedef struct _context
int flagged; /* how many flagged messages */
int msgnotreadyet; /* which msg "new" in pager, -1 if none */
#ifdef USE_IMAP
#include "imap.h"
#endif
-@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
+@@ -445,6 +449,10 @@ int mx_get_magic (const char *path)
return (-1);
}
return (magic);
}
-@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -484,6 +492,13 @@ static int mx_open_mailbox_append (CONTE
{
struct stat sb;
ctx->append = 1;
#ifdef USE_IMAP
-@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -647,7 +662,12 @@ CONTEXT *mx_open_mailbox (const char *pa
}
ctx->magic = mx_get_magic (path);
if(ctx->magic == 0)
mutt_error (_("%s is not a mailbox."), path);
-@@ -753,6 +773,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -748,6 +768,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
mutt_free_header (&ctx->hdrs[i]);
FREE (&ctx->hdrs);
FREE (&ctx->v2r);
FREE (&ctx->path);
FREE (&ctx->pattern);
if (ctx->limit_pattern)
-@@ -805,6 +829,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -800,6 +824,12 @@ static int sync_mailbox (CONTEXT *ctx, i
if (tmp && tmp->new == 0)
mutt_update_mailbox (tmp);
return rc;
}
-@@ -1063,6 +1093,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -1058,6 +1088,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
!mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
mx_unlink_empty (ctx->path);
mx_fastclose_mailbox (ctx);
return 0;
-@@ -1378,6 +1413,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
+@@ -1373,6 +1408,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
{
int rc;
};
WHERE short DefaultMagic INITVAL (M_MBOX);
---- a/PATCHES
-+++ b/PATCHES
-@@ -5,3 +5,4 @@ patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2
- patch-1.5.8.hr.sensible_browser_position.3
-+patch-1.5.16.rr.compressed.1
--- a/po/de.po
+++ b/po/de.po
-@@ -3,7 +3,7 @@ msgstr ""
- "Project-Id-Version: 1.5.14\n"
- "Report-Msgid-Bugs-To: \n"
- "POT-Creation-Date: 2007-02-23 09:18-0800\n"
--"PO-Revision-Date: 2007-02-25 12:33+0100\n"
-+"PO-Revision-Date: 2007-09-08 20:55+0200\n"
- "Last-Translator: Roland Rosenfeld <roland@spinnaker.de>\n"
- "Language-Team: German <mutt-po@mutt.org>\n"
- "MIME-Version: 1.0\n"
-@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
+@@ -1289,6 +1289,48 @@ msgstr "Prüfung des Absenders fehlgeschl
msgid "Failed to figure out sender"
msgstr "Kann Absender nicht ermitteln"
#: crypt.c:69
#, c-format
msgid " (current time: %c)"
-@@ -1926,6 +1968,10 @@ msgstr ""
- msgid "Help for %s"
- msgstr "Hilfe für %s"
+@@ -1958,6 +2000,10 @@ msgstr "Hilfe für %s"
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
+#: hook.c:96
+msgid "badly formatted command string"
+msgstr "Hook enthält nicht die Muster %f und %t"
+
- #: hook.c:246
+ #: hook.c:251
#, c-format
msgid "unhook: Can't do unhook * from within a hook."
-@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
+@@ -2687,18 +2733,10 @@ msgstr "Lese %s..."
msgid "Mailbox is corrupt!"
msgstr "Mailbox fehlerhaft!"
--#: mbox.c:670
+-#: mbox.c:678
-msgid "Mailbox was corrupted!"
-msgstr "Mailbox wurde zerstört!"
-
- #: mbox.c:711 mbox.c:964
+ #: mbox.c:719 mbox.c:975
msgid "Fatal error! Could not reopen mailbox!"
msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:720
+-#: mbox.c:728
-msgid "Unable to lock mailbox!"
-msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-
cryptglue.c
--- a/status.c
+++ b/status.c
-@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
+@@ -96,6 +96,14 @@ status_format_str (char *buf, size_t buf
case 'f':
snprintf (fmt, sizeof(fmt), "%%%ss", prefix);