]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/build_doc_adjustments.diff
Merge branch '1.5.20-1+fix533439-atime'
[software/mutt-debian.git] / debian / patches / debian-specific / build_doc_adjustments.diff
index de01fc7e67689c25894c02f87b2cb7cd550fb67d..71424b07f7845f50977d5808bab7aa77fcf563db 100644 (file)
@@ -1,20 +1,27 @@
+Use links(1) to generate the HTML manual page
+
 --- a/doc/Makefile.am
 +++ b/doc/Makefile.am
 --- a/doc/Makefile.am
 +++ b/doc/Makefile.am
-@@ -81,13 +81,14 @@ uninstall-local:
+@@ -100,7 +100,8 @@
  
  check:
  manual.txt: manual.html
  
  check:
  manual.txt: manual.html
--      -lynx -dump -nolist -with_backspaces $^ > $@ || w3m -dump $^ > $@
-+      links.main -dump $^ > $@ || links -dump $^ > $@ || \
-+      lynx -dump -nolist -with_backspaces $^ > $@ || w3m -dump $^ > $@
+-      -LC_ALL=C lynx -dump -nolist -with_backspaces manual.html > $@ || \
++      links.main -dump $< > $@ || links -dump $< > $@ || \
++      LC_ALL=C lynx -dump -nolist -with_backspaces manual.html > $@ || \
+       LC_ALL=C w3m -dump manual.html > $@ || \
+       LC_ALL=C elinks -dump -no-numbering -no-references manual.html | sed -e 's,\\001, ,g' > $@
  
  
- manual.html: $(srcdir)/html.xsl stamp-doc-xml
+@@ -114,10 +115,10 @@
+       touch stamp-doc-rc
+ manual.html: $(srcdir)/html.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
 -      -xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
 +      xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
  
 -      -xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
 +      xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
  
- stamp-doc-chunked: $(srcdir)/chunk.xsl stamp-doc-xml
+ stamp-doc-chunked: $(srcdir)/chunk.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
 -      -xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
 +      xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
        touch stamp-doc-chunked
  
 -      -xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
 +      xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
        touch stamp-doc-chunked
  
- $(HTML_DOCFILES): stamp-doc-chunked
+ $(CHUNKED_DOCFILES): stamp-doc-chunked