]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/xtitles
removing patches that were applied usptream into 1.5.21
[software/mutt-debian.git] / debian / patches / features / xtitles
index 3a3922117b1ae0a4326b6fbd490d82b3deb5b636..dc9951ba5a8b486441d8192ff13a9fa061b24db9 100644 (file)
@@ -4,25 +4,21 @@ This is the xterm title patch as found on the mutt mailing lists.
 * Changes made:
   - 2007-01-27 myon: using %P caused a segfault, updated status.c to catch
     menu==NULL.
+  - 2007-02-20 myon: make the note about the xterm_set_titles defaults a
+    comment.
+  - 2008-08-02 myon: move set_xterm_* prototypes into the proper header file
+    (cleaner code, no functional change, evades conflict with sidebar patch)
 
 == END PATCH
-Index: mutt/PATCHES
-===================================================================
---- mutt.orig/PATCHES  2007-01-27 19:33:32.932962104 +0100
-+++ mutt/PATCHES       2007-01-27 19:33:32.932962104 +0100
-@@ -0,0 +1 @@
-+patch-1.5.13.nt+ab.xtitles.4
-Index: mutt/curs_main.c
-===================================================================
---- mutt.orig/curs_main.c      2006-12-12 14:15:02.000000000 +0100
-+++ mutt/curs_main.c   2007-01-27 19:33:32.933961952 +0100
-@@ -110,6 +110,19 @@ static const char *No_visible = N_("No v
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -110,6 +110,19 @@
  
  extern size_t UngetCount;
  
 +#define ASCII_CTRL_G                  0x07
 +#define ASCII_CTRL_OPEN_SQUARE_BRAKET 0x1b
-+ 
++
 +void set_xterm_title_bar(char *title)
 +{
 +  fprintf(stderr ,"%c]2;%s%c", ASCII_CTRL_OPEN_SQUARE_BRAKET, title, ASCII_CTRL_G);
@@ -36,7 +32,7 @@ Index: mutt/curs_main.c
  void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
  {
    format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
-@@ -568,6 +581,13 @@ int mutt_index_menu (void)
+@@ -562,6 +575,13 @@
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
        menu->redraw &= ~REDRAW_STATUS;
@@ -50,11 +46,9 @@ Index: mutt/curs_main.c
        }
  
        menu->redraw = 0;
-Index: mutt/globals.h
-===================================================================
---- mutt.orig/globals.h        2007-01-04 15:23:49.000000000 +0100
-+++ mutt/globals.h     2007-01-27 19:33:32.933961952 +0100
-@@ -137,6 +137,8 @@ WHERE char *Tempdir;
+--- a/globals.h
++++ b/globals.h
+@@ -141,6 +141,8 @@
  WHERE char *Tochars;
  WHERE char *Username;
  WHERE char *Visual;
@@ -63,11 +57,9 @@ Index: mutt/globals.h
  
  WHERE char *CurrentFolder;
  WHERE char *LastFolder;
-Index: mutt/init.c
-===================================================================
---- mutt.orig/init.c   2006-12-12 14:15:03.000000000 +0100
-+++ mutt/init.c        2007-01-27 19:33:32.934961800 +0100
-@@ -1747,6 +1747,26 @@ static int parse_set (BUFFER *tmp, BUFFE
+--- a/init.c
++++ b/init.c
+@@ -1873,6 +1873,26 @@
        toggle_option (MuttVars[idx].data);
        else
        set_option (MuttVars[idx].data);
@@ -94,13 +86,11 @@ Index: mutt/init.c
      }
      else if (myvar || DTYPE (MuttVars[idx].type) == DT_STR ||
             DTYPE (MuttVars[idx].type) == DT_PATH ||
-Index: mutt/init.h
-===================================================================
---- mutt.orig/init.h   2006-12-12 14:15:03.000000000 +0100
-+++ mutt/init.h        2007-01-27 19:33:32.936961496 +0100
-@@ -2941,6 +2941,27 @@ struct option_t MuttVars[] = {
-   ** Controls whether mutt writes out the Bcc header when preparing
-   ** messages to be sent.  Exim users may wish to unset this.
+--- a/init.h
++++ b/init.h
+@@ -3364,6 +3364,27 @@
+   ** Also see the $$read_inc, $$net_inc and $$time_inc variables and the
+   ** ``$tuning'' section of the manual for performance considerations.
    */
 +  {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
 +  /*
@@ -110,11 +100,11 @@ Index: mutt/init.h
 +  ** ``$$status_format''.
 +  */
 +  {"xterm_set_titles", DT_BOOL,  R_BOTH, OPTXTERMSETTITLES, 0},
++  /* The default must be off to force in the validity checking. */
 +  /*
 +  ** .pp
 +  ** Controls whether mutt sets the xterm title bar and icon name
-+  ** (as long as you're in an appropriate terminal). The default must
-+  ** be off to force in the validity checking.
++  ** (as long as you are in an appropriate terminal).
 +  */
 +  {"xterm_title",      DT_STR,   R_BOTH, UL &XtermTitle, UL "Mutt with %?m?%m messages&no messages?%?n? [%n NEW]?"},
 +  /*
@@ -124,35 +114,22 @@ Index: mutt/init.h
 +  ** to the one used by ``$$status_format''.
 +  */
    /*--*/
-   { NULL }
+   { NULL, 0, 0, 0, 0 }
  };
-Index: mutt/mutt.h
-===================================================================
---- mutt.orig/mutt.h   2007-01-04 15:23:49.000000000 +0100
-+++ mutt/mutt.h        2007-01-27 19:33:32.936961496 +0100
-@@ -451,6 +451,7 @@ enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -447,6 +447,7 @@
    OPTWRAPSEARCH,
    OPTWRITEBCC,                /* write out a bcc header? */
    OPTXMAILER,
 +  OPTXTERMSETTITLES,
  
    OPTCRYPTUSEGPGME,
-Index: mutt/pager.c
-===================================================================
---- mutt.orig/pager.c  2006-12-12 14:15:03.000000000 +0100
-+++ mutt/pager.c       2007-01-27 19:33:32.937961344 +0100
-@@ -30,6 +30,8 @@
- #include "pager.h"
- #include "attach.h"
- #include "mbyte.h"
-+void set_xterm_title_bar(char *title);
-+void set_xterm_icon_name(char *name);
- #include "mx.h"
-@@ -1765,6 +1767,13 @@ mutt_pager (const char *banner, const ch
-       addstr (topline == 0 ? "all)" : "end)");
+   OPTCRYPTUSEPKA,
+--- a/pager.c
++++ b/pager.c
+@@ -1812,6 +1812,13 @@
+       }
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
 +      if (option(OPTXTERMSETTITLES))
@@ -165,11 +142,9 @@ Index: mutt/pager.c
      }
  
      if ((redraw & REDRAW_INDEX) && index)
-Index: mutt/status.c
-===================================================================
---- mutt.orig/status.c 2007-01-27 19:33:36.429430560 +0100
-+++ mutt/status.c      2007-01-27 19:34:11.072164064 +0100
-@@ -191,6 +191,8 @@ status_format_str (char *buf, size_t buf
+--- a/status.c
++++ b/status.c
+@@ -195,6 +195,8 @@
        break;
  
      case 'P':
@@ -178,3 +153,14 @@ Index: mutt/status.c
        if (menu->top + menu->pagelen >= menu->max)
        cp = menu->top ? "end" : "all";
        else
+--- a/mutt_menu.h
++++ b/mutt_menu.h
+@@ -103,6 +103,8 @@
+ void menu_current_bottom (MUTTMENU *);
+ void menu_check_recenter (MUTTMENU *);
+ void menu_status_line (char *, size_t, MUTTMENU *, const char *);
++void set_xterm_title_bar (char *title);
++void set_xterm_icon_name (char *name);
+ MUTTMENU *mutt_new_menu (int);
+ void mutt_menuDestroy (MUTTMENU **);