]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
do not store the color in header cache (Closes: 545316), preserve the References...
[software/mutt-debian.git] / debian / rules
index 87fb63ce9831cc17f8f8590f04093266a0287f82..1b5641f63e6aa76d5f3214ace21c16a0fe81def6 100755 (executable)
@@ -14,7 +14,7 @@ HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
 ###
 # GPGME backend
-GPGME := --enable-gpgme
+GPGME := --enable-gpgme
 ###
 
 ###################### variables ######################
@@ -26,13 +26,13 @@ endif
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
-    hcache_db := --without-gdbm --without-qdbm
+    hcache_db := --without-gdbm --without-qdbm --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),gdbm)
-    hcache_db := --without-qdbm --without-bdb
+    hcache_db := --without-qdbm --without-bdb --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),qdbm)
-    hcache_db := --without-gdbm --without-bdb
+    hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
 endif
 
 confflags =    --prefix=/usr                   \
@@ -126,13 +126,12 @@ install: build
        ###################### install ######################
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
        rm -rf samples/iconv samples/ca-bundle.crt && \
        mv NEWS NEWS.old && \
-       mv ChangeLog.old changelog.old && \
        cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*