]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
Instead of trying to maintain the PATCHES file, put "quilt applied" output there.
[software/mutt-debian.git] / debian / rules
index 87fb63ce9831cc17f8f8590f04093266a0287f82..7db0d8fc32a793c8e39635d935c2616f7344e85e 100755 (executable)
@@ -1,6 +1,7 @@
 #!/usr/bin/make -f
 
 include /usr/share/quilt/quilt.make
 #!/usr/bin/make -f
 
 include /usr/share/quilt/quilt.make
+QUILT = QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null
 
 ###################### user serviceable parts ######################
 
 
 ###################### user serviceable parts ######################
 
@@ -10,11 +11,12 @@ BUILD_PATCHED := yes
 ###
 # header cache backend
 # HCACHE_DB := bdb
 ###
 # header cache backend
 # HCACHE_DB := bdb
-HCACHE_DB := gdbm
+HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
 # HCACHE_DB := qdbm
+HCACHE_DB := tokyocabinet
 ###
 # GPGME backend
 ###
 # GPGME backend
-GPGME := --enable-gpgme
+GPGME := --enable-gpgme
 ###
 
 ###################### variables ######################
 ###
 
 ###################### variables ######################
@@ -26,13 +28,16 @@ endif
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
-    hcache_db := --without-gdbm --without-qdbm
+    hcache_db := --without-gdbm --without-qdbm --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),gdbm)
 endif
 ifeq ($(HCACHE_DB),gdbm)
-    hcache_db := --without-qdbm --without-bdb
+    hcache_db := --without-qdbm --without-bdb --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),qdbm)
 endif
 ifeq ($(HCACHE_DB),qdbm)
-    hcache_db := --without-gdbm --without-bdb
+    hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
+endif
+ifeq ($(HCACHE_DB),tokyocabinet)
+    hcache_db := --without-gdbm --without-bdb --without-qdbm
 endif
 
 confflags =    --prefix=/usr                   \
 endif
 
 confflags =    --prefix=/usr                   \
@@ -92,6 +97,7 @@ $(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        
 ifeq ($(BUILD_PATCHED),yes)
        ###################### building mutt-patched ######################
        
 ifeq ($(BUILD_PATCHED),yes)
        ###################### building mutt-patched ######################
+       $(QUILT) applied > PATCHES
        autoreconf --install --include=m4
        cd $(objdir)-patched && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
        autoreconf --install --include=m4
        cd $(objdir)-patched && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
@@ -108,7 +114,8 @@ endif
 build build-arch: $(objdir)/build-stamp
 $(objdir)/build-stamp: $(objdir)-patched/build-stamp
        ###################### building mutt ######################
 build build-arch: $(objdir)/build-stamp
 $(objdir)/build-stamp: $(objdir)-patched/build-stamp
        ###################### building mutt ######################
-       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null pop mutt.org
+       $(QUILT) pop mutt.org
+       $(QUILT) applied > PATCHES
        
        autoreconf --install --include=m4
        -mkdir $(objdir)
        
        autoreconf --install --include=m4
        -mkdir $(objdir)
@@ -126,13 +133,12 @@ install: build
        ###################### install ######################
        dh_testdir
        dh_testroot
        ###################### install ######################
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
        rm -rf samples/iconv samples/ca-bundle.crt && \
        mv NEWS NEWS.old && \
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
        rm -rf samples/iconv samples/ca-bundle.crt && \
        mv NEWS NEWS.old && \
-       mv ChangeLog.old changelog.old && \
        cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*
        cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*
@@ -194,7 +200,7 @@ clean: unpatch
        
        # please dpkg-source
        rm -f po/*.gmo
        
        # please dpkg-source
        rm -f po/*.gmo
-       touch PATCHES
+       echo -n > PATCHES
        
        # remove build trees
        rm -rf $(objdir) $(objdir)-patched
        
        # remove build trees
        rm -rf $(objdir) $(objdir)-patched
@@ -203,9 +209,6 @@ clean: unpatch
        rm -f configure config.h.in
        rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
        
        rm -f configure config.h.in
        rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
        
-       # clean PATCHES hunks (blame quilt refresh)
-       for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
-       
        dh_clean
 
 .PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch
        dh_clean
 
 .PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch