]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
refreshed all patches up to mutt.org
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 274aec212d0a54c8e05c73646fa3b3024107bd19..a9de103ed633274ebebf49e8b229d0f3e1fdc37d 100644 (file)
@@ -551,7 +551,7 @@ The home page for this patch is:
 +void mutt_fast_close_compressed (CONTEXT *);
 --- a/configure.ac
 +++ b/configure.ac
-@@ -805,6 +805,11 @@
+@@ -812,6 +812,11 @@
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -565,7 +565,7 @@ The home page for this patch is:
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
 --- a/curs_main.c
 +++ b/curs_main.c
-@@ -1135,6 +1135,11 @@
+@@ -1153,6 +1153,11 @@
          {
          int check;
  
@@ -579,7 +579,7 @@ The home page for this patch is:
  
 --- a/doc/manual.xml.head
 +++ b/doc/manual.xml.head
-@@ -5678,6 +5678,205 @@
+@@ -6116,6 +6116,205 @@
  
  </chapter>
  
@@ -787,7 +787,7 @@ The home page for this patch is:
  
 --- a/doc/muttrc.man.head
 +++ b/doc/muttrc.man.head
-@@ -345,6 +345,24 @@
+@@ -346,6 +346,24 @@
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -844,7 +844,7 @@ The home page for this patch is:
        )
 --- a/init.h
 +++ b/init.h
-@@ -3504,6 +3504,11 @@
+@@ -3530,6 +3530,11 @@
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -853,12 +853,12 @@ The home page for this patch is:
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
+   { "group",          parse_group,            M_GROUP },
+   { "ungroup",                parse_group,            M_UNGROUP },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
 --- a/main.c
 +++ b/main.c
-@@ -402,6 +402,12 @@
+@@ -401,6 +401,12 @@
  #else
        "-LOCALES_HACK  "
  #endif
@@ -873,7 +873,7 @@ The home page for this patch is:
        "+HAVE_WC_FUNCS  "
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -18,7 +18,7 @@
+@@ -22,7 +22,7 @@
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
@@ -882,7 +882,7 @@ The home page for this patch is:
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -57,7 +57,7 @@
+@@ -61,7 +61,7 @@
        bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
@@ -904,7 +904,7 @@ The home page for this patch is:
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1048,6 +1052,12 @@
+@@ -1070,6 +1074,12 @@
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -931,7 +931,7 @@ The home page for this patch is:
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -882,6 +887,11 @@
+@@ -887,6 +892,11 @@
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
@@ -956,7 +956,7 @@ The home page for this patch is:
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -415,6 +419,10 @@
+@@ -414,6 +418,10 @@
      return (-1);
    }
  
@@ -967,7 +967,7 @@ The home page for this patch is:
    return (magic);
  }
  
-@@ -454,6 +462,13 @@
+@@ -453,6 +461,13 @@
  {
    struct stat sb;
  
@@ -981,7 +981,7 @@ The home page for this patch is:
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -617,7 +632,12 @@
+@@ -616,7 +631,12 @@
    }
  
    ctx->magic = mx_get_magic (path);
@@ -995,7 +995,7 @@ The home page for this patch is:
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -718,6 +738,10 @@
+@@ -721,6 +741,10 @@
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1006,7 +1006,7 @@ The home page for this patch is:
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -770,6 +794,12 @@
+@@ -773,6 +797,12 @@
    
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
@@ -1019,7 +1019,7 @@ The home page for this patch is:
    return rc;
  }
  
-@@ -1033,6 +1063,11 @@
+@@ -1043,6 +1073,11 @@
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1031,7 +1031,7 @@ The home page for this patch is:
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1355,6 +1390,11 @@
+@@ -1361,6 +1396,11 @@
  {
    int rc;
  
@@ -1045,55 +1045,49 @@ The home page for this patch is:
      if (ctx->locked) lock = 0;
 --- a/mx.h
 +++ b/mx.h
-@@ -40,6 +40,9 @@
- #ifdef USE_POP
-   , M_POP
- #endif
+@@ -36,6 +36,9 @@
+   M_MAILDIR,
+   M_IMAP,
+   M_POP
 +#ifdef USE_COMPRESSED
 +  , M_COMPRESSED
 +#endif
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -8,6 +8,7 @@
+ color.c
+ commands.c
+ compose.c
++compress.c
+ crypt-gpgme.c
+ crypt.c
+ cryptglue.c
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
+     case 'f':
+       snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
++#ifdef USE_COMPRESSED
++      if (Context && Context->compressinfo && Context->realpath)
++      {
++       strfcpy (tmp, Context->realpath, sizeof (tmp));
++       mutt_pretty_mailbox (tmp, sizeof (tmp));
++      }
++      else
++#endif
+       if (Context && Context->path)
+       {
+       strfcpy (tmp, Context->path, sizeof (tmp));
 --- a/po/de.po
 +++ b/po/de.po
-@@ -2005,6 +2005,10 @@
- msgid "Bad history file format (line %d)"
- msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
-+#: hook.c:96
-+msgid "badly formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:251
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -2766,7 +2770,7 @@
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
--#: mbox.c:678
-+#: mbox.c:678 compress.c:203 mbox.c:661
- msgid "Mailbox was corrupted!"
- msgstr "Mailbox wurde zerstört!"
-@@ -2774,10 +2778,11 @@
- msgid "Fatal error!  Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
+@@ -5159,6 +5159,36 @@
+ msgid "show S/MIME options"
+ msgstr "Zeige S/MIME Optionen"
  
--#: mbox.c:746
-+#: mbox.c:746 compress.c:264 compress.c:246 compress.c:367 compress.c:443 mbox.c:706
- msgid "Unable to lock mailbox!"
- msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-+
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted.  This should
- #. * never happen, is we presume it is a bug in mutt.
-@@ -5378,3 +5383,32 @@
- #~ msgid "Authentication method is unknown."
- #~ msgstr "Authentifizierungsmethode unbekannt."
 +
 +#: compress.c:228 compress.c:253
 +#, c-format
@@ -1123,30 +1117,7 @@ The home page for this patch is:
 +#, c-format
 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
---- a/po/POTFILES.in
-+++ b/po/POTFILES.in
-@@ -8,6 +8,7 @@
- color.c
- commands.c
- compose.c
-+compress.c
- crypt-gpgme.c
- crypt.c
- cryptglue.c
---- a/status.c
-+++ b/status.c
-@@ -96,6 +96,14 @@
++
+ #~ msgid "Clear"
+ #~ msgstr "Klartext"
  
-     case 'f':
-       snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
-+#ifdef USE_COMPRESSED
-+      if (Context && Context->compressinfo && Context->realpath)
-+      {
-+       strfcpy (tmp, Context->realpath, sizeof (tmp));
-+       mutt_pretty_mailbox (tmp, sizeof (tmp));
-+      }
-+      else
-+#endif
-       if (Context && Context->path)
-       {
-       strfcpy (tmp, Context->path, sizeof (tmp));