]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/imap_fast_trash
refreshed all patches up to mutt.org
[software/mutt-debian.git] / debian / patches / features / imap_fast_trash
index def2bc21ec43711cf21bc9cfe6557128b6d4f0e8..d40d169c1cf44293b8737ecd8e3b63ae4d006d31 100644 (file)
@@ -4,11 +4,9 @@ Make "move to trash folder" use IMAP COPY.
 
 by Paul Miller (jettero)
 
-diff --git a/imap/imap.c b/imap/imap.c
-index f08b4ea..47a8035 100644
 --- a/imap/imap.c
 +++ b/imap/imap.c
-@@ -2028,3 +2028,54 @@ int imap_complete(char* dest, size_t dlen, char* path) {
+@@ -2028,3 +2028,54 @@
  
    return -1;
  }
@@ -63,11 +61,9 @@ index f08b4ea..47a8035 100644
 +
 +    return 1;
 +}
-diff --git a/imap/imap.h b/imap/imap.h
-index 74d7e13..99cd454 100644
 --- a/imap/imap.h
 +++ b/imap/imap.h
-@@ -72,4 +72,7 @@ void imap_keepalive (void);
+@@ -72,4 +72,7 @@
  
  int imap_account_match (const ACCOUNT* a1, const ACCOUNT* a2);
  
@@ -75,11 +71,9 @@ index 74d7e13..99cd454 100644
 +int imap_fast_trash();
 +
  #endif
-diff --git a/mx.c b/mx.c
-index 78aafcc..38c4e7f 100644
 --- a/mx.c
 +++ b/mx.c
-@@ -828,6 +828,11 @@ static int trash_append (CONTEXT *ctx)
+@@ -802,6 +802,11 @@
        && stc.st_dev == st.st_dev && stc.st_rdev == st.st_rdev)
        return 0;  /* we are in the trash folder: simple sync */