]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/xtitles
refreshed all patches up to mutt.org
[software/mutt-debian.git] / debian / patches / features / xtitles
index b42acc15a708c00814c6d358b4d72cee371870e1..dc9951ba5a8b486441d8192ff13a9fa061b24db9 100644 (file)
@@ -10,10 +10,8 @@ This is the xterm title patch as found on the mutt mailing lists.
     (cleaner code, no functional change, evades conflict with sidebar patch)
 
 == END PATCH
-Index: mutt/curs_main.c
-===================================================================
---- mutt.orig/curs_main.c      2009-06-25 12:35:37.000000000 +0200
-+++ mutt/curs_main.c   2009-06-25 12:35:44.000000000 +0200
+--- a/curs_main.c
++++ b/curs_main.c
 @@ -110,6 +110,19 @@
  
  extern size_t UngetCount;
@@ -34,7 +32,7 @@ Index: mutt/curs_main.c
  void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
  {
    format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
-@@ -566,6 +579,13 @@
+@@ -562,6 +575,13 @@
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
        menu->redraw &= ~REDRAW_STATUS;
@@ -48,10 +46,8 @@ Index: mutt/curs_main.c
        }
  
        menu->redraw = 0;
-Index: mutt/globals.h
-===================================================================
---- mutt.orig/globals.h        2009-06-25 12:35:37.000000000 +0200
-+++ mutt/globals.h     2009-06-25 12:35:44.000000000 +0200
+--- a/globals.h
++++ b/globals.h
 @@ -141,6 +141,8 @@
  WHERE char *Tochars;
  WHERE char *Username;
@@ -61,11 +57,9 @@ Index: mutt/globals.h
  
  WHERE char *CurrentFolder;
  WHERE char *LastFolder;
-Index: mutt/init.c
-===================================================================
---- mutt.orig/init.c   2009-06-25 12:35:42.000000000 +0200
-+++ mutt/init.c        2009-06-25 12:35:44.000000000 +0200
-@@ -1892,6 +1892,26 @@
+--- a/init.c
++++ b/init.c
+@@ -1873,6 +1873,26 @@
        toggle_option (MuttVars[idx].data);
        else
        set_option (MuttVars[idx].data);
@@ -92,11 +86,9 @@ Index: mutt/init.c
      }
      else if (myvar || DTYPE (MuttVars[idx].type) == DT_STR ||
             DTYPE (MuttVars[idx].type) == DT_PATH ||
-Index: mutt/init.h
-===================================================================
---- mutt.orig/init.h   2009-06-25 12:35:42.000000000 +0200
-+++ mutt/init.h        2009-06-25 12:35:44.000000000 +0200
-@@ -3337,6 +3337,27 @@
+--- a/init.h
++++ b/init.h
+@@ -3364,6 +3364,27 @@
    ** Also see the $$read_inc, $$net_inc and $$time_inc variables and the
    ** ``$tuning'' section of the manual for performance considerations.
    */
@@ -124,11 +116,9 @@ Index: mutt/init.h
    /*--*/
    { NULL, 0, 0, 0, 0 }
  };
-Index: mutt/mutt.h
-===================================================================
---- mutt.orig/mutt.h   2009-06-25 12:35:37.000000000 +0200
-+++ mutt/mutt.h        2009-06-25 12:35:44.000000000 +0200
-@@ -446,6 +446,7 @@
+--- a/mutt.h
++++ b/mutt.h
+@@ -447,6 +447,7 @@
    OPTWRAPSEARCH,
    OPTWRITEBCC,                /* write out a bcc header? */
    OPTXMAILER,
@@ -136,11 +126,9 @@ Index: mutt/mutt.h
  
    OPTCRYPTUSEGPGME,
    OPTCRYPTUSEPKA,
-Index: mutt/pager.c
-===================================================================
---- mutt.orig/pager.c  2009-06-25 12:35:37.000000000 +0200
-+++ mutt/pager.c       2009-06-25 12:35:44.000000000 +0200
-@@ -1784,6 +1784,13 @@
+--- a/pager.c
++++ b/pager.c
+@@ -1812,6 +1812,13 @@
        }
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
@@ -154,10 +142,8 @@ Index: mutt/pager.c
      }
  
      if ((redraw & REDRAW_INDEX) && index)
-Index: mutt/status.c
-===================================================================
---- mutt.orig/status.c 2009-06-25 12:35:37.000000000 +0200
-+++ mutt/status.c      2009-06-25 12:35:44.000000000 +0200
+--- a/status.c
++++ b/status.c
 @@ -195,6 +195,8 @@
        break;
  
@@ -167,10 +153,8 @@ Index: mutt/status.c
        if (menu->top + menu->pagelen >= menu->max)
        cp = menu->top ? "end" : "all";
        else
-Index: mutt/mutt_menu.h
-===================================================================
---- mutt.orig/mutt_menu.h      2009-06-25 12:35:37.000000000 +0200
-+++ mutt/mutt_menu.h   2009-06-25 12:35:44.000000000 +0200
+--- a/mutt_menu.h
++++ b/mutt_menu.h
 @@ -103,6 +103,8 @@
  void menu_current_bottom (MUTTMENU *);
  void menu_check_recenter (MUTTMENU *);