I hope, it's usefull for someone ;)
-Index: mutt/sidebar.c
-===================================================================
---- mutt.orig/sidebar.c 2009-06-25 12:36:53.000000000 +0200
-+++ mutt/sidebar.c 2009-06-25 12:36:59.000000000 +0200
+--- a/sidebar.c
++++ b/sidebar.c
@@ -255,14 +255,23 @@
int i;
tmp_folder_name = tmp->path + strlen(Maildir);
for (i = 0; i < strlen(tmp->path) - strlen(Maildir); i++) {
- if (tmp_folder_name[i] == '/') sidebar_folder_depth++;
+ if (tmp_folder_name[i] == '/' || tmp_folder_name[i] == '.') sidebar_folder_depth++;
- }
+ }
if (sidebar_folder_depth > 0) {
- sidebar_folder_name = malloc(strlen(basename(tmp->path)) + sidebar_folder_depth + 1);
+ if (option(OPTSIDEBARSHORTPATH)) {
+ if (tmp_folder_name == NULL)
+ tmp_folder_name = tmp->path;
+ else
-+ tmp_folder_name++;
++ tmp_folder_name++;
+ }
+ else
+ tmp_folder_name = tmp->path;
}
}
printw( "%.*s", SidebarWidth - delim_len + 1,
-Index: mutt/init.h
-===================================================================
---- mutt.orig/init.h 2009-06-25 12:36:53.000000000 +0200
-+++ mutt/init.h 2009-06-25 12:36:59.000000000 +0200
-@@ -1969,6 +1969,11 @@
+--- a/init.h
++++ b/init.h
+@@ -1981,6 +1981,11 @@
** .pp
** The width of the sidebar.
*/
{ "pgp_use_gpg_agent", DT_BOOL, R_NONE, OPTUSEGPGAGENT, 0},
/*
** .pp
-Index: mutt/mutt.h
-===================================================================
---- mutt.orig/mutt.h 2009-06-25 12:36:53.000000000 +0200
-+++ mutt/mutt.h 2009-06-25 12:36:59.000000000 +0200
-@@ -426,6 +426,7 @@
+--- a/mutt.h
++++ b/mutt.h
+@@ -432,6 +432,7 @@
OPTSAVENAME,
OPTSCORE,
OPTSIDEBAR,