]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
incorporating fixes of http://bugs.mutt.org/3308 into the existing patch
[software/mutt-debian.git] / debian / rules
index 11eefc253b42fad44555b4834d23bb4a38044681..1b5641f63e6aa76d5f3214ace21c16a0fe81def6 100755 (executable)
@@ -2,6 +2,11 @@
 
 include /usr/share/quilt/quilt.make
 
+###################### user serviceable parts ######################
+
+###
+# build a separate mutt-patched package?
+BUILD_PATCHED := yes
 ###
 # header cache backend
 # HCACHE_DB := bdb
@@ -9,19 +14,25 @@ HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
 ###
 # GPGME backend
-GPGME := --enable-gpgme
+GPGME := --enable-gpgme
 ###
 
+###################### variables ######################
+
+ifneq ($(BUILD_PATCHED),yes)
+export DH_OPTIONS := -Nmutt-patched
+endif
+
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
-    hcache_db := --without-gdbm --without-qdbm
+    hcache_db := --without-gdbm --without-qdbm --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),gdbm)
-    hcache_db := --without-qdbm --without-bdb
+    hcache_db := --without-qdbm --without-bdb --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),qdbm)
-    hcache_db := --without-gdbm --without-bdb
+    hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
 endif
 
 confflags =    --prefix=/usr                   \
@@ -72,13 +83,16 @@ endif
 # Directory to make the build on
 objdir = $(CURDIR)/obj-$(DEB_HOST_GNU_TYPE)
 
+###################### main ######################
+
 $(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        dh_testdir
        dh_clean
+       -mkdir $(objdir)-patched
        
+ifeq ($(BUILD_PATCHED),yes)
        ###################### building mutt-patched ######################
        autoreconf --install --include=m4
-       -mkdir $(objdir)-patched
        cd $(objdir)-patched && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
        ../configure $(confflags)
@@ -87,6 +101,7 @@ $(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        
        # we should just "make mutt" here, but that doesn't work yet
        cd $(objdir)-patched && $(MAKE) CFLAGS="$(CFLAGS)"
+endif
        
        touch $@
 
@@ -111,13 +126,12 @@ install: build
        ###################### install ######################
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
        rm -rf samples/iconv samples/ca-bundle.crt && \
        mv NEWS NEWS.old && \
-       mv ChangeLog.old changelog.old && \
        cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*
@@ -132,8 +146,10 @@ install: build
          grep '^set' contrib/gpg.rc; \
          echo ) > debian/tmp/gpg.rc
        
+ifeq ($(BUILD_PATCHED),yes)
        # temporarily call the binary mutt-patched so dh_strip gets the debug file name right
        install -D $(objdir)-patched/mutt debian/mutt-patched/usr/bin/mutt-patched
+endif
        
        # reportbug driver
        dh_installdirs
@@ -154,7 +170,9 @@ binary binary-arch: install
        dh_strip --dbg-package=mutt-dbg
        rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg \
                $(CURDIR)/debian/mutt-patched/usr/share/doc/mutt-patched
+ifeq ($(BUILD_PATCHED),yes)
        mv debian/mutt-patched/usr/bin/mutt-patched debian/mutt-patched/usr/bin/mutt
+endif
        
        dh_link
        dh_compress --exclude usr/share/doc/mutt/README.Patches