]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar-sorted
sidebar-sorted: use strcoll() to sort the sidebar using the locale settings of the...
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-sorted
index 5bc262df7d06867bd29855e7f9b1be517d631e4e..c5211b8ff84c69dcdae5fe148960ce032ae17a7e 100644 (file)
@@ -26,7 +26,7 @@ should be easy to adopt it to a vanilla mutt.
 +                      needsort=0;
 +                      tmp = Incoming;
 +                      for ( ; tmp ; tmp=tmp->next ) {
-+                              if (tmp->next != NULL && strcmp(tmp->path, tmp->next->path) > 0) {
++                              if (tmp->next != NULL && strcoll(tmp->path, tmp->next->path) > 0) {
 +                                      needsort=1;
 +                                      prev = tmp->prev;
 +                                      next = tmp->next;
@@ -73,3 +73,15 @@ should be easy to adopt it to a vanilla mutt.
    OPTSIGDASHES,
    OPTSIGONTOP,
    OPTSORTRE,
+--- a/debian/extra/samples/sidebar.muttrc
++++ b/debian/extra/samples/sidebar.muttrc
+@@ -55,6 +55,9 @@
+ # When using IMAP, a '.' is often used as a separator. This option
+ # allows to shorten the folder name to the part after the last dot.
+ #
++# sidebar_sort (boolean)
++# Sorts the folders in the sidebar alphabetically.
++#
+ # color sidebar_new [fg] [bg]
+ # The foreground (fg) and background (bg) color of folders that contain new
+ # mail.