for (i = 0; i < strlen(tmp->path) - strlen(Maildir); i++) {
- if (tmp_folder_name[i] == '/') sidebar_folder_depth++;
+ if (tmp_folder_name[i] == '/' || tmp_folder_name[i] == '.') sidebar_folder_depth++;
- }
+ }
if (sidebar_folder_depth > 0) {
- sidebar_folder_name = malloc(strlen(basename(tmp->path)) + sidebar_folder_depth + 1);
+ if (option(OPTSIDEBARSHORTPATH)) {
+ if (tmp_folder_name == NULL)
+ tmp_folder_name = tmp->path;
+ else
-+ tmp_folder_name++;
++ tmp_folder_name++;
+ }
+ else
+ tmp_folder_name = tmp->path;
OPTSIGDASHES,
OPTSIGONTOP,
OPTSORTRE,
+--- a/debian/extra/samples/sidebar.muttrc
++++ b/debian/extra/samples/sidebar.muttrc
+@@ -50,7 +50,11 @@
+ #
+ # sidebar_delim (string)
+ # Specifies the delimiter between the sidebar and other screens
+-#
++#
++# sidebar_shortpath (boolean)
++# When using IMAP, a '.' is often used as a separator. This option
++# allows to shorten the folder name to the part after the last dot.
++#
+ # color sidebar_new [fg] [bg]
+ # The foreground (fg) and background (bg) color of folders that contain new
+ # mail.