]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar-dotted
sidebar: don't overwrite the status if status_on_top is enabled (Closes: 494735)
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-dotted
index 1649f0d4bb83cff9da7062710003ee2a40d6943a..070a0cb306db4cc2ceade35867679b91832078fa 100644 (file)
@@ -17,7 +17,7 @@ I hope, it's usefull for someone ;)
                        for (i = 0; i < strlen(tmp->path) - strlen(Maildir); i++) {
 -                              if (tmp_folder_name[i] == '/') sidebar_folder_depth++;
 +                              if (tmp_folder_name[i] == '/'  || tmp_folder_name[i] == '.') sidebar_folder_depth++;
-                       }
+                       }   
                        if (sidebar_folder_depth > 0) {
 -                              sidebar_folder_name = malloc(strlen(basename(tmp->path)) + sidebar_folder_depth + 1);
 +                              if (option(OPTSIDEBARSHORTPATH)) {
@@ -25,7 +25,7 @@ I hope, it's usefull for someone ;)
 +                                      if (tmp_folder_name == NULL)
 +                                              tmp_folder_name = tmp->path;
 +                                      else
-+                                              tmp_folder_name++;
++                                              tmp_folder_name++;
 +                              }
 +                              else
 +                                      tmp_folder_name = tmp->path;
@@ -62,3 +62,18 @@ I hope, it's usefull for someone ;)
    OPTSIGDASHES,
    OPTSIGONTOP,
    OPTSORTRE,
+--- a/debian/extra/samples/sidebar.muttrc
++++ b/debian/extra/samples/sidebar.muttrc
+@@ -50,7 +50,11 @@
+ # 
+ # sidebar_delim (string)
+ # Specifies the delimiter between the sidebar and other screens
+-# 
++#
++# sidebar_shortpath (boolean)
++# When using IMAP, a '.' is often used as a separator. This option
++# allows to shorten the folder name to the part after the last dot.
++#
+ # color sidebar_new [fg] [bg]
+ # The foreground (fg) and background (bg) color of folders that contain new
+ # mail.