]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar-dotted
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-dotted
index 1649f0d4bb83cff9da7062710003ee2a40d6943a..2900889cd2f54a7b37e9abd2592e555a585a2fdf 100644 (file)
@@ -17,7 +17,7 @@ I hope, it's usefull for someone ;)
                        for (i = 0; i < strlen(tmp->path) - strlen(Maildir); i++) {
 -                              if (tmp_folder_name[i] == '/') sidebar_folder_depth++;
 +                              if (tmp_folder_name[i] == '/'  || tmp_folder_name[i] == '.') sidebar_folder_depth++;
-                       }
+                       }   
                        if (sidebar_folder_depth > 0) {
 -                              sidebar_folder_name = malloc(strlen(basename(tmp->path)) + sidebar_folder_depth + 1);
 +                              if (option(OPTSIDEBARSHORTPATH)) {
@@ -25,7 +25,7 @@ I hope, it's usefull for someone ;)
 +                                      if (tmp_folder_name == NULL)
 +                                              tmp_folder_name = tmp->path;
 +                                      else
-+                                              tmp_folder_name++;
++                                              tmp_folder_name++;
 +                              }
 +                              else
 +                                      tmp_folder_name = tmp->path;