doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
- adjust the init.h hunk to the presence of group & ungroup
- 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
+ - 2006-08-16: adjust Makefile.am mutt-1.5.13
== END PATCH
---- /dev/null
-+++ compress.c
+Index: compress.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ compress.c 2007-03-01 22:30:00.101678680 +0100
@@ -0,0 +1,487 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+}
+
+#endif /* USE_COMPRESSED */
---- /dev/null
-+++ compress.h
+Index: compress.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ compress.h 2007-03-01 22:30:00.101678680 +0100
@@ -0,0 +1,27 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+int mutt_test_compress_command (const char *);
+int mutt_check_mailbox_compressed (CONTEXT *);
+void mutt_fast_close_compressed (CONTEXT *);
---- configure.in.orig
-+++ configure.in
-@@ -745,6 +745,11 @@
+Index: configure.in
+===================================================================
+--- configure.in.orig 2007-03-01 22:20:42.248485256 +0100
++++ configure.in 2007-03-01 22:30:00.102678528 +0100
+@@ -808,6 +808,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
[if test $withval != yes; then
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
---- curs_main.c.orig
-+++ curs_main.c
-@@ -1096,6 +1096,11 @@
+Index: curs_main.c
+===================================================================
+--- curs_main.c.orig 2007-03-01 22:08:47.806097008 +0100
++++ curs_main.c 2007-03-01 22:30:00.102678528 +0100
+@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
{
int check;
mutt_str_replace (&LastFolder, Context->path);
oldcount = Context ? Context->msgcount : 0;
---- doc/manual.xml.head.orig
-+++ doc/manual.xml.head
-@@ -4745,6 +4745,205 @@
+Index: doc/manual.xml.head
+===================================================================
+--- doc/manual.xml.head.orig 2007-03-01 22:08:47.852090016 +0100
++++ doc/manual.xml.head 2007-03-01 22:30:00.106677920 +0100
+@@ -4749,6 +4749,205 @@ becomes an issue as mutt will silently f
</sect1>
</chapter>
<chapter id="mimesupport">
---- doc/muttrc.man.head.orig
-+++ doc/muttrc.man.head
-@@ -316,6 +316,24 @@
+Index: doc/muttrc.man.head
+===================================================================
+--- doc/muttrc.man.head.orig 2007-03-01 22:08:47.900082720 +0100
++++ doc/muttrc.man.head 2007-03-01 22:30:00.106677920 +0100
+@@ -316,6 +316,24 @@ specify the ID of the public key to be u
to a certain recipient. The meaning of "key ID" is to be taken
broadly: This can be a different e-mail address, a numerical key ID,
or even just an arbitrary search string.
.TP
\fBpush\fP \fIstring\fP
This command adds the named \fIstring\fP to the keyboard buffer.
---- hook.c.orig
-+++ hook.c
+Index: hook.c
+===================================================================
+--- hook.c.orig 2007-03-01 22:08:47.947075576 +0100
++++ hook.c 2007-03-01 22:30:00.107677768 +0100
@@ -24,6 +24,10 @@
#include "mailbox.h"
#include "mutt_crypt.h"
#include <limits.h>
#include <string.h>
#include <stdlib.h>
-@@ -92,6 +96,16 @@
+@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
memset (&pattern, 0, sizeof (pattern));
pattern.data = safe_strdup (path);
}
else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
&& (!WithCrypto || !(data & M_CRYPTHOOK))
)
---- init.h.orig
-+++ init.h
-@@ -3108,6 +3108,11 @@
+Index: init.h
+===================================================================
+--- init.h.orig 2007-03-01 22:20:35.279544696 +0100
++++ init.h 2007-03-01 22:30:00.108677616 +0100
+@@ -3155,6 +3155,11 @@ struct command_t Commands[] = {
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
{ "group", parse_group, 0 },
{ "ungroup", parse_ungroup, 0 },
{ "hdr_order", parse_list, UL &HeaderOrderList },
#ifdef HAVE_ICONV
{ "iconv-hook", mutt_parse_hook, M_ICONVHOOK },
---- main.c.orig
-+++ main.c
-@@ -398,6 +398,12 @@
+Index: main.c
+===================================================================
+--- main.c.orig 2007-03-01 22:20:46.386856128 +0100
++++ main.c 2007-03-01 22:30:00.108677616 +0100
+@@ -404,6 +404,12 @@ static void show_version (void)
#else
"-LOCALES_HACK "
#endif
#ifdef HAVE_WC_FUNCS
"+HAVE_WC_FUNCS "
---- Makefile.am.orig
-+++ Makefile.am
-@@ -18,7 +18,7 @@
+Index: Makefile.am
+===================================================================
+--- Makefile.am.orig 2007-03-01 22:20:46.454845792 +0100
++++ Makefile.am 2007-03-01 22:30:00.108677616 +0100
+@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
mutt_SOURCES = $(BUILT_SOURCES) \
addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
-- crypt.c cryptglue.c \
-+ crypt.c cryptglue.c compress.c \
+- crypt.c cryptglue.c \
++ crypt.c cryptglue.c compress.c \
commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
edit.c enter.c flags.c init.c filter.c from.c \
getdomain.c group.c \
-@@ -68,7 +68,7 @@
- crypt-gpgme.c crypt-mod-pgp-gpgme.c crypt-mod-smime-gpgme.c
+@@ -67,7 +67,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+ utf8.c wcwidth.c
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
- configure account.h \
attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
---- mbox.c.orig
-+++ mbox.c
-@@ -28,6 +28,10 @@
- #include "sort.h"
+Index: mbox.c
+===================================================================
+--- mbox.c.orig 2007-03-01 22:08:48.131047608 +0100
++++ mbox.c 2007-03-01 22:30:00.109677464 +0100
+@@ -29,6 +29,10 @@
#include "copy.h"
+ #include "mutt_curses.h"
+#ifdef USE_COMPRESSED
+#include "compress.h"
#include <sys/stat.h>
#include <dirent.h>
#include <string.h>
-@@ -1014,6 +1018,12 @@
+@@ -1026,6 +1030,12 @@ bail: /* Come here in case of disaster
int mbox_close_mailbox (CONTEXT *ctx)
{
mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
mutt_unblock_signals ();
mx_fastclose_mailbox (ctx);
return 0;
---- mutt.h.orig
-+++ mutt.h
-@@ -157,6 +157,11 @@
+Index: mutt.h
+===================================================================
+--- mutt.h.orig 2007-03-01 22:20:43.625275952 +0100
++++ mutt.h 2007-03-01 22:30:00.109677464 +0100
+@@ -159,6 +159,11 @@ typedef enum
#define M_ACCOUNTHOOK (1<<9)
#define M_REPLYHOOK (1<<10)
#define M_SEND2HOOK (1<<11)
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -863,6 +868,11 @@
+@@ -882,6 +887,11 @@ typedef struct
void *data; /* driver specific data */
#endif /* USE_IMAP */
+
short magic; /* mailbox type */
- unsigned int locked : 1; /* is the mailbox locked? */
---- mx.c.orig
-+++ mx.c
+ unsigned char rights[(RIGHTSMAX + 7)/8]; /* ACL bits */
+Index: mx.c
+===================================================================
+--- mx.c.orig 2007-03-01 22:08:48.223033624 +0100
++++ mx.c 2007-03-01 22:30:00.110677312 +0100
@@ -30,6 +30,10 @@
#include "keymap.h"
#include "url.h"
#ifdef USE_IMAP
#include "imap.h"
#endif
-@@ -454,6 +458,10 @@
+@@ -454,6 +458,10 @@ int mx_get_magic (const char *path)
return (-1);
}
return (magic);
}
-@@ -493,6 +501,13 @@
+@@ -493,6 +501,13 @@ static int mx_open_mailbox_append (CONTE
{
struct stat sb;
ctx->append = 1;
#ifdef USE_IMAP
-@@ -653,7 +668,12 @@
+@@ -656,7 +671,12 @@ CONTEXT *mx_open_mailbox (const char *pa
}
ctx->magic = mx_get_magic (path);
if(ctx->magic == 0)
mutt_error (_("%s is not a mailbox."), path);
-@@ -759,6 +779,10 @@
+@@ -762,6 +782,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
mutt_free_header (&ctx->hdrs[i]);
FREE (&ctx->hdrs);
FREE (&ctx->v2r);
FREE (&ctx->path);
FREE (&ctx->pattern);
if (ctx->limit_pattern)
-@@ -816,6 +840,12 @@
+@@ -819,6 +843,12 @@ static int sync_mailbox (CONTEXT *ctx, i
if (tmp && tmp->new == 0)
mutt_update_mailbox (tmp);
#endif
return rc;
}
-@@ -1017,6 +1047,11 @@
+@@ -1020,6 +1050,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
!mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
mx_unlink_empty (ctx->path);
mx_fastclose_mailbox (ctx);
return 0;
-@@ -1326,6 +1361,11 @@
+@@ -1329,6 +1364,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
{
int rc;
if (ctx)
{
if (ctx->locked) lock = 0;
---- mx.h.orig
-+++ mx.h
-@@ -40,6 +40,9 @@
+Index: mx.h
+===================================================================
+--- mx.h.orig 2007-03-01 22:08:48.272026176 +0100
++++ mx.h 2007-03-01 22:30:00.110677312 +0100
+@@ -40,6 +40,9 @@ enum
#ifdef USE_POP
, M_POP
#endif
};
WHERE short DefaultMagic INITVAL (M_MBOX);
---- PATCHES.orig
-+++ PATCHES
-@@ -1,2 +1,3 @@
+Index: PATCHES
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ PATCHES 2007-03-01 22:30:00.110677312 +0100
+@@ -0,0 +1 @@
+patch-1.5.11.rr.compressed.1
- patch-1.5.6.tt.assumed_charset.1
- patch-1.5.6.dw.maildir-mtime.1
---- po/de.po.orig
-+++ po/de.po
-@@ -1262,6 +1262,48 @@
+Index: po/de.po
+===================================================================
+--- po/de.po.orig 2007-03-01 22:21:09.228383688 +0100
++++ po/de.po 2007-03-01 22:30:00.112677008 +0100
+@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
msgid "Failed to figure out sender"
msgstr "Kann Absender nicht ermitteln"
#: crypt.c:69
#, c-format
msgid " (current time: %c)"
-@@ -1910,6 +1952,10 @@
+@@ -1926,6 +1968,10 @@ msgstr ""
msgid "Help for %s"
msgstr "Hilfe für %s"
#: hook.c:246
#, c-format
msgid "unhook: Can't do unhook * from within a hook."
-@@ -3424,18 +3470,10 @@
+@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
msgid "Mailbox is corrupt!"
msgstr "Mailbox fehlerhaft!"
--#: mbox.c:662
+-#: mbox.c:670
-msgid "Mailbox was corrupted!"
-msgstr "Mailbox wurde zerstört!"
-
- #: mbox.c:701 mbox.c:952
+ #: mbox.c:711 mbox.c:964
msgid "Fatal error! Could not reopen mailbox!"
msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:710
+-#: mbox.c:720
-msgid "Unable to lock mailbox!"
-msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-
#. this means ctx->changed or ctx->deleted was set, but no
#. * messages were found to be changed or deleted. This should
#. * never happen, is we presume it is a bug in mutt.
---- po/POTFILES.in.orig
-+++ po/POTFILES.in
-@@ -8,6 +8,7 @@
+Index: po/POTFILES.in
+===================================================================
+--- po/POTFILES.in.orig 2007-03-01 22:20:56.152371544 +0100
++++ po/POTFILES.in 2007-03-01 22:30:00.112677008 +0100
+@@ -8,6 +8,7 @@ charset.c
color.c
commands.c
compose.c
crypt-gpgme.c
crypt.c
cryptglue.c
---- status.c.orig
-+++ status.c
-@@ -97,6 +97,14 @@
+Index: status.c
+===================================================================
+--- status.c.orig 2007-03-01 22:08:48.458997752 +0100
++++ status.c 2007-03-01 22:30:00.113676856 +0100
+@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
case 'f':
snprintf (fmt, sizeof(fmt), "%%%ss", prefix);