+Even if EDITOR is not set, mutt will always use /usr/bin/editor (which
+is set by update-alternatives), rather than falling back to vi
+
--- a/init.c
+++ b/init.c
-@@ -3070,7 +3070,7 @@ void mutt_init (int skip_sys_rc, LIST *c
+@@ -3115,7 +3115,7 @@
{
p = getenv ("EDITOR");
if (!p)
Visual = safe_strdup (p);
--- a/init.h
+++ b/init.h
-@@ -552,7 +552,7 @@ struct option_t MuttVars[] = {
+@@ -686,7 +686,7 @@
** .pp
** This variable specifies which editor is used by mutt.
- ** It defaults to the value of the VISUAL, or EDITOR, environment
-- ** variable, or to the string "vi" if neither of those are set.
-+ ** variable, or to the string "/usr/bin/editor" if neither of those are set.
+ ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment
+- ** variable, or to the string ``vi'' if neither of those are set.
++ ** variable, or to the string ``/usr/bin/editor'' if neither of those are set.
*/
{ "encode_from", DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
/*