]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/use_usr_bin_editor.diff
new upstream release, patches refreshed
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
index f6b6806aae0f84d80a6fed5a6f02c8c20d9a537d..5c51a580cb6d349b3d687dd97430383081c37b28 100644 (file)
@@ -1,6 +1,9 @@
+Even if EDITOR is not set, mutt will always use /usr/bin/editor (which 
+is set by update-alternatives), rather than falling back to vi
+
 --- a/init.c
 +++ b/init.c
-@@ -3070,7 +3070,7 @@ void mutt_init (int skip_sys_rc, LIST *c
+@@ -3115,7 +3115,7 @@
    {
      p = getenv ("EDITOR");
      if (!p)
    Visual = safe_strdup (p);
 --- a/init.h
 +++ b/init.h
-@@ -552,7 +552,7 @@ struct option_t MuttVars[] = {
+@@ -686,7 +686,7 @@
    ** .pp
    ** This variable specifies which editor is used by mutt.
-   ** It defaults to the value of the VISUAL, or EDITOR, environment
--  ** variable, or to the string "vi" if neither of those are set.
-+  ** variable, or to the string "/usr/bin/editor" if neither of those are set.
+   ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment
+-  ** variable, or to the string ``vi'' if neither of those are set.
++  ** variable, or to the string ``/usr/bin/editor'' if neither of those are set.
    */
    { "encode_from",    DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
    /*