+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
--- a/init.c
+++ b/init.c
-@@ -46,6 +46,7 @@
+@@ -47,6 +47,7 @@
#include <unistd.h>
#include <string.h>
#include <sys/utsname.h>
#include <errno.h>
#include <sys/wait.h>
-@@ -2911,6 +2912,31 @@ static int mutt_execute_commands (LIST *
+@@ -2952,6 +2953,31 @@
return 0;
}
void mutt_init (int skip_sys_rc, LIST *commands)
{
struct passwd *pw;
-@@ -2982,10 +3008,25 @@ void mutt_init (int skip_sys_rc, LIST *c
+@@ -3026,10 +3052,25 @@
Hostname = mutt_substrdup (utsname.nodename, p);
p++;
strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */