]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/use_usr_bin_editor.diff
Use upstream's smime.rc file, hereby fixing S/MIME encryption. (Closes: #315319)
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
index f6b6806aae0f84d80a6fed5a6f02c8c20d9a537d..13baea5395c9596fdc07131d79416ea9fa2b5152 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init.c
 +++ b/init.c
-@@ -3070,7 +3070,7 @@ void mutt_init (int skip_sys_rc, LIST *c
+@@ -3114,7 +3114,7 @@ void mutt_init (int skip_sys_rc, LIST *c
    {
      p = getenv ("EDITOR");
      if (!p)
    Visual = safe_strdup (p);
 --- a/init.h
 +++ b/init.h
-@@ -552,7 +552,7 @@ struct option_t MuttVars[] = {
+@@ -589,7 +589,7 @@ struct option_t MuttVars[] = {
    ** .pp
    ** This variable specifies which editor is used by mutt.
-   ** It defaults to the value of the VISUAL, or EDITOR, environment
--  ** variable, or to the string "vi" if neither of those are set.
-+  ** variable, or to the string "/usr/bin/editor" if neither of those are set.
+   ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment
+-  ** variable, or to the string ``vi'' if neither of those are set.
++  ** variable, or to the string ``/usr/bin/editor'' if neither of those are set.
    */
    { "encode_from",    DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
    /*