]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/upstream/393926-internal-viewer.patch
upstream/578087-header-strchr.patch: prevent from segfaulting on malformed messages...
[software/mutt-debian.git] / debian / patches / upstream / 393926-internal-viewer.patch
index 70c45754430cc5531037a24709ac8a041e03f64e..f97f42a450c450f282317bc4f963a304f94aa2f6 100644 (file)
@@ -1,19 +1,21 @@
-Display any text/* part with the internal viewer, see upstream bug
+Display text/x-diff with the internal viewer, see upstream bug
 http://bugs.mutt.org/3246
 
 --- a/muttlib.c
 +++ b/muttlib.c
 http://bugs.mutt.org/3246
 
 --- a/muttlib.c
 +++ b/muttlib.c
-@@ -622,11 +622,8 @@
+@@ -622,11 +622,11 @@
    switch (m->type)
    {
      case TYPETEXT:
 -
    switch (m->type)
    {
      case TYPETEXT:
 -
--      if (!ascii_strcasecmp ("plain", m->subtype) ||
+       if (!ascii_strcasecmp ("plain", m->subtype) ||
 -        !ascii_strcasecmp ("rfc822-headers", m->subtype) ||
 -        !ascii_strcasecmp ("enriched", m->subtype))
 -      return 0;
 -        !ascii_strcasecmp ("rfc822-headers", m->subtype) ||
 -        !ascii_strcasecmp ("enriched", m->subtype))
 -      return 0;
-+      /* we can display any text, overridable by auto_view */
-+      return 0;
++         !ascii_strcasecmp ("rfc822-headers", m->subtype) ||
++         !ascii_strcasecmp ("enriched", m->subtype) ||
++         !ascii_strcasecmp ("x-diff", m->subtype))
++       return 0;
        break;
  
      case TYPEAPPLICATION:
        break;
  
      case TYPEAPPLICATION: