- 2007-04-03 myon: resolved conflict in browser.c
== END PATCH
-Index: debian-mutt/buffy.c
-===================================================================
---- debian-mutt.orig/buffy.c 2007-04-03 19:17:22.000000000 +0200
-+++ debian-mutt/buffy.c 2007-04-03 19:20:31.000000000 +0200
-@@ -226,6 +226,7 @@ int mutt_parse_mailboxes (BUFFER *path,
+--- a/buffy.c
++++ b/buffy.c
+@@ -226,6 +226,7 @@
(*tmp)->new = 0;
(*tmp)->notified = 1;
(*tmp)->newly_created = 0;
/* for check_mbox_size, it is important that if the folder is new (tested by
* reading it), the size is set to 0 so that later when we check we see
-@@ -254,6 +255,7 @@ int mutt_buffy_check (int force)
+@@ -254,6 +255,7 @@
{
BUFFY *tmp;
struct stat sb;
struct dirent *de;
DIR *dirp;
char path[_POSIX_PATH_MAX];
-@@ -298,6 +300,7 @@ int mutt_buffy_check (int force)
+@@ -298,6 +300,7 @@
if (tmp->magic != M_IMAP)
#endif
tmp->new = 0;
#ifdef USE_IMAP
if (tmp->magic != M_IMAP)
-@@ -380,10 +383,20 @@ int mutt_buffy_check (int force)
+@@ -380,10 +383,20 @@
if (*de->d_name != '.' &&
(!(p = strstr (de->d_name, ":2,")) || !strchr (p + 3, 'T')))
{
}
}
closedir (dirp);
-Index: debian-mutt/init.h
-===================================================================
---- debian-mutt.orig/init.h 2007-04-03 19:20:27.000000000 +0200
-+++ debian-mutt/init.h 2007-04-03 19:20:31.000000000 +0200
-@@ -1086,6 +1086,16 @@ struct option_t MuttVars[] = {
+--- a/init.h
++++ b/init.h
+@@ -1185,6 +1185,16 @@
** \fBDON'T CHANGE THIS SETTING UNLESS YOU ARE REALLY SURE WHAT YOU ARE
** DOING!\fP
*/
#ifdef USE_HCACHE
{ "header_cache", DT_PATH, R_NONE, UL &HeaderCache, 0 },
/*
-Index: debian-mutt/mutt.h
-===================================================================
---- debian-mutt.orig/mutt.h 2007-04-03 19:20:27.000000000 +0200
-+++ debian-mutt/mutt.h 2007-04-03 19:20:31.000000000 +0200
-@@ -400,6 +400,7 @@ enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -375,6 +375,7 @@
OPTINCLUDEONLYFIRST,
OPTKEEPFLAGGED,
OPTMAILCAPSANITIZE,
OPTMAILDIRTRASH,
OPTMARKERS,
OPTMARKOLD,
-Index: debian-mutt/PATCHES
-===================================================================
---- debian-mutt.orig/PATCHES 2007-04-03 19:20:27.000000000 +0200
-+++ debian-mutt/PATCHES 2007-04-03 19:20:31.000000000 +0200
-@@ -1,2 +1,3 @@
-+patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2
- patch-1.5.14.rr.compressed.1
-Index: debian-mutt/browser.c
-===================================================================
---- debian-mutt.orig/browser.c 2007-04-03 19:20:17.000000000 +0200
-+++ debian-mutt/browser.c 2007-04-03 19:24:32.000000000 +0200
+--- a/browser.c
++++ b/browser.c
@@ -32,6 +32,7 @@
#ifdef USE_IMAP
#include "imap.h"
#include <stdlib.h>
#include <dirent.h>
-@@ -307,8 +308,10 @@ folder_format_str (char *dest, size_t de
+@@ -308,8 +309,10 @@
}
static void add_folder (MUTTMENU *m, struct browser_state *state,
if (state->entrylen == state->entrymax)
{
/* need to allocate more space */
-@@ -320,6 +323,9 @@ static void add_folder (MUTTMENU *m, str
+@@ -321,6 +324,9 @@
m->data = state->entry;
}
if (s != NULL)
{
(state->entry)[state->entrylen].mode = s->st_mode;
-@@ -414,7 +420,7 @@ static int examine_directory (MUTTMENU *
+@@ -415,7 +421,7 @@
tmp = Incoming;
while (tmp && mutt_strcmp (buffer, tmp->path))
tmp = tmp->next;
}
closedir (dp);
browser_sort (state);
-@@ -442,14 +448,15 @@ static int examine_mailboxes (MUTTMENU *
+@@ -443,14 +449,15 @@
if (mx_is_imap (tmp->path))
{
imap_mailbox_state (tmp->path, &mbox);
continue;
}
#endif
-@@ -463,7 +469,7 @@ static int examine_mailboxes (MUTTMENU *
+@@ -464,7 +471,7 @@
strfcpy (buffer, NONULL(tmp->path), sizeof (buffer));
- mutt_pretty_mailbox (buffer);
+ mutt_pretty_mailbox (buffer, sizeof (buffer));
- add_folder (menu, state, buffer, &s, tmp->new);
+ add_folder (menu, state, buffer, &s, tmp);
}
while ((tmp = tmp->next));
browser_sort (state);
-Index: debian-mutt/buffy.h
-===================================================================
---- debian-mutt.orig/buffy.h 2007-04-03 19:17:22.000000000 +0200
-+++ debian-mutt/buffy.h 2007-04-03 19:20:31.000000000 +0200
-@@ -25,6 +25,7 @@ typedef struct buffy_t
+--- a/buffy.h
++++ b/buffy.h
+@@ -25,6 +25,7 @@
char *path;
- long size;
+ off_t size;
struct buffy_t *next;
+ time_t mtime; /* for maildirs...time of newest entry */
short new; /* mailbox has new mail */
short notified; /* user has been notified */
short magic; /* mailbox type */
+--- a/PATCHES
++++ b/PATCHES
+@@ -1 +1,2 @@
++patch-1.5.6.dw.maildir-mtime.1
+ patch-1.5.13.cd.ifdef.2