]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/xtitles
adding a missing bug number
[software/mutt-debian.git] / debian / patches / features / xtitles
index 4309878d06991e1bc727ff18357d9fea3a9bc1e5..b42acc15a708c00814c6d358b4d72cee371870e1 100644 (file)
@@ -6,19 +6,15 @@ This is the xterm title patch as found on the mutt mailing lists.
     menu==NULL.
   - 2007-02-20 myon: make the note about the xterm_set_titles defaults a
     comment.
+  - 2008-08-02 myon: move set_xterm_* prototypes into the proper header file
+    (cleaner code, no functional change, evades conflict with sidebar patch)
 
 == END PATCH
-Index: mutt/PATCHES
-===================================================================
---- mutt/PATCHES.orig  2007-02-20 16:46:09.943601256 +0100
-+++ mutt/PATCHES       2007-02-20 16:46:09.943601256 +0100
-@@ -0,0 +1 @@
-+patch-1.5.13.nt+ab.xtitles.4
 Index: mutt/curs_main.c
 ===================================================================
---- mutt.orig/curs_main.c      2006-12-12 14:15:02.000000000 +0100
-+++ mutt/curs_main.c   2007-02-20 16:53:27.211126488 +0100
-@@ -110,6 +110,19 @@ static const char *No_visible = N_("No v
+--- mutt.orig/curs_main.c      2009-06-25 12:35:37.000000000 +0200
++++ mutt/curs_main.c   2009-06-25 12:35:44.000000000 +0200
+@@ -110,6 +110,19 @@
  
  extern size_t UngetCount;
  
@@ -38,7 +34,7 @@ Index: mutt/curs_main.c
  void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
  {
    format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
-@@ -568,6 +581,13 @@ int mutt_index_menu (void)
+@@ -566,6 +579,13 @@
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
        menu->redraw &= ~REDRAW_STATUS;
@@ -54,9 +50,9 @@ Index: mutt/curs_main.c
        menu->redraw = 0;
 Index: mutt/globals.h
 ===================================================================
---- mutt.orig/globals.h        2007-01-04 15:23:49.000000000 +0100
-+++ mutt/globals.h     2007-01-27 19:33:32.000000000 +0100
-@@ -137,6 +137,8 @@ WHERE char *Tempdir;
+--- mutt.orig/globals.h        2009-06-25 12:35:37.000000000 +0200
++++ mutt/globals.h     2009-06-25 12:35:44.000000000 +0200
+@@ -141,6 +141,8 @@
  WHERE char *Tochars;
  WHERE char *Username;
  WHERE char *Visual;
@@ -67,9 +63,9 @@ Index: mutt/globals.h
  WHERE char *LastFolder;
 Index: mutt/init.c
 ===================================================================
---- mutt.orig/init.c   2006-12-12 14:15:03.000000000 +0100
-+++ mutt/init.c        2007-01-27 19:33:32.000000000 +0100
-@@ -1747,6 +1747,26 @@ static int parse_set (BUFFER *tmp, BUFFE
+--- mutt.orig/init.c   2009-06-25 12:35:42.000000000 +0200
++++ mutt/init.c        2009-06-25 12:35:44.000000000 +0200
+@@ -1892,6 +1892,26 @@
        toggle_option (MuttVars[idx].data);
        else
        set_option (MuttVars[idx].data);
@@ -98,11 +94,11 @@ Index: mutt/init.c
             DTYPE (MuttVars[idx].type) == DT_PATH ||
 Index: mutt/init.h
 ===================================================================
---- mutt.orig/init.h   2006-12-12 14:15:03.000000000 +0100
-+++ mutt/init.h        2007-02-20 16:47:02.718578240 +0100
-@@ -2941,6 +2941,27 @@ struct option_t MuttVars[] = {
-   ** Controls whether mutt writes out the Bcc header when preparing
-   ** messages to be sent.  Exim users may wish to unset this.
+--- mutt.orig/init.h   2009-06-25 12:35:42.000000000 +0200
++++ mutt/init.h        2009-06-25 12:35:44.000000000 +0200
+@@ -3337,6 +3337,27 @@
+   ** Also see the $$read_inc, $$net_inc and $$time_inc variables and the
+   ** ``$tuning'' section of the manual for performance considerations.
    */
 +  {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
 +  /*
@@ -126,35 +122,26 @@ Index: mutt/init.h
 +  ** to the one used by ``$$status_format''.
 +  */
    /*--*/
-   { NULL }
+   { NULL, 0, 0, 0, 0 }
  };
 Index: mutt/mutt.h
 ===================================================================
---- mutt.orig/mutt.h   2007-01-04 15:23:49.000000000 +0100
-+++ mutt/mutt.h        2007-01-27 19:33:32.000000000 +0100
-@@ -451,6 +451,7 @@ enum
+--- mutt.orig/mutt.h   2009-06-25 12:35:37.000000000 +0200
++++ mutt/mutt.h        2009-06-25 12:35:44.000000000 +0200
+@@ -446,6 +446,7 @@
    OPTWRAPSEARCH,
    OPTWRITEBCC,                /* write out a bcc header? */
    OPTXMAILER,
 +  OPTXTERMSETTITLES,
  
    OPTCRYPTUSEGPGME,
+   OPTCRYPTUSEPKA,
 Index: mutt/pager.c
 ===================================================================
---- mutt.orig/pager.c  2006-12-12 14:15:03.000000000 +0100
-+++ mutt/pager.c       2007-01-27 19:33:32.000000000 +0100
-@@ -30,6 +30,8 @@
- #include "pager.h"
- #include "attach.h"
- #include "mbyte.h"
-+void set_xterm_title_bar(char *title);
-+void set_xterm_icon_name(char *name);
- #include "mx.h"
-@@ -1765,6 +1767,13 @@ mutt_pager (const char *banner, const ch
-       addstr (topline == 0 ? "all)" : "end)");
+--- mutt.orig/pager.c  2009-06-25 12:35:37.000000000 +0200
++++ mutt/pager.c       2009-06-25 12:35:44.000000000 +0200
+@@ -1784,6 +1784,13 @@
+       }
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
 +      if (option(OPTXTERMSETTITLES))
@@ -169,9 +156,9 @@ Index: mutt/pager.c
      if ((redraw & REDRAW_INDEX) && index)
 Index: mutt/status.c
 ===================================================================
---- mutt.orig/status.c 2007-01-27 19:33:36.000000000 +0100
-+++ mutt/status.c      2007-01-27 19:34:11.000000000 +0100
-@@ -191,6 +191,8 @@ status_format_str (char *buf, size_t buf
+--- mutt.orig/status.c 2009-06-25 12:35:37.000000000 +0200
++++ mutt/status.c      2009-06-25 12:35:44.000000000 +0200
+@@ -195,6 +195,8 @@
        break;
  
      case 'P':
@@ -180,3 +167,16 @@ Index: mutt/status.c
        if (menu->top + menu->pagelen >= menu->max)
        cp = menu->top ? "end" : "all";
        else
+Index: mutt/mutt_menu.h
+===================================================================
+--- mutt.orig/mutt_menu.h      2009-06-25 12:35:37.000000000 +0200
++++ mutt/mutt_menu.h   2009-06-25 12:35:44.000000000 +0200
+@@ -103,6 +103,8 @@
+ void menu_current_bottom (MUTTMENU *);
+ void menu_check_recenter (MUTTMENU *);
+ void menu_status_line (char *, size_t, MUTTMENU *, const char *);
++void set_xterm_title_bar (char *title);
++void set_xterm_icon_name (char *name);
+ MUTTMENU *mutt_new_menu (int);
+ void mutt_menuDestroy (MUTTMENU **);