- 2007-06-14 myon: remove hunks for Muttrc*
== END PATCH
-Index: debian-mutt/compress.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.c 2007-06-14 10:57:02.000000000 +0200
+--- /dev/null
++++ b/compress.c
@@ -0,0 +1,499 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+}
+
+#endif /* USE_COMPRESSED */
-Index: debian-mutt/compress.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.h 2007-06-14 10:57:02.000000000 +0200
+--- /dev/null
++++ b/compress.h
@@ -0,0 +1,27 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+int mutt_test_compress_command (const char *);
+int mutt_check_mailbox_compressed (CONTEXT *);
+void mutt_fast_close_compressed (CONTEXT *);
-Index: debian-mutt/config.h.in
-===================================================================
---- debian-mutt.orig/config.h.in 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/config.h.in 2007-06-14 10:57:02.000000000 +0200
-@@ -513,6 +513,9 @@
- /* Define to enable Sun mailtool attachments support. */
- #undef SUN_ATTACHMENT
-
-+/* Define to enable compressed mailboxes support */
-+#undef USE_COMPRESSED
-+
- /* Define to use dotlocking for mailboxes. */
- #undef USE_DOTLOCK
-
-Index: debian-mutt/configure
-===================================================================
---- debian-mutt.orig/configure 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/configure 2007-06-14 10:57:02.000000000 +0200
-@@ -1371,6 +1371,7 @@ Optional Features:
- --enable-hcache Enable header caching
- --disable-iconv Disable iconv support
- --disable-nls Do not use Native Language Support
-+ --enable-compressed Enable compressed folders support
-
- Optional Packages:
- --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
-@@ -15105,6 +15106,17 @@ _ACEOF
- fi
-
-
-+# Check whether --enable-compressed or --disable-compressed was given.
-+if test "${enable_compressed+set}" = set; then
-+ enableval="$enable_compressed"; if test x$enableval = xyes; then
-+
-+cat >>confdefs.h <<\_ACEOF
-+#define USE_COMPRESSED 1
-+_ACEOF
-+
-+ fi
-+fi
-+
-
- # Check whether --with-exec-shell was given.
- if test "${with_exec_shell+set}" = set; then
-Index: debian-mutt/configure.ac
-===================================================================
---- debian-mutt.orig/configure.ac 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/configure.ac 2007-06-14 10:57:02.000000000 +0200
-@@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- a/configure.ac
++++ b/configure.ac
+@@ -792,6 +792,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
[if test $withval != yes; then
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: debian-mutt/curs_main.c
-===================================================================
---- debian-mutt.orig/curs_main.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/curs_main.c 2007-06-14 10:57:02.000000000 +0200
-@@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1131,6 +1131,11 @@ int mutt_index_menu (void)
{
int check;
mutt_str_replace (&LastFolder, Context->path);
oldcount = Context ? Context->msgcount : 0;
-Index: debian-mutt/doc/manual.xml.head
-===================================================================
---- debian-mutt.orig/doc/manual.xml.head 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/doc/manual.xml.head 2007-06-14 10:57:02.000000000 +0200
-@@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -4676,6 +4676,205 @@ macro pager \cb |urlview\n
</chapter>
<chapter id="mimesupport">
<title>Mutt's MIME Support</title>
-Index: debian-mutt/doc/muttrc.man.head
-===================================================================
---- debian-mutt.orig/doc/muttrc.man.head 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/doc/muttrc.man.head 2007-06-14 10:57:02.000000000 +0200
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
@@ -345,6 +345,24 @@ specify the ID of the public key to be u
to a certain recipient. The meaning of "key ID" is to be taken
broadly: This can be a different e-mail address, a numerical key ID,
.TP
\fBpush\fP \fIstring\fP
This command adds the named \fIstring\fP to the keyboard buffer.
-Index: debian-mutt/hook.c
-===================================================================
---- debian-mutt.orig/hook.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/hook.c 2007-06-14 10:57:02.000000000 +0200
+--- a/hook.c
++++ b/hook.c
@@ -24,6 +24,10 @@
#include "mailbox.h"
#include "mutt_crypt.h"
else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
&& (!WithCrypto || !(data & M_CRYPTHOOK))
)
-Index: debian-mutt/init.h
-===================================================================
---- debian-mutt.orig/init.h 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/init.h 2007-06-14 10:57:02.000000000 +0200
-@@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
+--- a/init.h
++++ b/init.h
+@@ -3210,6 +3210,11 @@ struct command_t Commands[] = {
{ "fcc-hook", mutt_parse_hook, M_FCCHOOK },
{ "fcc-save-hook", mutt_parse_hook, M_FCCHOOK | M_SAVEHOOK },
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
{ "group", parse_group, 0 },
{ "ungroup", parse_ungroup, 0 },
{ "hdr_order", parse_list, UL &HeaderOrderList },
-Index: debian-mutt/main.c
-===================================================================
---- debian-mutt.orig/main.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/main.c 2007-06-14 10:57:02.000000000 +0200
-@@ -401,6 +401,12 @@ static void show_version (void)
+--- a/main.c
++++ b/main.c
+@@ -409,6 +409,12 @@ static void show_version (void)
#else
"-LOCALES_HACK "
#endif
#ifdef HAVE_WC_FUNCS
"+HAVE_WC_FUNCS "
-Index: debian-mutt/Makefile.am
-===================================================================
---- debian-mutt.orig/Makefile.am 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/Makefile.am 2007-06-14 10:57:02.000000000 +0200
+--- a/Makefile.am
++++ b/Makefile.am
@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
mutt_SOURCES = $(BUILT_SOURCES) \
commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
edit.c enter.c flags.c init.c filter.c from.c \
getdomain.c group.c \
-@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
- utf8.c wcwidth.c
-
- EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
-- configure account.h \
-+ configure account.h compress.h \
- attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
- globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
- mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: debian-mutt/Makefile.in
-===================================================================
---- debian-mutt.orig/Makefile.in 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/Makefile.in 2007-06-14 10:57:02.000000000 +0200
-@@ -74,7 +74,7 @@ am_mutt_OBJECTS = $(am__objects_1) addrb
- attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
- buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
- cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
-- compose.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
-+ compose.$(OBJEXT) compress.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
- curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
- enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
- filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
-@@ -302,7 +302,7 @@ bin_SCRIPTS = muttbug flea @SMIMEAUX_TAR
- BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h hcversion.h
- mutt_SOURCES = $(BUILT_SOURCES) \
- addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
-- crypt.c cryptglue.c \
-+ crypt.c cryptglue.c compress.c \
- commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
- edit.c enter.c flags.c init.c filter.c from.c \
- getdomain.c group.c \
-@@ -335,7 +335,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5.c mut
utf8.c wcwidth.c
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-@@ -507,6 +507,7 @@ distclean-compile:
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/commands.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/complete.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compose.Po@am__quote@
-+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/copy.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-gpgme.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-mod-pgp-classic.Po@am__quote@
-Index: debian-mutt/mbox.c
-===================================================================
---- debian-mutt.orig/mbox.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mbox.c 2007-06-14 10:57:02.000000000 +0200
+--- a/mbox.c
++++ b/mbox.c
@@ -29,6 +29,10 @@
#include "copy.h"
#include "mutt_curses.h"
mutt_unblock_signals ();
mx_fastclose_mailbox (ctx);
return 0;
-Index: debian-mutt/mutt.h
-===================================================================
---- debian-mutt.orig/mutt.h 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mutt.h 2007-06-14 10:57:02.000000000 +0200
+--- a/mutt.h
++++ b/mutt.h
@@ -160,6 +160,11 @@ typedef enum
#define M_ACCOUNTHOOK (1<<9)
#define M_REPLYHOOK (1<<10)
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -885,6 +890,11 @@ typedef struct _context
+@@ -892,6 +897,11 @@ typedef struct _context
int flagged; /* how many flagged messages */
int msgnotreadyet; /* which msg "new" in pager, -1 if none */
short magic; /* mailbox type */
unsigned char rights[(RIGHTSMAX + 7)/8]; /* ACL bits */
-Index: debian-mutt/mx.c
-===================================================================
---- debian-mutt.orig/mx.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mx.c 2007-06-14 10:57:02.000000000 +0200
+--- a/mx.c
++++ b/mx.c
@@ -30,6 +30,10 @@
#include "keymap.h"
#include "url.h"
#ifdef USE_IMAP
#include "imap.h"
#endif
-@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
+@@ -445,6 +449,10 @@ int mx_get_magic (const char *path)
return (-1);
}
return (magic);
}
-@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -484,6 +492,13 @@ static int mx_open_mailbox_append (CONTE
{
struct stat sb;
ctx->append = 1;
#ifdef USE_IMAP
-@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -647,7 +662,12 @@ CONTEXT *mx_open_mailbox (const char *pa
}
ctx->magic = mx_get_magic (path);
if(ctx->magic == 0)
mutt_error (_("%s is not a mailbox."), path);
-@@ -753,6 +773,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -748,6 +768,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
mutt_free_header (&ctx->hdrs[i]);
FREE (&ctx->hdrs);
FREE (&ctx->v2r);
FREE (&ctx->path);
FREE (&ctx->pattern);
if (ctx->limit_pattern)
-@@ -805,6 +829,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -800,6 +824,12 @@ static int sync_mailbox (CONTEXT *ctx, i
if (tmp && tmp->new == 0)
mutt_update_mailbox (tmp);
return rc;
}
-@@ -1006,6 +1036,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -1058,6 +1088,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
!mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
mx_unlink_empty (ctx->path);
mx_fastclose_mailbox (ctx);
return 0;
-@@ -1315,6 +1350,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
+@@ -1373,6 +1408,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
{
int rc;
if (ctx)
{
if (ctx->locked) lock = 0;
-Index: debian-mutt/mx.h
-===================================================================
---- debian-mutt.orig/mx.h 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mx.h 2007-06-14 10:57:02.000000000 +0200
+--- a/mx.h
++++ b/mx.h
@@ -40,6 +40,9 @@ enum
#ifdef USE_POP
, M_POP
};
WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: debian-mutt/PATCHES
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/PATCHES 2007-06-14 10:57:02.000000000 +0200
-@@ -0,0 +1 @@
-+patch-1.5.16.rr.compressed.1
-Index: debian-mutt/po/de.po
-===================================================================
---- debian-mutt.orig/po/de.po 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/po/de.po 2007-06-14 10:57:02.000000000 +0200
+--- a/po/de.po
++++ b/po/de.po
@@ -1279,6 +1279,48 @@ msgstr "Prüfung des Absenders fehlgeschl
msgid "Failed to figure out sender"
msgstr "Kann Absender nicht ermitteln"
#: hook.c:251
#, c-format
msgid "unhook: Can't do unhook * from within a hook."
-@@ -3452,18 +3498,10 @@ msgstr "Lese %s..."
+@@ -3463,18 +3509,10 @@ msgstr "Lese %s..."
msgid "Mailbox is corrupt!"
msgstr "Mailbox fehlerhaft!"
#. this means ctx->changed or ctx->deleted was set, but no
#. * messages were found to be changed or deleted. This should
#. * never happen, is we presume it is a bug in mutt.
-Index: debian-mutt/po/POTFILES.in
-===================================================================
---- debian-mutt.orig/po/POTFILES.in 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/po/POTFILES.in 2007-06-14 10:57:02.000000000 +0200
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
@@ -8,6 +8,7 @@ charset.c
color.c
commands.c
crypt-gpgme.c
crypt.c
cryptglue.c
-Index: debian-mutt/status.c
-===================================================================
---- debian-mutt.orig/status.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/status.c 2007-06-14 10:57:02.000000000 +0200
+--- a/status.c
++++ b/status.c
@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
case 'f':