]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/purge-message
Merge branch '1.5.20-1+fix533439-atime'
[software/mutt-debian.git] / debian / patches / features / purge-message
index d69ed549220f6743c740f394bebb71a510d27abd..a509e1df316bfe4eba90375f9f261a078827e740 100644 (file)
@@ -26,11 +26,9 @@ of having a trash folder feature.
   - Fixed indentation of "purged" in mutt.h.
 
 == END PATCH
   - Fixed indentation of "purged" in mutt.h.
 
 == END PATCH
-Index: trash/OPS
-===================================================================
---- trash.orig/OPS     2006-12-12 14:15:02.000000000 +0100
-+++ trash/OPS  2007-02-15 19:39:57.479112576 +0100
-@@ -140,6 +140,7 @@ OP_PREV_ENTRY "move to the previous entr
+--- a/OPS
++++ b/OPS
+@@ -141,6 +141,7 @@
  OP_PREV_LINE "scroll up one line"
  OP_PREV_PAGE "move to the previous page"
  OP_PRINT "print the current entry"
  OP_PREV_LINE "scroll up one line"
  OP_PREV_PAGE "move to the previous page"
  OP_PRINT "print the current entry"
@@ -38,11 +36,9 @@ Index: trash/OPS
  OP_QUERY "query external program for addresses"
  OP_QUERY_APPEND "append new query results to current results"
  OP_QUIT "save changes to mailbox and quit"
  OP_QUERY "query external program for addresses"
  OP_QUERY_APPEND "append new query results to current results"
  OP_QUIT "save changes to mailbox and quit"
-Index: trash/curs_main.c
-===================================================================
---- trash.orig/curs_main.c     2006-12-12 14:15:02.000000000 +0100
-+++ trash/curs_main.c  2007-02-15 19:39:57.480112424 +0100
-@@ -1778,6 +1778,7 @@ int mutt_index_menu (void)
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1823,6 +1823,7 @@
        MAYBE_REDRAW (menu->redraw);
        break;
  
        MAYBE_REDRAW (menu->redraw);
        break;
  
@@ -50,7 +46,7 @@ Index: trash/curs_main.c
        case OP_DELETE:
  
        CHECK_MSGCOUNT;
        case OP_DELETE:
  
        CHECK_MSGCOUNT;
-@@ -1788,6 +1789,7 @@ int mutt_index_menu (void)
+@@ -1833,6 +1834,7 @@
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 1);
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 1);
@@ -58,7 +54,7 @@ Index: trash/curs_main.c
          if (option (OPTDELETEUNTAG))
            mutt_tag_set_flag (M_TAG, 0);
          menu->redraw = REDRAW_INDEX;
          if (option (OPTDELETEUNTAG))
            mutt_tag_set_flag (M_TAG, 0);
          menu->redraw = REDRAW_INDEX;
-@@ -1795,6 +1797,8 @@ int mutt_index_menu (void)
+@@ -1840,6 +1842,8 @@
        else
        {
          mutt_set_flag (Context, CURHDR, M_DELETE, 1);
        else
        {
          mutt_set_flag (Context, CURHDR, M_DELETE, 1);
@@ -67,7 +63,7 @@ Index: trash/curs_main.c
          if (option (OPTDELETEUNTAG))
            mutt_set_flag (Context, CURHDR, M_TAG, 0);
          if (option (OPTRESOLVE))
          if (option (OPTDELETEUNTAG))
            mutt_set_flag (Context, CURHDR, M_TAG, 0);
          if (option (OPTRESOLVE))
-@@ -2088,11 +2092,13 @@ int mutt_index_menu (void)
+@@ -2136,11 +2140,13 @@
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 0);
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 0);
@@ -81,7 +77,7 @@ Index: trash/curs_main.c
          if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
          {
            menu->current++;
          if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
          {
            menu->current++;
-@@ -2113,9 +2119,11 @@ int mutt_index_menu (void)
+@@ -2161,9 +2167,11 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
@@ -95,11 +91,9 @@ Index: trash/curs_main.c
        {
          if (option (OPTRESOLVE))
          {
        {
          if (option (OPTRESOLVE))
          {
-Index: trash/flags.c
-===================================================================
---- trash.orig/flags.c 2007-02-15 19:38:00.433906152 +0100
-+++ trash/flags.c      2007-02-15 19:39:57.480112424 +0100
-@@ -105,6 +105,16 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+--- a/flags.c
++++ b/flags.c
+@@ -104,6 +104,16 @@
        }
        break;
  
        }
        break;
  
@@ -116,11 +110,9 @@ Index: trash/flags.c
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
-Index: trash/functions.h
-===================================================================
---- trash.orig/functions.h     2005-09-18 13:16:40.000000000 +0200
-+++ trash/functions.h  2007-02-15 19:39:57.481112272 +0100
-@@ -103,6 +103,7 @@ struct binding_t OpMain[] = {
+--- a/functions.h
++++ b/functions.h
+@@ -120,6 +120,7 @@
    { "toggle-write",           OP_TOGGLE_WRITE,                "%" },
    { "next-thread",            OP_MAIN_NEXT_THREAD,            "\016" },
    { "next-subthread",         OP_MAIN_NEXT_SUBTHREAD,         "\033n" },
    { "toggle-write",           OP_TOGGLE_WRITE,                "%" },
    { "next-thread",            OP_MAIN_NEXT_THREAD,            "\016" },
    { "next-subthread",         OP_MAIN_NEXT_SUBTHREAD,         "\033n" },
@@ -128,7 +120,7 @@ Index: trash/functions.h
    { "query",                  OP_QUERY,                       "Q" },
    { "quit",                   OP_QUIT,                        "q" },
    { "reply",                  OP_REPLY,                       "r" },
    { "query",                  OP_QUERY,                       "Q" },
    { "quit",                   OP_QUIT,                        "q" },
    { "reply",                  OP_REPLY,                       "r" },
-@@ -189,6 +190,7 @@ struct binding_t OpPager[] = {
+@@ -209,6 +210,7 @@
    { "print-message",  OP_PRINT,                       "p" },
    { "previous-thread",        OP_MAIN_PREV_THREAD,            "\020" },
    { "previous-subthread",OP_MAIN_PREV_SUBTHREAD,      "\033p" },
    { "print-message",  OP_PRINT,                       "p" },
    { "previous-thread",        OP_MAIN_PREV_THREAD,            "\020" },
    { "previous-subthread",OP_MAIN_PREV_SUBTHREAD,      "\033p" },
@@ -136,11 +128,9 @@ Index: trash/functions.h
    { "quit",           OP_QUIT,                        "Q" },
    { "exit",           OP_EXIT,                        "q" },
    { "reply",          OP_REPLY,                       "r" },
    { "quit",           OP_QUIT,                        "Q" },
    { "exit",           OP_EXIT,                        "q" },
    { "reply",          OP_REPLY,                       "r" },
-Index: trash/mutt.h
-===================================================================
---- trash.orig/mutt.h  2007-02-15 19:38:00.435905848 +0100
-+++ trash/mutt.h       2007-02-15 19:40:38.768835584 +0100
-@@ -201,6 +201,7 @@ enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -188,6 +188,7 @@
    M_UNDELETE,
    M_DELETED,
    M_APPENDED,
    M_UNDELETE,
    M_DELETED,
    M_APPENDED,
@@ -148,7 +138,7 @@ Index: trash/mutt.h
    M_FLAG,
    M_TAG,
    M_UNTAG,
    M_FLAG,
    M_TAG,
    M_UNTAG,
-@@ -705,6 +706,7 @@ typedef struct header
+@@ -705,6 +706,7 @@
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int appended : 1;          /* has been saved */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int appended : 1;          /* has been saved */
@@ -156,11 +146,9 @@ Index: trash/mutt.h
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
-Index: trash/mx.c
-===================================================================
---- trash.orig/mx.c    2007-02-15 19:38:00.436905696 +0100
-+++ trash/mx.c 2007-02-15 19:39:57.482112120 +0100
-@@ -852,6 +852,7 @@ static int trash_append (CONTEXT *ctx)
+--- a/mx.c
++++ b/mx.c
+@@ -803,6 +803,7 @@
      {
        for (i = 0 ; i < ctx->msgcount ; i++)
        if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
      {
        for (i = 0 ; i < ctx->msgcount ; i++)
        if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
@@ -168,11 +156,9 @@ Index: trash/mx.c
            && mutt_append_message (ctx_trash, ctx, ctx->hdrs[i], 0, 0) == -1)
          {
            mx_close_mailbox (ctx_trash, NULL);
            && mutt_append_message (ctx_trash, ctx, ctx->hdrs[i], 0, 0) == -1)
          {
            mx_close_mailbox (ctx_trash, NULL);
-Index: trash/pager.c
-===================================================================
---- trash.orig/pager.c 2006-12-12 14:15:03.000000000 +0100
-+++ trash/pager.c      2007-02-15 19:39:57.482112120 +0100
-@@ -2254,12 +2254,15 @@ search_next:
+--- a/pager.c
++++ b/pager.c
+@@ -2316,12 +2316,15 @@
        MAYBE_REDRAW (redraw);
        break;
  
        MAYBE_REDRAW (redraw);
        break;
  
@@ -188,7 +174,7 @@ Index: trash/pager.c
          if (option (OPTDELETEUNTAG))
          mutt_set_flag (Context, extra->hdr, M_TAG, 0);
        redraw = REDRAW_STATUS | REDRAW_INDEX;
          if (option (OPTDELETEUNTAG))
          mutt_set_flag (Context, extra->hdr, M_TAG, 0);
        redraw = REDRAW_STATUS | REDRAW_INDEX;
-@@ -2572,6 +2575,7 @@ search_next:
+@@ -2648,6 +2651,7 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message"));
  
        mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
        CHECK_ACL(M_ACL_DELETE, _("undelete message"));
  
        mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
@@ -196,7 +182,7 @@ Index: trash/pager.c
        redraw = REDRAW_STATUS | REDRAW_INDEX;
        if (option (OPTRESOLVE))
        {
        redraw = REDRAW_STATUS | REDRAW_INDEX;
        if (option (OPTRESOLVE))
        {
-@@ -2587,9 +2591,11 @@ search_next:
+@@ -2663,9 +2667,11 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
@@ -209,11 +195,9 @@ Index: trash/pager.c
        {
          if (option (OPTRESOLVE))
          {
        {
          if (option (OPTRESOLVE))
          {
-Index: trash/pattern.c
-===================================================================
---- trash.orig/pattern.c       2007-01-25 21:44:41.000000000 +0100
-+++ trash/pattern.c    2007-02-15 19:39:57.483111968 +0100
-@@ -1338,8 +1338,10 @@ int mutt_pattern_func (int op, char *pro
+--- a/pattern.c
++++ b/pattern.c
+@@ -1347,8 +1347,10 @@
        {
        switch (op)
        {
        {
        switch (op)
        {
@@ -225,10 +209,3 @@ Index: trash/pattern.c
            mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE, 
                          (op == M_DELETE));
            break;
            mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE, 
                          (op == M_DELETE));
            break;
-Index: trash/PATCHES
-===================================================================
---- trash.orig/PATCHES 2007-02-15 19:38:00.437905544 +0100
-+++ trash/PATCHES      2007-02-15 19:41:01.724345816 +0100
-@@ -1 +1,2 @@
- patch-1.5.13.cd.trash_folder.3.4
-+patch-1.5.13.cd.purge_message.3.4